概要

EIGRPのネイバー認証とスタブの設定について、設定ミスの切り分けと修正を行います。

ネットワーク構成

下記のネットワーク構成でEIGRPを利用してルーティングを行なっています。

図 EIGRP 設定ミスの切り分けと修正 Part2 ネットワーク構成
図 EIGRP 設定ミスの切り分けと修正 Part2 ネットワーク構成

なお、ホストはルータのLoopback0インタフェースとしています。

設定概要

現在のR1~R3のEIGRPに関する設定は以下のとおりです。これらの設定には一部設定ミスがあります。

R1

key chain EIGRP
 key 1
   key-string cisco
!
interface Loopback0
 ip address 192.168.1.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.168.12.1 255.255.255.0
 ip authentication mode eigrp 1 md5
 ip authentication key-chain eigrp 1 EIGRP
!
!
router eigrp 1
 network 192.168.0.0 0.0.255.255
 auto-summary

R2

key chain EIGRP
 key 1
   key-string EIGRP
!
interface FastEthernet0/0
 ip address 192.168.12.2 255.255.255.0
 ip authentication mode eigrp 1 md5
!
interface FastEthernet1/0
 ip address 192.168.23.2 255.255.255.0
!
router eigrp 1
 network 192.168.0.0 0.0.255.255
 auto-summary

R3

interface Loopback0
 ip address 192.168.3.3 255.255.255.0
!
interface FastEthernet1/0
 ip address 192.168.23.3 255.255.255.0
!
router eigrp 1
 network 192.168.0.0 0.0.255.255
 auto-summary
 eigrp stub receive-only

トラブルの症状

EIGRPでルート情報を正しく学習することができずに、ホスト間の通信ができていません。原因を調べるために以下のshowコマンドを実行しました。

  • show ip eigrp interface detail
  • show ip eigrp neighbor detail

R1

R1#show ip eigrp interface detail
IP-EIGRP interfaces for process 1
                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Fa0/0              0        0/0         0       0/1           50           0
  Hello interval is 5 sec
  Next xmit serial 
  Un/reliable mcasts: 0/1  Un/reliable ucasts: 3/5
  Mcast exceptions: 1  CR packets: 1  ACKs suppressed: 0
  Retransmissions sent: 3  Out-of-sequence rcvd: 0
  Authentication mode is md5,  key-chain is "EIGRP"
  Use multicast
Lo0                0        0/0         0       0/1            0           0
  Hello interval is 5 sec
  Next xmit serial 
  Un/reliable mcasts: 0/0  Un/reliable ucasts: 0/0
  Mcast exceptions: 0  CR packets: 0  ACKs suppressed: 0
  Retransmissions sent: 0  Out-of-sequence rcvd: 0
  Authentication mode is not set
  Use multicast
R1#show ip eigrp neighbor detail
IP-EIGRP neighbors for process 1

R2

R2#show ip eigrp interface detail
IP-EIGRP interfaces for process 1
                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Fa0/0              0        0/0         0       0/1           50           0
  Hello interval is 5 sec
  Next xmit serial 
  Un/reliable mcasts: 0/4  Un/reliable ucasts: 4/7
  Mcast exceptions: 3  CR packets: 2  ACKs suppressed: 0
  Retransmissions sent: 3  Out-of-sequence rcvd: 0
  Authentication mode is md5,  key-chain is not set
  Use multicast
Fa1/0              1        0/0        25       0/1          104           0
  Hello interval is 5 sec
  Next xmit serial 
  Un/reliable mcasts: 0/4  Un/reliable ucasts: 3/8
  Mcast exceptions: 2  CR packets: 2  ACKs suppressed: 0
  Retransmissions sent: 1  Out-of-sequence rcvd: 0
  Interface has all stub peers
  Authentication mode is not set
  Use multicast
R2#show ip eigrp neighbor detail
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
1   192.168.23.3            Fa1/0             13 00:37:59   25   200  0  9
   Version 12.4/1.2, Retrans: 0, Retries: 0
   Receive-Only Peer Advertising ( No ) Routes
   Suppressing queries

R3

R3#show ip eigrp interface detail
IP-EIGRP interfaces for process 1
                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Fa1/0              1        0/0        37       0/1          168           0
  Hello interval is 5 sec
  Next xmit serial 
  Un/reliable mcasts: 0/3  Un/reliable ucasts: 8/6
  Mcast exceptions: 3  CR packets: 2  ACKs suppressed: 1
  Retransmissions sent: 1  Out-of-sequence rcvd: 0
  Authentication mode is not set
  Use multicast
Lo0                0        0/0         0       0/1            0           0
  Hello interval is 5 sec
  Next xmit serial 
  Un/reliable mcasts: 0/0  Un/reliable ucasts: 0/0
  Mcast exceptions: 0  CR packets: 0  ACKs suppressed: 0
  Retransmissions sent: 0  Out-of-sequence rcvd: 0
  Authentication mode is not set
  Use multicast
R3#show ip eigrp neighbor detail
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   192.168.23.2            Fa1/0             14 00:38:20   37   222  0  15
   Version 12.4/1.2, Retrans: 1, Retries: 0, Prefixes: 1

問題

  • なぜホスト間の通信ができないのですか。
  • ホスト間の通信ができるようにするためには、どのように設定を修正すればよいですか。

解答

なぜホスト間の通信ができないのですか。

R1-R2間のEIGRPネイバー認証ができずに、ネイバーを確立していない。そのため、Host1へルーティングするためのルートを学習できない。

R3のEIGRPスタブの設定でrecieve-onlyとなっているため、R3はHost2のルートをアドバタイズしない。

ホスト間の通信ができるようにするためには、どのように設定を修正すればよいですか。

R2

key chain EIGRP
 key 1
  key-string cisco

interface FastEthernet0/0
 ip authentication key-chain eigrp 1 EIGRP

R3

router eigrp 1
 eigrp stub connected

ワンポイント

  • EIGRPネイバー認証の認証キーはキーチェインで設定する
  • EIGRPスタブのネイバーへはクエリーを送信しない
  • EIGRPスタブのオプションで、アドバタイズするルートを制御できる

解説

基本的なEIGRPの設定についての問題です。以下の2つの設定ミスがあります。

  • R1-R2間のEIGRPネイバー認証
  • R3 EIGRPスタブのオプション

【R1-R2間のEIGRPネイバー認証】

R1-R2間でネイバー認証を行なっています。EIGRPでのネイバー認証の設定は、次の2つ行います。

  • ネイバー認証の有効化
  • 認証キーの設定

ネイバー認証の有効化は、インタフェースコンフィグレーションモードで次のコマンドを入力します。

EIGRPネイバー認証の有効化

(config-if)#ip authentication mode eigrp < AS > md5

< AS > : AS番号

そして、認証キーの設定は以下のコマンドでキーチェインを作成します。

キーチェインの作成

(config)#key chain < key-chain-name >
(config-keychain)#key < id >
(config-keychain-key)#key-string < password >

< key-chain-name > : キーチェイン名
< id > : キーID
< password > : 認証パスワード

そして、作成したキーチェインをネイバー認証を有効化したインタフェースに関連付けます。

キーチェインの関連付け

(config-if)#ip authentication key-chain eigrp < AS > < key-chain-name >

< AS > : AS番号
< key-chain-name > : 関連付けるキーチェイン名

R1では、ネイバー認証の有効化と認証キーの設定が行われています。ですが、R2では認証キーの設定が行われていません。そのため、R1-R2間でネイバーを確立できずに、Host1のルートを学習することもできません。R2で認証キーを以下のように、認証キーの設定を正しく行います。

R2

key chain EIGRP
 key 1
  key-string cisco

interface FastEthernet0/0
 ip authentication key-chain eigrp 1 EIGRP

その後、R2でネイバーおよびルーティングテーブルを確認すると、次のようになります。

R2

R2#show ip eigrp neighbors 
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
1   192.168.12.1            Fa0/0             11 00:00:31 1038  5000  0  4
0   192.168.23.3            Fa1/0             13 01:09:38   49   294  0  3
R2#show ip route eigrp 
D    192.168.1.0/24 [90/156160] via 192.168.12.1, 00:00:31, FastEthernet0/0

【R3 EIGRPスタブのオプション】

R3をスタブとして設定して、R2はR3へクエリーを送信しないようにしています。しかし、R3でスタブのオプションとしてrecieve-onlyが指定されています。R2でshow ip eigrp neighbor detailを見ると、recieve-onlyとなっていることがわかります。

R2

R2#show ip eigrp neighbors detail 
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
1   192.168.12.1            Fa0/0             13 00:09:56 1038  5000  0  4
   Version 12.4/1.2, Retrans: 0, Retries: 0, Prefixes: 1
0   192.168.23.3            Fa1/0             10 01:19:04   49   294  0  3
   Version 12.4/1.2, Retrans: 1, Retries: 0
   Receive-Only Peer Advertising ( No ) Routes
   Suppressing queries

そのため、R3はHost2のルート 192.168.3.0/24 をR2へアドバタイズしていません。その結果、Host1とHost3間の通信ができません。Host2はR3に直接接続されています。そこでR3では、EIGRPスタブのオプションをconnectedで指定します。

R3

router eigrp 1
 eigrp stub connected

R3でHost2のルートをアドバタイズするようになれば、Host1とHost2間の通信ができるようになります。Host1からHost2へのPingを実行すると、次のようになります。

R1

R1#ping 192.168.3.3 source 192.168.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.3.3, timeout is 2 seconds:
Packet sent with a source address of 192.168.1.1 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/12/20 ms

【設定ミスのまとめ】

次の図は、設定ミスをまとめたものです。

図 EIGRP 設定ミスの切り分けと修正 Part2 設定ミスのまとめ
図 EIGRP 設定ミスの切り分けと修正 Part2 設定ミスのまとめ


関連記事