概要

EIGRPによる基本的なルーティングを行う演習です。条件に基づいて設定していますが、設定ミスがあります。設定ミスの切り分けと修正を行います。

ネットワーク構成

図 EIGRP ネットワーク構成
図 EIGRP ネットワーク構成

設定条件

  1. 図 EIGRPネットワーク構成の通りに各ルータでEIGRPの設定を行なってください。なお、フレームリレーにはブロードキャスト/マルチキャストパケットを送信できないようにしています。また、インタフェースに設定されているIPアドレスのサブネットマスクでルートをアドバタイズできるようにします。
  2. フレームリレーのインタフェースでは、EIGRPパケットが利用する帯域幅が25%になるようにしてください。また、ネイバーの障害検出を10秒以内にできるようにしてください。
  3. フレームリレー上でMD5のネイバー認証を行います。パスワードは任意の文字列で設定してください。
  4. R3はR6にEIGRPクエリーを送信しないようにしてください。
  5. R4でデフォルトルートをEIGRPでアドバタイズし、インターネットにアクセスできるようにします。
  6. ネットワーク構成上のすべてのIPアドレスに接続性があることを確認してください。

初期設定

条件に基づいてEIGRPの設定を行っています。しかし、5つの設定ミスが含まれています。設定ミスによるトラブルの症状は次のとおりです。

  1. R1-R2間のネイバーを確立できません。
  2. R2-R5間のネイバーを確立できません。
  3. フレームリレー上でEIGRPルートを正しく送受信できていません。
  4. R6のLoopback0のIPアドレスへの通信ができません。
  5. インターネットへの通信ができません。

R1 Initical Configuration(Click)

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
key chain EIGRP
 key 1
   key-string cisco
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface Loopback0
 ip address 192.168.0.1 255.255.255.255
!
interface Serial0/0
 ip address 192.168.123.1 255.255.255.0
 ip bandwidth-percent eigrp 1 25
 ip hello-interval eigrp 1 3
 ip hold-time eigrp 1 10
 ip authentication mode eigrp 1 md5
 ip authentication key-chain eigrp 1 EIGRP
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map ip 192.168.123.3 130
 no frame-relay inverse-arp
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Ethernet1/0
 ip address 192.168.14.1 255.255.255.0
 half-duplex
!
interface Ethernet1/1
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/3
 no ip address
 shutdown
 half-duplex
!
router eigrp 1
 network 192.168.0.0
 network 192.168.14.0
 network 192.168.123.0
 no auto-summary
 neighbor 192.168.123.3 Serial0/0
 neighbor 192.168.123.2 Serial0/0
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R2 Initical Configuration(Click)

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
key chain EIGRP
 key 1
   key-string cisco
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface Loopback0
 ip address 192.168.0.2 255.255.255.255
!
interface Serial0/0
 ip address 192.168.123.2 255.255.255.0
 ip bandwidth-percent eigrp 1 25
 ip hello-interval eigrp 1 3
 ip hold-time eigrp 1 10
 ip authentication mode eigrp 1 md5
 ip authentication key-chain eigrp 1 EIGRP
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map ip 192.168.123.1 210
 frame-relay map ip 192.168.123.3 210
 no frame-relay inverse-arp
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Ethernet1/0
 ip address 192.168.25.2 255.255.255.0
 half-duplex
!
interface Ethernet1/1
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/3
 no ip address
 shutdown
 half-duplex
!
router eigrp 1
 network 192.168.0.0
 network 192.168.25.0
 network 192.168.123.0
 no auto-summary
 neighbor 192.168.123.1 Serial0/0
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R3 Initical Configuration(Click)

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
key chain EIGRP
 key 1
   key-string cisco
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface Loopback0
 ip address 192.168.0.3 255.255.255.255
!
interface Serial0/0
 ip address 192.168.123.3 255.255.255.0
 ip bandwidth-percent eigrp 1 25
 ip hello-interval eigrp 1 3
 ip hold-time eigrp 1 10
 ip authentication mode eigrp 1 md5
 ip authentication key-chain eigrp 1 EIGRP
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map ip 192.168.123.1 310
 frame-relay map ip 192.168.123.2 310
 no frame-relay inverse-arp
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Ethernet1/0
 ip address 192.168.36.3 255.255.255.0
 half-duplex
!
interface Ethernet1/1
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/3
 no ip address
 shutdown
 half-duplex
!
router eigrp 1
 network 192.168.0.0
 network 192.168.36.0
 network 192.168.123.0
 no auto-summary
 neighbor 192.168.123.1 Serial0/0
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R4 Initical Configuration(Click)

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface Loopback0
 ip address 192.168.0.4 255.255.255.255
!
interface Serial0/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Ethernet1/0
 ip address 192.168.14.4 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 half-duplex
!
interface Ethernet1/1
 ip address 100.0.0.4 255.255.255.0
 ip nat outside
 ip virtual-reassembly
 half-duplex
!
interface Ethernet1/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/3
 no ip address
 shutdown
 half-duplex
!
router eigrp 1
 redistribute static
 network 192.168.0.0
 network 192.168.4.0
 no auto-summary
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 100.0.0.10
!
ip nat inside source list 1 interface Ethernet1/1 overload
!
access-list 1 permit 192.168.0.0 0.0.255.255
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R5 Initical Configuration(Click)

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface Loopback0
 ip address 192.168.0.5 255.255.255.255
!
interface Serial0/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Ethernet1/0
 ip address 192.168.25.5 255.255.255.0
 half-duplex
!
interface Ethernet1/1
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/3
 no ip address
 shutdown
 half-duplex
!
router eigrp 1
 network 192.168.0.0
 network 192.168.25.0
 passive-interface Ethernet1/0
 no auto-summary
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R6 Initical Configuration(Click)

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R6
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface Loopback0
 ip address 192.168.0.6 255.255.255.255
!
interface Serial0/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Ethernet1/0
 ip address 192.168.36.6 255.255.255.0
 half-duplex
!
interface Ethernet1/1
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/3
 no ip address
 shutdown
 half-duplex
!
router eigrp 1
 network 192.168.0.0
 network 192.168.36.0
 no auto-summary
 eigrp stub receive-only
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

ISP Initical Configuration(Click)

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ISP
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface Loopback0
 ip address 100.1.1.1 255.255.255.0
!
interface Serial0/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Ethernet1/0
 ip address 100.0.0.10 255.255.255.0
 half-duplex
!
interface Ethernet1/1
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/3
 no ip address
 shutdown
 half-duplex
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

EIGRP基本設定 トラブルシューティング

1. neighborコマンド  

フレームリレー上でマルチキャストパケットを送信できないので、EIGRP Helloパケットをユニキャストで送信するためにneighborコマンドが必要です。R1でR2に対するneighborコマンドが設定されていないので、R1-R2間のネイバーを確立できません。

切り分け

R1 切り分け

R1#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
1   192.168.123.3           Se0/0              8 00:03:53   43   258  0  19
R1#show ip eigrp interfaces
IP-EIGRP interfaces for process 1
                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Lo0                0        0/0         0       0/1            0           0
Et1/0              0        0/0         0       0/1            0           0
Se0/0              1        0/0        43       0/31         219           0
R1#show run | section router eigrp 1
router eigrp 1
 network 192.168.0.0
 network 192.168.14.0
 network 192.168.123.0
 no auto-summary
 neighbor 192.168.123.3 Serial0/0

設定の修正

R1 設定の修正

router eigrp 1
 neighbor 192.168.123.2 Serial0/0

2. パッシブインタフェース

R5 E1/0がパッシブインタフェースとなっています。パッシブインタフェースからHelloパケットも送信しないのでR2-R5間でネイバーを確立できません。

切り分け

R5 切り分け

R5#show ip eigrp interfaces
IP-EIGRP interfaces for process 1
                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Lo0                0        0/0         0       0/1            0           0
R5#show ip protocols
Routing Protocol is "eigrp 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Redistributing: eigrp 1
  EIGRP NSF-aware route hold timer is 240s
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    192.168.0.0
    192.168.25.0
  Passive Interface(s):
    Ethernet1/0
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.25.2          90      00:15:30
  Distance: internal 90 external 170

設定の修正

R5 設定の修正

router eigrp 1
 no passive-interface Ethernet1/0

3. スプリットホライズン

R1のSerial0/0でスプリットホライズンが無効化されていません。そのため、スポークルータのルートを正しく送受信できません。

切り分け

R1 切り分け

R1#show run int se 0/0
Building configuration...

Current configuration : 388 bytes
!
interface Serial0/0
 ip address 192.168.123.1 255.255.255.0
 ip bandwidth-percent eigrp 1 25
 ip hello-interval eigrp 1 3
 ip hold-time eigrp 1 10
 ip authentication mode eigrp 1 md5
 ip authentication key-chain eigrp 1 EIGRP
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map ip 192.168.123.2 120
 frame-relay map ip 192.168.123.3 130
 no frame-relay inverse-arp
end

設定の修正

R1 設定の修正

interface Serial0/0
 no ip split-horizon eigrp 1

4. EIGRPスタブ

R6のスタブの設定でアドバタイズするルートのオプションがreceive-onlyとなっています。そのため、R6はLoopback0のルートをアドバタイズしません。

切り分け

R3 切り分け

R3#show ip eigrp neighbors detail
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
1   192.168.123.1           Se0/0              9 00:07:47   42   252  0  19
   Static neighbor
   Version 12.4/1.2, Retrans: 0, Retries: 0, Prefixes: 2
0   192.168.36.6            Et1/0             10 00:09:27  302  1812  0  7
   Version 12.4/1.2, Retrans: 0, Retries: 0
   Receive-Only Peer Advertising ( No ) Routes
   Suppressing queries

R6 切り分け

R6#show ip protocols
Routing Protocol is "eigrp 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  EIGRP stub, receive-only
  Redistributing: eigrp 1
  EIGRP NSF-aware route hold timer is 240s
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    192.168.0.0
    192.168.36.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.36.3          90      00:08:21
  Distance: internal 90 external 170

設定の修正

R6 設定の修正

router eigrp 1
 no eigrp stub receive-only
 eigrp stub

5. networkコマンド

R4でnetworkコマンドの設定が間違っているため、R1-R4でネイバーを確立できていません。そのため、インターネットへの通信ができません。

切り分け

R4 切り分け

R4#show ip eigrp interfaces
IP-EIGRP interfaces for process 1
                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Lo0                0        0/0         0       0/1            0           0

設定の修正

R4 設定の修正

router eigrp 1
 network 192.168.14.0
 no network 192.168.4.0

正常な設定ファイル

R1 Correct Configuration(Click)

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
key chain EIGRP
 key 1
   key-string cisco
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface Loopback0
 ip address 192.168.0.1 255.255.255.255
!
interface Serial0/0
 ip address 192.168.123.1 255.255.255.0
 ip bandwidth-percent eigrp 1 25
 ip hello-interval eigrp 1 3
 ip hold-time eigrp 1 10
 ip authentication mode eigrp 1 md5
 ip authentication key-chain eigrp 1 EIGRP
 encapsulation frame-relay
 no ip split-horizon eigrp 1
 serial restart-delay 0
 frame-relay map ip 192.168.123.2 120
 frame-relay map ip 192.168.123.3 130
 no frame-relay inverse-arp
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Ethernet1/0
 ip address 192.168.14.1 255.255.255.0
 half-duplex
!
interface Ethernet1/1
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/3
 no ip address
 shutdown
 half-duplex
!
router eigrp 1
 network 192.168.0.0
 network 192.168.14.0
 network 192.168.123.0
 no auto-summary
 neighbor 192.168.123.3 Serial0/0
 neighbor 192.168.123.2 Serial0/0
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R2 Correct Configuration(Click)

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
key chain EIGRP
 key 1
   key-string cisco
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface Loopback0
 ip address 192.168.0.2 255.255.255.255
!
interface Serial0/0
 ip address 192.168.123.2 255.255.255.0
 ip bandwidth-percent eigrp 1 25
 ip hello-interval eigrp 1 3
 ip hold-time eigrp 1 10
 ip authentication mode eigrp 1 md5
 ip authentication key-chain eigrp 1 EIGRP
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map ip 192.168.123.1 210
 frame-relay map ip 192.168.123.3 210
 no frame-relay inverse-arp
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Ethernet1/0
 ip address 192.168.25.2 255.255.255.0
 half-duplex
!
interface Ethernet1/1
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/3
 no ip address
 shutdown
 half-duplex
!
router eigrp 1
 network 192.168.0.0
 network 192.168.25.0
 network 192.168.123.0
 no auto-summary
 neighbor 192.168.123.1 Serial0/0
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R3 Correct Configuration(Click)

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
key chain EIGRP
 key 1
   key-string cisco
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface Loopback0
 ip address 192.168.0.3 255.255.255.255
!
interface Serial0/0
 ip address 192.168.123.3 255.255.255.0
 ip bandwidth-percent eigrp 1 25
 ip hello-interval eigrp 1 3
 ip hold-time eigrp 1 10
 ip authentication mode eigrp 1 md5
 ip authentication key-chain eigrp 1 EIGRP
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map ip 192.168.123.1 310
 frame-relay map ip 192.168.123.2 310
 no frame-relay inverse-arp
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Ethernet1/0
 ip address 192.168.36.3 255.255.255.0
 half-duplex
!
interface Ethernet1/1
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/3
 no ip address
 shutdown
 half-duplex
!
router eigrp 1
 network 192.168.0.0
 network 192.168.36.0
 network 192.168.123.0
 no auto-summary
 neighbor 192.168.123.1 Serial0/0
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R4 Correct Configuration(Click)

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface Loopback0
 ip address 192.168.0.4 255.255.255.255
!
interface Serial0/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Ethernet1/0
 ip address 192.168.14.4 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 half-duplex
!
interface Ethernet1/1
 ip address 100.0.0.4 255.255.255.0
 ip nat outside
 ip virtual-reassembly
 half-duplex
!
interface Ethernet1/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/3
 no ip address
 shutdown
 half-duplex
!
router eigrp 1
 redistribute static
 network 192.168.0.0
 network 192.168.14.0
 no auto-summary
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 100.0.0.10
!
ip nat inside source list 1 interface Ethernet1/1 overload
!
access-list 1 permit 192.168.0.0 0.0.255.255
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R5 Correct Configuration(Click)

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface Loopback0
 ip address 192.168.0.5 255.255.255.255
!
interface Serial0/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Ethernet1/0
 ip address 192.168.25.5 255.255.255.0
 half-duplex
!
interface Ethernet1/1
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/3
 no ip address
 shutdown
 half-duplex
!
router eigrp 1
 network 192.168.0.0
 network 192.168.25.0
 no auto-summary
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

R6 Correct Configuration(Click)

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R6
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface Loopback0
 ip address 192.168.0.6 255.255.255.255
!
interface Serial0/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Ethernet1/0
 ip address 192.168.36.6 255.255.255.0
 half-duplex
!
interface Ethernet1/1
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/3
 no ip address
 shutdown
 half-duplex
!
router eigrp 1
 network 192.168.0.0
 network 192.168.36.0
 no auto-summary
 eigrp stub connected summary
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

ISR Correct Configuration(Click)

!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ISP
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
ip domain name lab.local
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
! 
!
!
!
!
interface Loopback0
 ip address 100.1.1.1 255.255.255.0
!
interface Serial0/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial0/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Ethernet1/0
 ip address 100.0.0.10 255.255.255.0
 half-duplex
!
interface Ethernet1/1
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/2
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/3
 no ip address
 shutdown
 half-duplex
!
no ip http server
no ip http secure-server
!
ip forward-protocol nd
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

関連記事

関連記事