EIGRPでのデフォルトルート生成方法

デフォルトルートをEIGRPルートとして生成して、他のルータにアドバタイズするためには、以下のようにいくつかの方法があります。

  • スタティックルートのデフォルトルートをEIGRPへ再配送
  • ルート集約
  • ip default-networkコマンド

以降で、スタティックルートのデフォルトルートを再配送する設定例を解説します。

スタティックルートのデフォルトルートをEIGRPへ再配送

【ネットワーク構成】

図 ネットワーク構成
図 ネットワーク構成

【条件】

  • R2がR3へデフォルトルートをEIGRPでアドバタイズして、すべてのインタフェースの接続性を確保できるようにします。
  • デフォルトルートの生成はスタティックルートの再配送で行います。

【初期設定】

R1 初期設定

interface Loopback0
 ip address 172.16.2.1 255.255.255.0 secondary
 ip address 172.16.1.1 255.255.255.0
!
interface Ethernet0/0
 ip address 192.168.12.1 255.255.255.0
!
ip route 192.168.0.0 255.255.0.0 192.168.12.2

R2 初期設定

interface Ethernet0/0
 ip address 192.168.12.2 255.255.255.0
!
interface Ethernet0/1
 ip address 192.168.23.2 255.255.255.0
!
router eigrp 100
 network 192.168.23.0
 no auto-summary

R3 初期設定

interface Loopback0
 ip address 192.168.3.3 255.255.255.0
!
interface Ethernet0/0
 ip address 192.168.23.3 255.255.255.0
!
router eigrp 100
 network 192.168.3.0
 network 192.168.23.0
 no auto-summary

【Step1:デフォルトルートの設定】

R2でスタティックルートとしてデフォルトルートを設定します。

R2 デフォルトルートの設定

ip route 0.0.0.0 0.0.0.0 192.168.12.1

【Step2:スタティックルートをEIGRPへ再配送】

Step1で設定したデフォルトルートをEIGRPルートとするために、R2でスタティックルートをEIGRPへ再配送します。

R2 スタティックルートの再配送

router eigrp 100
 redistribute static

再配送元がstaticおよびconnectedのときには、シードメトリックを指定しなくても問題ありません。

【Step3:デフォルトルートの確認】

R3のルーティングテーブルにEIGRPルートとしてデフォルトルートが登録されていることを確認します。

R3

R3#show ip route 
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.23.2 to network 0.0.0.0

C    192.168.23.0/24 is directly connected, Ethernet0/0
C    192.168.3.0/24 is directly connected, Loopback0
D*EX 0.0.0.0/0 [170/307200] via 192.168.23.2, 00:00:03, Ethernet0/0

【Step4:通信確認】

R3からR1へpingを実行して通信できることを確認します。

R3

R3#ping 172.16.1.1 source 192.168.3.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.3.3 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/12/20 ms
R3#ping 172.16.2.1 source 192.168.3.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.2.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.3.3 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/10/20 ms

関連記事