概要

GREトンネルインタフェース上でマルチキャストパケットをルーティングするネットワーク構成において、設定ミスの切り分けと修正を行います。

ネットワーク構成

下記のネットワーク構成で、PIM-SMによるマルチキャストルーティングを行います。

図 PIM-SM ネットワーク構成
図 PIM-SM ネットワーク構成

マルチキャストグループのアドレスは239.1.1.1です。また、R2-R3間では、物理インタフェースではPIM-SMを有効化しません。トンネルインタフェースを作成し、トンネルインタフェースでPIM-SMを有効化します。

設定概要

各ルータでのIPアドレスやPIM-SMに関連する設定の抜粋を示します。

R1

ip multicast-routing
!
interface Loopback0
 ip address 192.168.0.1 255.255.255.255
 ip pim sparse-mode
!
interface FastEthernet0/0
 ip address 192.168.1.1 255.255.255.0
 ip pim sparse-mode
!
interface FastEthernet1/0
 ip address 192.168.12.1 255.255.255.0
 ip pim sparse-mode
!
router ospf 1
 log-adjacency-changes
 network 192.168.0.0 0.0.255.255 area 0
!
ip pim rp-address 192.168.0.2 1
!
access-list 1 permit 239.1.1.1

R2

ip multicast-routing
!
interface Loopback0
 ip address 192.168.0.2 255.255.255.255
 ip pim sparse-mode
!
interface Tunnel23
 ip unnumbered Loopback0
 ip pim sparse-mode
 tunnel source Loopback0
 tunnel destination 192.168.0.3
!
interface FastEthernet0/0
 ip address 192.168.12.2 255.255.255.0
 ip pim sparse-mode
!
interface FastEthernet1/0
 ip address 192.168.23.2 255.255.255.0
!
router ospf 1
 log-adjacency-changes
 network 192.168.0.0 0.0.255.255 area 0
!
ip pim rp-address 192.168.0.2 1
!
access-list 1 permit 239.1.1.1

R3

ip multicast-routing
!
interface Loopback0
 ip address 192.168.0.3 255.255.255.255
 ip pim sparse-mode
!
interface Tunnel23
 ip unnumbered Loopback0
 ip pim sparse-mode
 tunnel source Loopback0
 tunnel destination 192.168.0.2
!
interface FastEthernet0/0
 ip address 192.168.23.3 255.255.255.0
!
interface FastEthernet1/0
 ip address 192.168.3.3 255.255.255.0
 ip pim sparse-mode
!
router ospf 1
 log-adjacency-changes
 network 192.168.0.0 0.0.255.255 area 0
!
ip pim rp-address 192.168.0.2 1
!
access-list 1 permit 239.1.1.1

Source

interface FastEthernet0/0
 ip address 192.168.1.100 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 192.168.1.1

Reciever

interface FastEthernet0/0
 ip address 192.168.3.100 255.255.255.0
 ip igmp join-group 239.1.1.1
!
ip route 0.0.0.0 0.0.0.0 192.168.3.3

トラブルの症状

Recieverが239.1.1.1のマルチキャストグループに参加しているにも関わらず、RPであるR2までの共有ツリーが作成されていません。R2、R3でshow ip mrouteは次のようになっています。

R2 show ip mroute

R2#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.0.1.40), 02:06:47/00:02:08, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    FastEthernet0/0, Forward/Sparse, 02:06:47/00:02:08

R3 show ip mroute

R3#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.1.1.1), 00:00:15/00:02:44, RP 192.168.0.2, flags: SJC
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    FastEthernet1/0, Forward/Sparse, 00:00:15/00:02:44

(*, 224.0.1.40), 00:01:12/00:01:49, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Tunnel23, Forward/Sparse, 00:01:12/00:01:49

また、Sourceから239.1.1.1あてにマルチキャストパケットを送信しても、ルーティングされていません。Sourceから239.1.1.1あてにPingした結果は、次の通りです。

Source ping 239.1.1.1

Source#ping 239.1.1.1

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 239.1.1.1, timeout is 2 seconds:
.

トラブルを切り分けるために、Sourceから239.1.1.1へ連続してパケットを送信している状態で、各ルータで以下のshowコマンドを実行しました。

  • show ip pim interface
  • show ip pim neighbor
  • show ip mroute
  • show ip mroute count

R1 showコマンドの結果

R1#show ip pim interface

Address          Interface                Ver/   Nbr    Query  DR     DR
                                          Mode   Count  Intvl  Prior
192.168.1.1      FastEthernet0/0          v2/S   0      30     1      192.168.1.1
192.168.12.1     FastEthernet1/0          v2/S   1      30     1      192.168.12.2
192.168.0.1      Loopback0                v2/S   0      30     1      192.168.0.1
R1#show ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
      S - State Refresh Capable
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
192.168.12.2      FastEthernet1/0          02:12:34/00:01:16 v2    1 / DR S
R1#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.1.1.1), 00:03:12/stopped, RP 192.168.0.2, flags: SPF
  Incoming interface: FastEthernet1/0, RPF nbr 192.168.12.2
  Outgoing interface list: Null

(192.168.1.100, 239.1.1.1), 00:03:12/00:02:54, flags: PFT
  Incoming interface: FastEthernet0/0, RPF nbr 0.0.0.0
  Outgoing interface list: Null

(*, 224.0.1.40), 02:13:03/00:02:55, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    FastEthernet0/0, Forward/Sparse, 02:13:03/00:02:51

R1#show ip mroute count
IP Multicast Statistics
3 routes using 1474 bytes of memory
2 groups, 0.50 average sources per group
Forwarding Counts: Pkt Count/Pkts(neg(-) = Drops) per second/Avg Pkt Size
/Kilobits per second
Other counts: Total/RPF failed/Other drops(OIF-null, rate-limit etc)

Group: 239.1.1.1, Source count: 1, Packets forwarded: 0, Packets received: 15
  RP-tree: Forwarding: 0/0/0/0, Other: 0/0/0
  Source: 192.168.1.100/32, Forwarding: 0/-1/0/0, Other: 15/0/15

Group: 224.0.1.40, Source count: 0, Packets forwarded: 0, Packets received: 0

R2 showコマンドの結果

R2#show ip pim interface

Address          Interface                Ver/   Nbr    Query  DR     DR
                                          Mode   Count  Intvl  Prior
192.168.0.2      Tunnel23                 v2/S   1      30     1      0.0.0.0
192.168.12.2     FastEthernet0/0          v2/S   1      30     1      192.168.12.2
192.168.0.2      Loopback0                v2/S   0      30     1      192.168.0.2
R2#show ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
      S - State Refresh Capable
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
192.168.0.3       Tunnel23                 02:13:23/00:01:22 v2    1 / S
192.168.12.1      FastEthernet0/0          02:13:44/00:01:32 v2    1 / S
R2#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.1.1.1), 00:04:22/stopped, RP 192.168.0.2, flags: SP
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list: Null

(192.168.1.100, 239.1.1.1), 00:04:22/00:01:29, flags: P
  Incoming interface: FastEthernet0/0, RPF nbr 192.168.12.1
  Outgoing interface list: Null

(*, 224.0.1.40), 02:14:12/00:02:38, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    FastEthernet0/0, Forward/Sparse, 02:14:12/00:02:38

R2#show ip mroute count
IP Multicast Statistics
3 routes using 1454 bytes of memory
2 groups, 0.50 average sources per group
Forwarding Counts: Pkt Count/Pkts(neg(-) = Drops) per second/Avg Pkt Size
/Kilobits per second
Other counts: Total/RPF failed/Other drops(OIF-null, rate-limit etc)

Group: 239.1.1.1, Source count: 1, Packets forwarded: 0, Packets received: 0
  RP-tree: Forwarding: 0/0/0/0, Other: 0/0/0
  Source: 192.168.1.100/32, Forwarding: 0/0/0/0, Other: 0/0/0

Group: 224.0.1.40, Source count: 0, Packets forwarded: 0, Packets received: 0

R3 showコマンドの結果

R3#show ip pim interface

Address          Interface                Ver/   Nbr    Query  DR     DR
                                          Mode   Count  Intvl  Prior
192.168.0.3      Tunnel23                 v2/S   1      30     1      0.0.0.0
192.168.3.3      FastEthernet1/0          v2/S   0      30     1      192.168.3.3
192.168.0.3      Loopback0                v2/S   0      30     1      192.168.0.3
R3#show ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
      S - State Refresh Capable
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
192.168.0.2       Tunnel23                 02:14:28/00:01:43 v2    1 / S
R3#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.1.1.1), 00:07:12/00:02:50, RP 192.168.0.2, flags: SJC
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    FastEthernet1/0, Forward/Sparse, 00:07:12/00:02:50

(*, 224.0.1.40), 00:08:09/stopped, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Tunnel23, Forward/Sparse, 00:08:09/00:00:52

R3#show ip mroute count
IP Multicast Statistics
2 routes using 1308 bytes of memory
2 groups, 0.00 average sources per group
Forwarding Counts: Pkt Count/Pkts(neg(-) = Drops) per second/Avg Pkt Size
/Kilobits per second
Other counts: Total/RPF failed/Other drops(OIF-null, rate-limit etc)

Group: 239.1.1.1, Source count: 0, Packets forwarded: 0, Packets received: 0

Group: 224.0.1.40, Source count: 0, Packets forwarded: 0, Packets received: 0

問題

  • なぜ、Sourceから239.1.1.1のメンバーであるRecieverまでマルチキャストパケットがルーティングされないのですか?
  • 正常にマルチキャストパケットをルーティングできるようにするためには、どのように設定すればよいですか?ただし、R2-R3間はトンネルインタフェース上でマルチキャストルーティングを行うものとします。

解答

なぜ、Sourceから239.1.1.1のメンバーであるRecieverまでマルチキャストパケットがルーティングされないのですか?

R3でRPアドレス192.168.0.2に対するRPFインタフェースがNullになっているため、RPまでの239.1.1.1に対する共有ツリーを作成できない。そのため、R2まで239.1.1.1のマルチキャストパケットがルーティングされても、OILがNullなのでR2でパケットは破棄される。R3でRPアドレス192.168.0.2に対するRPFインタフェースをTunnel23にしなければいけない。

正常にマルチキャストパケットをルーティングできるようにするためには、どのように設定すればよいですか?ただし、R2-R3間はトンネルインタフェース上でマルチキャストルーティングを行うものとします。

R3

ip mroute 192.168.0.2 255.255.255.255 tunnel23
!
ip pim spt-threshold infinity

ワンポイント

  • トンネルインタフェース経由でマルチキャストパケットをルーティングするときには、RPFインタフェースに注意
  • 共有ツリーでは、RPアドレスを基にしてRPFインタフェースを決定する
  • ソースツリーでは、ソースのIPアドレスを基にしてRPFインタフェースを決定する

解説

トンネルインタフェース経由でマルチキャストパケットをルーティングするときには、ディストリビューションツリーのRPFインタフェースに注意しなければいけません。RPFインタフェースは、マルチキャストパケットを受信するべきインタフェースです。RPFインタフェースで受信したマルチキャストパケットのみOILのインタフェースにルーティングします。また、ディストリビューションツリーを作成するためのPIM JoinメッセージをRPFインタフェースから上流のルータ(RPFネイバー)に対して送信します。


GREトンネルインタフェースについて、以下の記事をご覧ください。


ディストリビューションツリーの種類によって、RPFインタフェースを決定するためのアドレスが異なります。共有ツリーでは、RPアドレスを基にしてRPFインタフェースを決定します。ソースツリーではソースのIPアドレスを基にしてRPFインタフェースを決定します。RPアドレスまたはソースのIPアドレスに到達するための最短経路のインタフェースをユニキャストルーティングテーブルから判断して、RPFインタフェースとします。ただし、RPFインタフェースはPIMが有効になっていることが前提です。

R3の239.1.1.1の共有ツリー(*,239.1.1.1)を見ると、RPFインタフェースがNullとなっています。

R3 show ip mroute

R3#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode
 
(*, 239.1.1.1), 00:17:29/00:02:27, RP 192.168.0.2, flags: SJC
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    FastEthernet1/0, Forward/Sparse, 00:17:29/00:02:27
 
(*, 224.0.1.40), 00:17:31/00:02:20, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Loopback0, Forward/Sparse, 00:17:31/00:02:20

R3では、(*,239.1.1.1)のRPFインタフェースをRPアドレス192.168.0.2から決定します。192.168.0.2へ到達するための最短経路のインタフェースはFa0/0です。しかし、Fa0/0ではPIM-SMが有効化されていません。そのため、RPFインタフェースがNullになっています。RPFインタフェースがNullなので、R3からPIM Joinメッセージが送信されず、R2までの共有ツリーが作成されません。

図 R3のRPFインタフェース
図 R3のRPFインタフェース

R2-R3間はTunnel23でマルチキャストパケットをルーティングするので、R3の(*,239.1.1.1)のRPFインタフェースがTunnel23になるようにしなければいけません。ip mrouteコマンドによって、ユニキャストルーティングテーブルによらずにRPFインタフェースを決定することができます。R3でRPアドレス192.168.0.2に対するRPFインタフェースをTunnel23にするためには、次のように設定します。

R3 ip mrouteでRPFインタフェースの変更

ip mroute 192.168.0.2 255.255.255.255 tunnel23


ip mrouteコマンドについて、以下の記事をご覧ください。


設定後、R3の(*,239.1.1.1)を確認すると、RPFインタフェースがTunnel23になっていることがわかります。

R3 show ip mroute(ip mroute設定後)

R3#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode
 
(*, 239.1.1.1), 00:00:48/00:02:11, RP 192.168.0.2, flags: SJC
  Incoming interface: Tunnel23, RPF nbr 192.168.0.2, Mroute
  Outgoing interface list:
    FastEthernet1/0, Forward/Sparse, 00:00:48/00:02:11
 
(*, 224.0.1.40), 00:00:59/00:02:12, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Loopback0, Forward/Sparse, 00:00:59/00:02:12

R3はTunnel23からRPFネイバー192.168.0.2へPIM Joinメッセージを送信し、R2までの共有ツリーが完成します。R2でshow ip mrouteを見ると、次のようになっています。

R2 show ip mroute

R2#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode
 
(*, 239.1.1.1), 00:02:35/00:03:06, RP 192.168.0.2, flags: S
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Tunnel23, Forward/Sparse, 00:02:35/00:03:06
 
(*, 224.0.1.40), 00:26:16/00:02:37, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Loopback0, Forward/Sparse, 00:26:16/00:02:37
 

この状態でSourceから239.1.1.1のマルチキャストパケットを送信すると、Recieverまでルーティングされるようになります。

Source ping 239.1.1.1

Source#ping 239.1.1.1 repeat 5
 
Type escape sequence to abort.
Sending 20, 100-byte ICMP Echos to 239.1.1.1, timeout is 2 seconds:
 
Reply to request 0 from 192.168.3.100, 60 ms
Reply to request 1 from 192.168.3.100, 88 ms
Reply to request 2 from 192.168.3.100, 60 ms
Reply to request 3 from 192.168.3.100, 92 ms
Reply to request 4 from 192.168.3.100, 48 ms

これで、SourceからRecieverまでのマルチキャストルーティングはできますが、R3で余計なディストリビューションツリーができてしまいます。Sourceからマルチキャストパケットを送信しているときに、R3のディストリビューションツリーを確認すると、次のように(192.168.1.100,239.1.1.1)のエントリが作成されています。

R3 show ip mroute

R3#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode
 
(*, 239.1.1.1), 00:10:02/stopped, RP 192.168.0.2, flags: SJC
  Incoming interface: Tunnel23, RPF nbr 192.168.0.2, Mroute
  Outgoing interface list:
    FastEthernet1/0, Forward/Sparse, 00:10:02/00:02:56
 
(192.168.1.100, 239.1.1.1), 00:00:05/00:02:54, flags: J
  Incoming interface: Null, RPF nbr 192.168.23.2
  Outgoing interface list:
    FastEthernet1/0, Forward/Sparse, 00:00:05/00:02:56
 
(*, 224.0.1.40), 00:10:14/00:01:57, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Loopback0, Forward/Sparse, 00:10:14/00:01:57
 

この(192.168.1.100,239.1.1.1)のエントリはスイッチオーバーにより、作成されたものです。スイッチオーバーのしきい値のSPT Thresholdのデフォルトは0なので、すぐにスイッチオーバーします。ただし、今回のネットワーク構成はスイッチオーバーしてもしなくても、マルチキャストパケットの転送経路は変わりません。スイッチオーバーしても意味はなく、余計なディストリビューションツリーのエントリが作成されてしまいます。意味のないスイッチオーバーをしないように、次のコマンドを入力します。

R3 スイッチオーバーの無効化

ip pim spt-threshold infinity

関連記事

IPマルチキャストの仕組み