概要

CiscoルータのOSPFのエリア間ルート集約の設定例です。デフォルトの集約ルートのコストに注目してください。

ネットワーク構成

図 OSPFルート集約の設定例(Cisco) ネットワーク構成
図 OSPFルート集約の設定例(Cisco) ネットワーク構成

設定条件

  • ネットワーク構成に基づいてOSPFを有効化します。
  • R2でOSPFルートが次のように見えるように設定します。

R2

R2#show ip route ospf
     10.0.0.0/8 is variably subnetted, 3 subnets, 3 masks
O       10.3.1.0/24 [110/20] via 192.168.23.3, 00:00:13, Ethernet0/1
O       10.3.3.0/27 [110/40] via 192.168.23.3, 00:00:13, Ethernet0/1
O       10.3.2.0/25 [110/30] via 192.168.23.3, 00:00:13, Ethernet0/1

  • R1でOSPFルートが次のように見えるように設定します。

R1

R1#show ip route ospf
     10.0.0.0/16 is subnetted, 1 subnets
O IA    10.3.0.0 [110/30] via 192.168.12.2, 00:00:41, Ethernet0/0
O IA 192.168.23.0/24 [110/20] via 192.168.12.2, 00:04:44, Ethernet0/0

初期設定

  • ホスト名
  • IPアドレス

設定と確認

Step1:OSPFの有効化

ネットワーク構成に基づいてR1/R2/R3でOSPFを有効化します。R3では、Loopbackインタフェースで10.3.1.0/24、10.3.2.0/25、10.3.3.0/27のネットワークを構成しています。R2において、設定条件にあるように「10.3」ではじまるOSPFルートが設定されたサブネットマスクで見えるようにR3のLoopbackインタフェースでip ospf network point-to-pointが必要です。

R1

router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 network 192.168.12.0 0.0.0.255 area 0

R2

router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 network 192.168.12.0 0.0.0.255 area 0
 network 192.168.23.0 0.0.0.255 area 1

R3

interface Loopback0
 ip ospf network point-to-point
!
interface Loopback1
 ip ospf network point-to-point
!
interface Loopback2
 ip ospf network point-to-point
!
router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
 network 10.3.0.0 0.0.255.255 area 1
 network 192.168.23.0 0.0.0.255 area 1

Step2:OSPFの確認

Step1のOSPFの設定が正しく動作していることを確認します。R2でOSPFネイバーとOSPFルートを確認します。

R2

R2#show ip ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           1   FULL/BDR        00:00:34    192.168.12.1    Ethernet0/0
3.3.3.3           1   FULL/BDR        00:00:35    192.168.23.3    Ethernet0/1
R2#show ip route ospf 
     10.0.0.0/8 is variably subnetted, 3 subnets, 3 masks
O       10.3.1.0/24 [110/11] via 192.168.23.3, 00:01:39, Ethernet0/1
O       10.3.3.0/27 [110/11] via 192.168.23.3, 00:01:39, Ethernet0/1
O       10.3.2.0/25 [110/11] via 192.168.23.3, 00:01:39, Ethernet0/1

R2はR1、R3とネイバーを確立してR3の「10.3」ではじまるルートを正しく受信できていることがわかります。

Step3:OSPFコストの変更

R2でOSPFルートが設定条件のように見えるために、R3の各Loopbackインタフェースのコストを変更します。R2のE0/1のコストは10です。設定条件のOSPFルートのコストになるように、次のようにOSPFコストを設定します。

  • Loopback0 10.3.1.0/24 コスト10
  • Loopback1 10.3.2.0/25 コスト20
  • Loopback2 10.3.3.0/27 コスト30

R3

interface Loopback0
 ip ospf cost 10
!
interface Loopback1
 ip ospf cost 20
!
interface Loopback2
 ip ospf cost 30

Step4:OSPFコストの確認

R2でのOSPFルートを確認します。

R2

R2#show ip route ospf 
     10.0.0.0/8 is variably subnetted, 3 subnets, 3 masks
O       10.3.1.0/24 [110/20] via 192.168.23.3, 00:00:57, Ethernet0/1
O       10.3.3.0/27 [110/40] via 192.168.23.3, 00:00:57, Ethernet0/1
O       10.3.2.0/25 [110/30] via 192.168.23.3, 00:00:57, Ethernet0/1

設定条件と同じようにOSPFルートのコストが表示されていることが確認できます。

Step5:ルート集約の設定

R1のルーティングテーブルでOSPFルートが設定条件のように見えるためには、10.3.1.0/24、10.3.2.0/25、10.3.3.0/27を10.3.0.0/16に集約します。OSPFでのルート集約はABRで行うため、R2で集約ルートを生成します。

R2

router ospf 1
 area 1 range 10.3.0.0 255.255.0.0

Step6:ルート集約の確認

ルート集約の設定を確認します。集約ルートを生成するR2では、show ip opsfコマンドを利用します。また、エリア0のLSDBに集約ルートを表すLSAタイプ3があります。

R2

R2#show ip ospf 
 Routing Process "ospf 1" with ID 2.2.2.2
~省略~
 Number of areas in this router is 2. 2 normal 0 stub 0 nssa
 Number of areas transit capable is 0
 External flood list length 0
    Area BACKBONE(0)
        Number of interfaces in this area is 1
        Area has no authentication
        SPF algorithm last executed 00:13:20.256 ago
        SPF algorithm executed 6 times
        Area ranges are
        Number of LSA 5. Checksum Sum 0x0308BA
        Number of opaque link LSA 0. Checksum Sum 0x000000
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0
    Area 1
        Number of interfaces in this area is 1
        Area has no authentication
        SPF algorithm last executed 00:13:20.268 ago
        SPF algorithm executed 12 times
        Area ranges are
           10.3.0.0/16 Active(20) Advertise 
        Number of LSA 4. Checksum Sum 0x022C3D
        Number of opaque link LSA 0. Checksum Sum 0x000000
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0
R2#show ip ospf database summary 

            OSPF Router with ID (2.2.2.2) (Process ID 1)

                Summary Net Link States (Area 0)

  LS age: 894
  Options: (No TOS-capability, DC, Upward)
  LS Type: Summary Links(Network)
  Link State ID: 10.3.0.0 (summary Network Number)
  Advertising Router: 2.2.2.2
  LS Seq Number: 80000001
  Checksum: 0x6FA4
  Length: 28
  Network Mask: /16
        TOS: 0  Metric: 20 

  LS age: 524
  Options: (No TOS-capability, DC, Upward)
  LS Type: Summary Links(Network)
  Link State ID: 192.168.23.0 (summary Network Number)
  Advertising Router: 2.2.2.2
  LS Seq Number: 80000002
  Checksum: 0xFFA9
  Length: 28
  Network Mask: /24
        TOS: 0  Metric: 10 


                Summary Net Link States (Area 1)

  LS age: 527
  Options: (No TOS-capability, DC, Upward)
  LS Type: Summary Links(Network)
  Link State ID: 192.168.12.0 (summary Network Number)
  Advertising Router: 2.2.2.2
  LS Seq Number: 80000002
  Checksum: 0x793B
  Length: 28
  Network Mask: /24
        TOS: 0  Metric: 10

集約ルートのメトリックは、デフォルトで集約の範囲内に含まれる詳細なルートの最小メトリックです。詳細なルートの最小メトリックは10.3.1.0/24の20なので、集約ルートのメトリックは20です。

そして、R1のルーティングテーブルでは設定条件と同じようにOSPFルートが見えます。

R1

R1#show ip route ospf 
     10.0.0.0/16 is subnetted, 1 subnets
O IA    10.3.0.0 [110/30] via 192.168.12.2, 00:17:08, Ethernet0/0
O IA 192.168.23.0/24 [110/20] via 192.168.12.2, 00:43:58, Ethernet0/0

図 ルート集約の動作
図 ルート集約の動作

ネットワーク技術解説記事のアップデートや新規記事をTwitterでお知らせしています。

「ネットワークのおべんきょしませんか?」内の記事を検索

OSPFの仕組み