概要

OSPFのバーチャルリンクが必要なエリア構成で、設定ミスの切り分けと修正を行います。

ネットワーク構成

下記のネットワーク構成でOSPFによるダイナミックルーティングを行います。

図 OSPF 設定ミスの切り分けと修正 Part1 ネットw-悪構成

設定概要

各ルータのOSPFに関連する設定の抜粋です。

R1

interface Loopback0
 ip address 192.168.1.1 255.255.255.0
 ip ospf network point-to-point
!
interface Serial1/0
 ip address 192.168.12.1 255.255.255.0
!
router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 network 192.168.1.1 0.0.0.0 area 0
 network 192.168.12.1 0.0.0.0 area 12

R2

interface Loopback0
 ip address 192.168.2.2 255.255.255.0
 ip ospf network point-to-point
!
interface Serial1/0
 ip address 192.168.12.2 255.255.255.0
!
interface Serial1/1
 ip address 192.168.23.2 255.255.255.0
!
router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 network 192.168.2.2 0.0.0.0 area 12
 network 192.168.12.2 0.0.0.0 area 12
 network 192.168.23.2 0.0.0.0 area 23

R3

interface Loopback0
 ip address 192.168.3.3 255.255.255.0
 ip ospf network point-to-point
!
interface Serial1/0
 ip address 192.168.23.3 255.255.255.0
!
router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
 network 192.168.3.3 0.0.0.0 area 3
 network 192.168.23.3 0.0.0.0 area 23

問題

R1でルーティングテーブルをみると、次のように192.168.2.0/24のルートしかOSPFで学習できていません。

R1 show ip route

R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.12.0/24 is directly connected, Serial1/0
C    192.168.1.0/24 is directly connected, Loopback0
O    192.168.2.0/24 [110/65] via 192.168.12.2, 00:07:31, Serial1/0

エリア構成を変えないで、必要なネットワークのルート情報が各ルータのルーティングテーブルに登録されるようにしたいと考えています。どのように設定すればよいですか?

解答

R1

router ospf 1
 area 12 virtual-link 2.2.2.2

R2

router ospf 1
 area 12 virtual-link 1.1.1.1
 area 23 virtual-link 3.3.3.3

R3

router ospf 1
 area 23 virtual-link 2.2.2.2

解説

OSPFのエリア構成は、バックボーンエリア(エリア0)を中心とした2階層構造が原則です。すべてのエリアは原則として、バックボーンエリアに接続していなければいけません。物理的な配置上、バックボーンエリアに接続することができないエリアがある場合、バーチャルリンクが必要です。バーチャルリンクによって、仮想的にバックボーンエリアに接続することができます。

問題のネットワーク構成を見ると、エリア23とエリア3がバックボーンエリアに接続されていません。すると、このエリア23とエリア3に含まれるネットワークのルート情報を正しく学習できなくなります。エリア23とエリア3をバックボーンエリアに接続するために、バーチャルリンクの設定が必要です。

【エリア23をエリア0に接続】

エリア23をバーチャルリンクによってエリア0に接続します。そのためには、R1とR2間でバーチャルリンクを設定します。バーチャルリンクの設定は、エリア0に接続しているABRとエリア0に接続していないエリアのABR間で行います。この場合は、エリア0に接続しているABRはR1です。また、エリア0に接続していないエリア(エリア23)のABRはR2です。バーチャルリンクを設定するルータは、同じエリアに所属していなければいけません。バーチャルリンクを設定するルータが所属しているエリアがトランジットエリアです。R1とR2が所属しているエリア12がトランジットエリアとなります。

エリア23をエリア0に接続するためにR1とR2でのバーチャルリンクの設定は次のように行います。

R1

router ospf 1
 area 12 virtual-link 2.2.2.2

R2
router ospf 1 area 12 virtual-link 1.1.1.1

バーチャルリンクにより、R1とR2は仮想的にポイントツーポイント接続されます。そして、仮想的なポイントツーポイントインタフェースは、エリア0のインタフェースです。また、バーチャルリンクを介してネイバーを確立します。R2はバーチャルリンクによってエリア0のABRにもなります。

バーチャルリンクの確認は、show ip ospf virtual-linksやshow ip ospf interfaceコマンドなどで行います。R1でshow ip ospf virtual-links/show ip ospf interface/show ip ospf neighborを見ると、次のようになります。

R1 show ip ospf interface/show ip ospf neighbor

R1#show ip ospf virtual-links
Virtual Link OSPF_VL0 to router 2.2.2.2 is up
  Run as demand circuit
  DoNotAge LSA allowed.
  Transit area 12, via interface Serial1/0, Cost of using 64
  Transmit Delay is 1 sec, State POINT_TO_POINT,
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:05
    Adjacency State FULL (Hello suppressed)
    Index 1/2, retransmission queue length 0, number of retransmission 0
    First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
    Last retransmission scan length is 0, maximum is 0
    Last retransmission scan time is 0 msec, maximum is 0 msec
R1#show ip ospf interface
Loopback0 is up, line protocol is up
  Internet Address 192.168.1.1/24, Area 0
~省略~
OSPF_VL0 is up, line protocol is up
  Internet Address 192.168.12.1/24, Area 0
  Process ID 1, Router ID 1.1.1.1, Network Type VIRTUAL_LINK, Cost: 64
  Configured as demand circuit.
  Run as demand circuit.
  DoNotAge LSA allowed.
  Transmit Delay is 1 sec, State POINT_TO_POINT
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:02
  Supports Link-local Signaling (LLS)
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 2.2.2.2  (Hello suppressed)
  Suppress hello for 1 neighbor(s)
Serial1/0 is up, line protocol is up
  Internet Address 192.168.12.1/24, Area 12
~省略~
R1#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2           0   FULL/  -           -        192.168.12.2    OSPF_VL0
2.2.2.2           0   FULL/  -        00:00:34    192.168.12.2    Serial1/0

【エリア33をエリア0に接続】

エリア3もエリア0に接続しなければいけません。R1とR2間のバーチャルリンクによってR2はエリア0のABRになっています。R2と同じエリア23内に所属しているR3がエリア3のABRなので、R2とR3間でバーチャルリンクを設定します。トランジットエリアは、エリア23です。そのための設定は次のように行います。

R2

router ospf 1
 area 23 virtual-link 3.3.3.3

R3

router ospf 1
 area 23 virtual-link 2.2.2.2

R2とR3間もバーチャルリンクにより仮想的にエリア0のポイントツーポイントリンクで接続されることになります。

R1-R2間、そしてR2-R3間でバーチャルリンクを設定することで、すべてのエリアがエリア0を中心とした2階層構造になります。バーチャルリンクを考慮したエリア構成をまとめたものが次の図です。

図 バーチャルリンク設定後のエリア構成
図 バーチャルリンク設定後のエリア構成


そして、次のようにR1はエリア23、エリア3のルートを学習できるようになります。

R1 show ip route

R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.12.0/24 is directly connected, Serial1/0
O IA 192.168.23.0/24 [110/128] via 192.168.12.2, 00:32:02, Serial1/0
C    192.168.1.0/24 is directly connected, Loopback0
O    192.168.2.0/24 [110/65] via 192.168.12.2, 00:32:12, Serial1/0
O IA 192.168.3.0/24 [110/129] via 192.168.12.2, 00:32:02, Serial1/0

関連記事