概要

広域イーサネットで相互接続している4拠点の社内ネットワークにおいて、OSPFによるルーティングを行う演習です。Part2では、デフォルトルートを生成してインターネットへ接続できるようにします。

Part1:OSPFの基本設定
Part2:デフォルトルートの生成
Part3:スタブエリア
Part4:ルート集約
Part5:トラブルシューティング

ネットワーク構成

図 演習:実践的なOSPFルーティング 論理構成図
図 演習:実践的なOSPFルーティング 論理構成図

 図 演習:実践的なOSPFルーティング ルーティングプロトコル
図 演習:実践的なOSPFルーティング ルーティングプロトコル

設定条件

Part1:OSPFの基本設定

  1. 図 ルーティングプロトコルの構成のように、OSPFおよびRIPv2の設定を行います。OSPFルータのルータIDは、YY.YY.YY.YY(YY:ルータ番号)とします。また、将来的なギガビットイーサネット導入に対応できるように設定します。
  2. 不要なインタフェースにはルーティングプロトコルのパケットを送信しないようにします。
  3. R42では、RIPv2のルートをOSPFへ再配送します。また、R42はR43へRIPv2でデフォルトルートをアドバタイズします。
  4. 10.0.0.0/24上では、R11がDR、R12がBDRとなるようにします。また、MD5によるネイバー認証を行い、ネイバーの障害検出を4秒以内にできるようにします。

Part2デフォルトルートの生成 -> このページで設定

  1. R13、R14でインターネットへルーティングするためのデフォルトルートをスタティックで設定します。
  2. R13、R14でOSPFドメインにデフォルトルートを生成します。インターネットへのルーティングはR13を優先します。

Part3:スタブエリアの設定

  1. エリア2、エリア4にはLSAタイプ5をアドバタイズしないように設定します。エリア4にはインターネットへの接続性を確保するために、デフォルトルートをアドバタイズできるようにします。
  2. エリア3のLSDBのサイズが最も小さくなるように設定します。

Part4:ルート集約

  1. エリア1、エリア2、エリア3、エリア4のネットワークアドレスを集約してバックボーンエリアにアドバタイズします。
  2. RIPv2ドメインのルートを集約してOSPFドメインへアドバタイズします。

初期設定

「演習:実践的なOSPFルーティング Part1」完了時点から開始します。

R11 Initial Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R11
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.1.11.11 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.0.11 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 ip ospf hello-interval 1
 ip ospf priority 255
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.1.1.11 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 11.11.11.11
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 passive-interface Loopback0
 network 10.0.0.0 0.0.0.255 area 0
 network 10.1.0.0 0.0.255.255 area 1
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R12 Initial Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R12
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.1.12.12 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.0.12 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 ip ospf hello-interval 1
 ip ospf priority 100
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.1.1.12 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 12.12.12.12
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 passive-interface Loopback0
 network 10.0.0.0 0.0.0.255 area 0
 network 10.1.0.0 0.0.255.255 area 1
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R13 Initial Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R13
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.1.13.13 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.1.2.13 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.1.1.13 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface Serial2/0
 ip address 100.1.0.1 255.255.255.252
 ip nat outside
 ip virtual-reassembly
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 13.13.13.13
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 passive-interface FastEthernet0/0
 passive-interface Loopback0
 network 10.1.0.0 0.0.255.255 area 1
!
ip http server
ip forward-protocol nd
!
!
ip nat inside source list 1 interface Serial2/0 overload
!
access-list 1 permit 10.0.0.0 0.255.255.255
access-list 1 permit 172.16.0.0 0.0.255.255
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R14 Initial Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R14
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.1.14.14 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.1.3.14 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.1.1.14 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface Serial2/0
 ip address 100.1.0.5 255.255.255.252
 ip nat outside
 ip virtual-reassembly
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 14.14.14.14
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 passive-interface FastEthernet0/0
 passive-interface Loopback0
 network 10.1.0.0 0.0.255.255 area 1
!
ip http server
ip forward-protocol nd
!
!
ip nat inside source list 1 interface Serial2/0 overload
!
access-list 1 permit 10.0.0.0 0.255.255.255
access-list 1 permit 172.16.0.0 0.0.255.255
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R21 Initial Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R21
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.2.21.21 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.0.21 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 ip ospf hello-interval 1
 ip ospf priority 0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.2.1.21 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 21.21.21.21
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 passive-interface Loopback0
 network 10.0.0.0 0.0.0.255 area 0
 network 10.2.0.0 0.0.255.255 area 2
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R22 Initial Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R22
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.2.22.22 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.2.2.22 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.2.1.22 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 22.22.22.22
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 passive-interface FastEthernet0/0
 passive-interface Loopback0
 network 10.2.0.0 0.0.255.255 area 2
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R23 Initial Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R23
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.2.23.23 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.2.3.23 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.2.1.23 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 23.23.23.23
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 passive-interface FastEthernet0/0
 passive-interface Loopback0
 network 10.2.0.0 0.0.255.255 area 2
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R31 Initial Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R31
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.3.31.31 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.0.31 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 ip ospf hello-interval 1
 ip ospf priority 0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.3.1.31 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 23.23.23.23
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 passive-interface FastEthernet0/0
 passive-interface Loopback0
 network 10.0.0.0 0.0.0.255 area 0
 network 10.2.0.0 0.0.255.255 area 2
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R41 Initial Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R41
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.4.41.41 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.0.41 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 ip ospf hello-interval 1
 ip ospf priority 0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.4.1.41 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 41.41.41.41
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 passive-interface Loopback0
 network 10.0.0.0 0.0.0.255 area 0
 network 10.4.0.0 0.0.255.255 area 4
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R42 Initial Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R42
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.4.42.42 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.4.1.42 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 ip address 172.16.0.42 255.255.255.0
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 42.42.42.42
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 redistribute rip subnets
 passive-interface Loopback0
 network 10.4.0.0 0.0.255.255 area 4
!
router rip
 version 2
 network 172.16.0.0
 default-information originate
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R43 Initial Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R43
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.4.43.43 255.255.255.255
!
interface Loopback1
 ip address 172.16.2.43 255.255.255.0 secondary
 ip address 172.16.1.43 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial2/0
 ip address 172.16.0.43 255.255.255.0
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router rip
 version 2
 passive-interface default
 no passive-interface Serial2/0
 network 172.16.0.0
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

ISP Initial Configuration (Click)

!
!
!
!
!
!
!
!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ISP
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 100.1.1.1 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial2/0
 ip address 100.1.0.2 255.255.255.252
 serial restart-delay 0
!
interface Serial2/1
 ip address 100.1.0.6 255.255.255.252
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

設定と確認 Part2:デフォルトルートの生成

Step1:デフォルトルートの設定

R13、R14でインターネットへパケットをルーティングするためにISPをネクストホップとするデフォルトルートをスタティックで設定します。

R13 デフォルトルートの設定

ip route 0.0.0.0 0.0.0.0 100.1.0.2

R14 デフォルトルートの設定

ip route 0.0.0.0 0.0.0.0 100.1.0.6

Step2:OSPFでのデフォルトルート生成

R13、R14でOSPFドメインにデフォルトルートをアドバタイズします。R13を優先するため、R13で生成するデフォルトルートのメトリックタイプを1とします。

R13 OSPFデフォルトルートの設定

router ospf 1
 default-information originate metric-type 1

R14 OSPFデフォルトルートの設定

router ospf 1
 default-information originate

Step3:OSPFでのデフォルトルート生成の確認

R13、R14で生成したデフォルトルートを確認するために、以下のshowコマンドを実行します。

  • show ip ospf database external 0.0.0.0
  • show ip route 0.0.0.0

R11では、次のようになります。

R11 OSPFデフォルトルートの確認

R11#show ip ospf database external 0.0.0.0

            OSPF Router with ID (11.11.11.11) (Process ID 1)

                Type-5 AS External Link States

  Routing Bit Set on this LSA
  LS age: 236
  Options: (No TOS-capability, DC)
  LS Type: AS External Link
  Link State ID: 0.0.0.0 (External Network Number )
  Advertising Router: 13.13.13.13
  LS Seq Number: 80000001
  Checksum: 0x30CE
  Length: 36
  Network Mask: /0
        Metric Type: 1 (Comparable directly to link state metric)
        TOS: 0 
        Metric: 1 
        Forward Address: 0.0.0.0
        External Route Tag: 1

  LS age: 224
  Options: (No TOS-capability, DC)
  LS Type: AS External Link
  Link State ID: 0.0.0.0 (External Network Number )
  Advertising Router: 14.14.14.14
  LS Seq Number: 80000001
  Checksum: 0x95E4
  Length: 36
  Network Mask: /0
        Metric Type: 2 (Larger than any link state path)
        TOS: 0 
        Metric: 1 
        Forward Address: 0.0.0.0
        External Route Tag: 1

R11#show ip route 0.0.0.0
Routing entry for 0.0.0.0/0, supernet
  Known via "ospf 1", distance 110, metric 31, candidate default path
  Tag 1, type extern 1
  Last update from 10.1.1.13 on FastEthernet1/0, 00:03:38 ago
  Routing Descriptor Blocks:
  * 10.1.1.13, from 13.13.13.13, 00:03:38 ago, via FastEthernet1/0
      Route metric is 31, traffic share count is 1
      Route tag 1

R13はメトリックタイプ1の外部ルートとしてデフォルトルートを生成し、OSPFドメインにアドバタイズしていることがわかります。また、R14はメトリックタイプ2の外部ルートとしてデフォルトルートを生成し、OSPFドメインにアドバタイズしています。

そして、メトリックタイプ1の外部ルートとメトリックタイプ2の外部ルートでは、メトリックの値によらずメトリックタイプ1の外部ルートが優先されます。そのため、OSPFドメインのルータはR13が生成したデフォルトルートをルーティングテーブルに登録します。

図 デフォルトルートの生成
図 デフォルトルートの生成

Part2完了の設定ファイル

R11 Completed Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R11
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.1.11.11 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.0.11 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 ip ospf hello-interval 1
 ip ospf priority 255
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.1.1.11 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 11.11.11.11
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 passive-interface Loopback0
 network 10.0.0.0 0.0.0.255 area 0
 network 10.1.0.0 0.0.255.255 area 1
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R12 Completed Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R12
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.1.12.12 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.0.12 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 ip ospf hello-interval 1
 ip ospf priority 100
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.1.1.12 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 12.12.12.12
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 passive-interface Loopback0
 network 10.0.0.0 0.0.0.255 area 0
 network 10.1.0.0 0.0.255.255 area 1
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R13 Completed Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R13
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.1.13.13 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.1.2.13 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.1.1.13 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface Serial2/0
 ip address 100.1.0.1 255.255.255.252
 ip nat outside
 ip virtual-reassembly
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 13.13.13.13
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 passive-interface FastEthernet0/0
 passive-interface Loopback0
 network 10.1.0.0 0.0.255.255 area 1
 default-information originate metric-type 1
!
ip http server
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 100.1.0.2
!
!
ip nat inside source list 1 interface Serial2/0 overload
!
access-list 1 permit 10.0.0.0 0.255.255.255
access-list 1 permit 172.16.0.0 0.0.255.255
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R14 Completed Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R14
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.1.14.14 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.1.3.14 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.1.1.14 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface Serial2/0
 ip address 100.1.0.5 255.255.255.252
 ip nat outside
 ip virtual-reassembly
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 14.14.14.14
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 passive-interface FastEthernet0/0
 passive-interface Loopback0
 network 10.1.0.0 0.0.255.255 area 1
 default-information originate
!
ip http server
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 100.1.0.6
!
!
ip nat inside source list 1 interface Serial2/0 overload
!
access-list 1 permit 10.0.0.0 0.255.255.255
access-list 1 permit 172.16.0.0 0.0.255.255
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R21 Completed Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R21
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.2.21.21 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.0.21 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 ip ospf hello-interval 1
 ip ospf priority 0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.2.1.21 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 21.21.21.21
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 passive-interface Loopback0
 network 10.0.0.0 0.0.0.255 area 0
 network 10.2.0.0 0.0.255.255 area 2
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R22 Completed Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R22
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.2.22.22 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.2.2.22 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.2.1.22 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 22.22.22.22
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 passive-interface FastEthernet0/0
 passive-interface Loopback0
 network 10.2.0.0 0.0.255.255 area 2
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R23 Completed Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R23
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.2.23.23 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.2.3.23 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.2.1.23 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 23.23.23.23
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 passive-interface FastEthernet0/0
 passive-interface Loopback0
 network 10.2.0.0 0.0.255.255 area 2
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R31 Completed Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R31
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.3.31.31 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.0.31 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 ip ospf hello-interval 1
 ip ospf priority 0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.3.1.31 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 23.23.23.23
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 passive-interface FastEthernet0/0
 passive-interface Loopback0
 network 10.0.0.0 0.0.0.255 area 0
 network 10.2.0.0 0.0.255.255 area 2
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R41 Completed Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R41
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.4.41.41 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.0.41 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 ip ospf hello-interval 1
 ip ospf priority 0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.4.1.41 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 41.41.41.41
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 passive-interface Loopback0
 network 10.0.0.0 0.0.0.255 area 0
 network 10.4.0.0 0.0.255.255 area 4
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R42 Completed Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R42
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.4.42.42 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.4.1.42 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 ip address 172.16.0.42 255.255.255.0
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 42.42.42.42
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 redistribute rip subnets
 passive-interface Loopback0
 network 10.4.0.0 0.0.255.255 area 4
!
router rip
 version 2
 network 172.16.0.0
 default-information originate
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R43 Completed Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R43
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.4.43.43 255.255.255.255
!
interface Loopback1
 ip address 172.16.2.43 255.255.255.0 secondary
 ip address 172.16.1.43 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial2/0
 ip address 172.16.0.43 255.255.255.0
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router rip
 version 2
 passive-interface default
 no passive-interface Serial2/0
 network 172.16.0.0
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

ISP Completed Configuration (Click)

!
!
!
!
!
!
!
!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ISP
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 100.1.1.1 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial2/0
 ip address 100.1.0.2 255.255.255.252
 serial restart-delay 0
!
interface Serial2/1
 ip address 100.1.0.6 255.255.255.252
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

関連記事

OSPFの仕組み