redistribute maximum-prefixコマンド

設定ミスなどによって、想定外の大量のルート情報がOSPFに再配送されることを防止するためにredistribute maximum-prefixコマンドを利用します。

redistribute maximum-prefixコマンドで、他のルーティングプロトコル(ルーティングプロセス)からOSPFに再配送されるルート情報の上限を決められます。

redistribute maximum-prefixコマンドのフォーマット

redistribute maximum-prefixコマンドはOSPFのコンフィグレーションモードで設定します。

redistribute maximum-prefixコマンド

(config)#router ospf <process-id>
(config-router)#redistribute maximum-prefix <maximum> [<threshold>] [warning-only]

<process-id> : OSPFプロセス番号
<maximum> : 再配送されるルートの上限。パーセンテージ
<threshold> : ワーニングメッセージを生成するしきい値

コマンドフォーマットはとてもシンプルです。基本的には、<maximum>でOSPFへ再配送されるルートの上限を決めるだけです。<threshold>でワーニングメッセージを生成するしきい値を決めます。<threshold>のデフォルトは75(%)で、小数点以下は切り捨てです。

また、warning-onlyのオプションをつけると、ワーニングメッセージを生成するだけで、設定した上限を超えてもOSPFへ再配送されます。

redistribute maximum-prefixコマンドの設定例

以下のシンプルなネットワーク構成でredistribute maximum-prefixコマンドでOSPFに再配送されるルートを制限します。

図 redistribute maximum-prefixコマンドの設定例 ネットワーク構成
図 redistribute maximum-prefixコマンドの設定例 ネットワーク構成

R1でOSPFへ再配送します。再配送元のルーティングプロセスはconnectedです。

制限なしのとき

10.1.1.0/24~10.1.6.0/24はR1のLo0に設定しているIPアドレスのconnectedのルート情報です。R1でconnectedのルート情報をOSPFに再配送しています。

R1

interface Loopback0
 ip address 10.1.2.1 255.255.255.0 secondary
 ip address 10.1.3.1 255.255.255.0 secondary
 ip address 10.1.4.1 255.255.255.0 secondary
 ip address 10.1.5.1 255.255.255.0 secondary
 ip address 10.1.6.1 255.255.255.0 secondary
 ip address 10.1.1.1 255.255.255.0
!
router ospf 1
 redistribute connected subnets

OSPFのLSDBにはLSAタイプ5で10.1.1.0/24~10.1.6.0/24の6つのルート情報が登録されています。

R1

R1#show ip ospf database

            OSPF Router with ID (1.1.1.1) (Process ID 1)

                Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
1.1.1.1         1.1.1.1         213         0x80000003 0x007DBC 1
2.2.2.2         2.2.2.2         214         0x80000002 0x003BF8 1

                Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
192.168.12.1    1.1.1.1         213         0x80000001 0x00C7EB

                Type-5 AS External Link States

Link ID         ADV Router      Age         Seq#       Checksum Tag
10.1.1.0        1.1.1.1         272         0x80000001 0x003060 0
10.1.2.0        1.1.1.1         272         0x80000001 0x00256A 0
10.1.3.0        1.1.1.1         272         0x80000001 0x001A74 0
10.1.4.0        1.1.1.1         272         0x80000001 0x000F7E 0
10.1.5.0        1.1.1.1         272         0x80000001 0x000488 0
10.1.6.0        1.1.1.1         272         0x80000001 0x00F892 0

redistribute maximum-prefixの設定

OSPFに再配送されるルート情報の上限をredistribute maximum-prefixコマンドで5にします。

R1

router ospf 1
 redistribute maximum-prefix 5

redistribute maximum-prefixコマンドを設定したあと、いったんOSPFプロセスをクリアします。

再配送されるルート情報の上限を5にすると、次のようなメッセージがコンソールに表示されます。

*Mar  1 00:08:28.755: %IPRT-4-REDIST_THR_PFX: Redistribution prefix threshold has been reached "ospf 1" - 3 prefixes
*Mar  1 00:08:28.759: %IPRT-4-REDIST_MAX_PFX: Redistribution prefix limit has been reached "ospf 1" - 5 prefixes

ワーニングメッセージを生成するしきい値は5*0.75=3(小数点以下切り捨て)です。3つ以上のルート情報が再配送されてワーニングメッセージが生成されています。そして、設定した上限を超過している旨のメッセージも表示されます。R1のLSDBを見ると、connectedから再配送されたルート情報は5つだけになっています。

R1

R1#show ip ospf database

            OSPF Router with ID (1.1.1.1) (Process ID 1)

                Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
1.1.1.1         1.1.1.1         260         0x80000004 0x0085B2 1
2.2.2.2         2.2.2.2         267         0x80000003 0x0043EE 1

                Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
192.168.12.2    2.2.2.2         267         0x80000001 0x008F1F

                Type-5 AS External Link States

Link ID         ADV Router      Age         Seq#       Checksum Tag
10.1.1.0        1.1.1.1         252         0x80000001 0x003060 0
10.1.2.0        1.1.1.1         252         0x80000001 0x00256A 0
10.1.3.0        1.1.1.1         252         0x80000001 0x001A74 0
10.1.5.0        1.1.1.1         252         0x80000001 0x000488 0
10.1.6.0        1.1.1.1         252         0x80000001 0x00F892 0

warning-onlyオプション

redistribute maximum-prefixコマンドにwarning-onlyのオプションをつけます。

R1

router ospf 1
 redistribute maximum-prefix 5 warning-only

コンソールに生成されるメッセージは同様です。

*Mar  1 00:16:45.791: %IPRT-4-REDIST_THR_PFX: Redistribution prefix threshold has been reached "ospf 1" - 3 prefixes
*Mar  1 00:16:45.795: %IPRT-4-REDIST_MAX_PFX: Redistribution prefix limit has been reached "ospf 1" - 5 prefixes

R1のLSDBを見るとwarning-onlyオプションを付けておくことで、上限を超えても再配送されていることがわかります。

R1

R1#show ip ospf database

            OSPF Router with ID (1.1.1.1) (Process ID 1)

                Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
1.1.1.1         1.1.1.1         84          0x80000005 0x0083B3 1
2.2.2.2         2.2.2.2         580         0x80000003 0x0043EE 1

                Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
192.168.12.2    2.2.2.2         580         0x80000001 0x008F1F

                Type-5 AS External Link States

Link ID         ADV Router      Age         Seq#       Checksum Tag
10.1.1.0        1.1.1.1         69          0x80000001 0x003060 0
10.1.2.0        1.1.1.1         69          0x80000001 0x00256A 0
10.1.3.0        1.1.1.1         69          0x80000001 0x001A74 0
10.1.4.0        1.1.1.1         69          0x80000001 0x000F7E 0
10.1.5.0        1.1.1.1         69          0x80000001 0x000488 0
10.1.6.0        1.1.1.1         69          0x80000001 0x00F892 0

関連記事

「ネットワークのおべんきょしませんか?」内の記事を検索

OSPFの仕組み