概要

フレームリレーのハブ&スポークトポロジでのOSPFの設定について、設定ミスの切り分けと修正を行います。

ネットワーク構成

次の図のような、R1を中心とするフレームリレーのハブ&スポークトポロジでOSPFによるルーティングを行います。

図 OSPF 設定ミスの切り分けと修正 Part6 ネットワーク構成
図 OSPF 設定ミスの切り分けと修正 Part6 ネットワーク構成

設定概要

各ルータのOSPFに関する設定は次のとおりです。これらの設定には、一部設定ミスがあります。

R1

interface Ethernet0/0
 ip address 192.168.1.1 255.255.255.0
!
interface Serial1/0
 ip address 192.168.123.1 255.255.255.0
 encapsulation frame-relay
 ip ospf priority 0
 frame-relay map ip 192.168.123.2 120 broadcast
 frame-relay map ip 192.168.123.3 130 broadcast
!
router ospf 1
 log-adjacency-changes
 network 192.168.0.0 0.0.255.255 area 0
 neighbor 192.168.123.2
 neighbor 192.168.123.3

R2

interface Ethernet0/0
 ip address 192.168.2.2 255.255.255.0
!
interface Serial1/0
 ip address 192.168.123.2 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 192.168.123.1 210 broadcast
 frame-relay map ip 192.168.123.3 210 broadcast
!
router ospf 1
 log-adjacency-changes
 network 192.168.0.0 0.0.255.255 area 0

R3

interface Ethernet0/0
 ip address 192.168.3.3 255.255.255.0
!
interface Serial1/0
 ip address 192.168.123.3 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 192.168.123.1 310 broadcast
 frame-relay map ip 192.168.123.2 310 broadcast
!
router ospf 1
 log-adjacency-changes
 network 192.168.0.0 0.0.255.255 area 0

トラブルの症状

OSPFネイバーは正常に確立しているものの、ルーティングテーブルに一部のルートが登録されていません。そのため、すべてのネットワーク間での通信ができない状態です。
トラブルの原因を特定するために、各ルータで以下のコマンドを実行しました。

  • show ip ospf neighbor
  • show ip route

R1

R1#show ip ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.123.2     1   2WAY/DROTHER    00:01:49    192.168.123.2   Serial1/0
192.168.123.3     1   FULL/DR         00:01:55    192.168.123.3   Serial1/0
R1#show ip route 
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.123.0/24 is directly connected, Serial1/0
C    192.168.1.0/24 is directly connected, Ethernet0/0
O    192.168.2.0/24 [110/74] via 192.168.123.2, 00:30:59, Serial1/0
O    192.168.3.0/24 [110/74] via 192.168.123.3, 00:30:59, Serial1/0

R2

R2#show ip ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.123.1     0   FULL/DROTHER    00:01:49    192.168.123.1   Serial1/0
R2#show ip route 
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.123.0/24 is directly connected, Serial1/0
O    192.168.1.0/24 [110/74] via 192.168.123.1, 00:31:37, Serial1/0
C    192.168.2.0/24 is directly connected, Ethernet0/0

R3

R3#show ip ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.123.1     0   FULL/DROTHER    00:01:32    192.168.123.1   Serial1/0
R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.123.0/24 is directly connected, Serial1/0
O    192.168.1.0/24 [110/74] via 192.168.123.1, 00:32:04, Serial1/0
O    192.168.2.0/24 [110/138] via 192.168.123.1, 00:32:04, Serial1/0
C    192.168.3.0/24 is directly connected, Ethernet0/0

問題

  • なぜOSPFネイバーが確立できているのに、ルーティングテーブルが不完全になっているのですか。
  • 正常にルーティングするためには、どのように設定を修正すればよいですか。

解答

なぜOSPFネイバーが確立できているのに、ルーティングテーブルが不完全になっているのですか。

フレームリレー上でDRの認識が正しくないため。ハブ&スポークトポロジでは、ハブルータをDRにしなければならない。

正常にルーティングするためには、どのように設定を修正すればよいですか。

R2

interface Serial1/0
 ip ospf priority 0

R3

interface Serial1/0
 ip ospf priority 0

ワンポイント

  • フレームリレーインタフェースのOSPFネットワークタイプはNON_BROADCAST
  • NON_BROADCASTでは、DR/BDRを選出する
  • ハブ&スポークトポロジでは、ハブルータをDRにしなければならない

解説

フレームリレーインタフェースのOSPFネットワークタイプはNON_BROADCASTで、DR/BDRの選出を行います。フレームリレーハブ&スポークトポロジでは、ハブとなるルータをDRにしなければいけません。

ハブルータであるR1のshow ip ospf neighborを見ると、R1はR3をDRとして認識しています。また、R1はR2をDROTHERとして認識しています。そして、R2、R3はともにR1をBDRとして、認識し自身をDRとしています。ハブ&スポークトポロジのため、R2とR3間は直接通信することができずに、各ルータでフレームリレーネットワーク上のDR/BDRの認識に整合性が取れていません。その結果、正しくルートの計算ができず一部のルーティングができなくなります。

この問題を解消するためには、フレームリレーネットワーク上の他のルータと直接通信できるハブルータのR1をDRにしなければいけません。R1を確実にDRにするためには、スポークルータであるR2、R3 Serial1/0のOSPFプライオリティを0にします。

R2/R3

interface serial1/0
 ip ospf priority 0

R2、R3 Serial1/0のOSPFプライオリティを0にしたあと、各ルータでshow ip ospf neighborを確認すると、すべてのルータがR1をDRとして認識し
ていることがわかります。

R1 show ip ospf neighbor

R1#show ip ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.123.2     0   FULL/DROTHER    00:01:54    192.168.123.2   Serial1/0
192.168.123.3     0   FULL/DROTHER    00:01:54    192.168.123.3   Serial1/0

R2 show ip ospf neighbor

R2#show ip ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.123.1     1   FULL/DR         00:01:57    192.168.123.1   Serial1/0

R3 show ip ospf neighbor

R3#show ip ospf neighbor 

Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.123.1     1   FULL/DR         00:01:38    192.168.123.1   Serial1/0

図 ハブ&スポークトポロジのDR
図 ハブ&スポークトポロジのDR

フレームリレーネットワーク上でハブルータであるR1がDRになったので、正しくルーティングできるようになります。R1~R3のルーティングテーブルは次のようになります。

R1 show ip route

R1#show ip route 
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.123.0/24 is directly connected, Serial1/0
C    192.168.1.0/24 is directly connected, Ethernet0/0
O    192.168.2.0/24 [110/74] via 192.168.123.2, 00:00:49, Serial1/0
O    192.168.3.0/24 [110/74] via 192.168.123.3, 00:00:49, Serial1/0

R2 show ip route

R2#show ip route 
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.123.0/24 is directly connected, Serial1/0
O    192.168.1.0/24 [110/74] via 192.168.123.1, 00:01:13, Serial1/0
C    192.168.2.0/24 is directly connected, Ethernet0/0
O    192.168.3.0/24 [110/74] via 192.168.123.3, 00:01:13, Serial1/0

R3 show ip route

R3#show ip route 
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.123.0/24 is directly connected, Serial1/0
O    192.168.1.0/24 [110/74] via 192.168.123.1, 00:01:31, Serial1/0
O    192.168.2.0/24 [110/74] via 192.168.123.2, 00:01:31, Serial1/0
C    192.168.3.0/24 is directly connected, Ethernet0/0

OSPFの仕組み