概要

広域イーサネットで相互接続している4拠点の社内ネットワークにおいて、OSPFによるルーティングを行う演習です。Part5では、設定ミスの切り分けと修正のトラブルシューティングです。

Part1:OSPFの基本設定
Part2:デフォルトルートの生成
Part3:スタブエリア
Part4:ルート集約
Part5:トラブルシューティング

ネットワーク構成

図 演習:実践的なOSPFルーティング 論理構成図
図 演習:実践的なOSPFルーティング 論理構成図

 図 演習:実践的なOSPFルーティング ルーティングプロトコル
図 演習:実践的なOSPFルーティング ルーティングプロトコル

設定条件

Part1:OSPFの基本設定

  1. 図 ルーティングプロトコルの構成のように、OSPFおよびRIPv2の設定を行います。OSPFルータのルータIDは、YY.YY.YY.YY(YY:ルータ番号)とします。また、将来的なギガビットイーサネット導入に対応できるように設定します。
  2. 不要なインタフェースにはルーティングプロトコルのパケットを送信しないようにします。
  3. R42では、RIPv2のルートをOSPFへ再配送します。また、R42はR43へRIPv2でデフォルトルートをアドバタイズします。
  4. 10.0.0.0/24上では、R11がDR、R12がBDRとなるようにします。また、MD5によるネイバー認証を行い、ネイバーの障害検出を4秒以内にできるようにします。

Part2デフォルトルートの生成

  1. R13、R14でインターネットへルーティングするためのデフォルトルートをスタティックで設定します。
  2. R13、R14でOSPFドメインにデフォルトルートを生成します。インターネットへのルーティングはR13を優先します。

Part3:スタブエリアの設定

  1. エリア2、エリア4にはLSAタイプ5をアドバタイズしないように設定します。エリア4にはインターネットへの接続性を確保するために、デフォルトルートをアドバタイズできるようにします。
  2. エリア3のLSDBのサイズが最も小さくなるように設定します。

Part4:ルート集約

  1. エリア1、エリア2、エリア3、エリア4のネットワークアドレスを集約してバックボーンエリアにアドバタイズします。
  2. RIPv2ドメインのルートを集約してOSPFドメインへアドバタイズします。

初期設定

「演習:実践的なOSPFルーティング Part1」から「演習:実践的なOSPFルーティング Part4」の設定を行っています。しかし、設定ミスが5つあります。設定ミスによるトラブルの症状は次のとおりです。

  1. R11 F0/0上でOSPFネイバーを確立できません。
  2. R13がデフォルトルートをアドバタイズしていません。
  3. R23が正常にOSPFネイバーを確立できません。
  4. R31が正常にOSPFネイバーを確立できません。
  5. RIPドメインのネットワークへの通信ができません。

すべての設定ミスを修正して、正常にOSPFルーティングできるようにしてください。

R11 Initial Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R11
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.1.11.11 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.0.11 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 ip ospf priority 255
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.1.1.11 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 11.11.11.11
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 area 1 range 10.1.0.0 255.255.0.0
 passive-interface Loopback0
 network 10.0.0.0 0.0.0.255 area 0
 network 10.1.0.0 0.0.255.255 area 1
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R12 Initial Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R12
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.1.12.12 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.0.12 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 ip ospf hello-interval 1
 ip ospf priority 100
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.1.1.12 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 12.12.12.12
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 area 1 range 10.1.0.0 255.255.0.0
 passive-interface Loopback0
 passive-interface Fa0/0
 network 10.0.0.0 0.0.0.255 area 0
 network 10.1.0.0 0.0.255.255 area 1
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R13 Initial Configuration (Click)

!
!
!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R13
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.1.13.13 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.1.2.13 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.1.1.13 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface Serial2/0
 ip address 100.1.0.1 255.255.255.252
 ip nat outside
 ip virtual-reassembly
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 13.13.13.13
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 passive-interface FastEthernet0/0
 passive-interface Loopback0
 network 10.1.0.0 0.0.255.255 area 1
 default-information originate metric-type 1
!
ip http server
ip forward-protocol nd
!
!
ip nat inside source list 1 interface Serial2/0 overload
!
access-list 1 permit 10.0.0.0 0.255.255.255
access-list 1 permit 172.16.0.0 0.0.255.255
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R14 Initial Configuration (Click)

!
!
!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R14
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.1.14.14 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.1.3.14 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.1.1.14 255.255.255.0
 ip ospf 1 area 0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface Serial2/0
 ip address 100.1.0.5 255.255.255.252
 ip nat outside
 ip virtual-reassembly
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 14.14.14.14
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 passive-interface FastEthernet0/0
 passive-interface Loopback0
 network 10.1.0.0 0.0.255.255 area 1
 default-information originate
!
ip http server
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 100.1.0.6
!
!
ip nat inside source list 1 interface Serial2/0 overload
!
access-list 1 permit 10.0.0.0 0.255.255.255
access-list 1 permit 172.16.0.0 0.0.255.255
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R21 Initial Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R21
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.2.21.21 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.0.21 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 ip ospf hello-interval 1
 ip ospf priority 0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.2.1.21 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 21.21.21.21
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 area 2 stub
 passive-interface Loopback0
 network 10.0.0.0 0.0.0.255 area 0
 network 10.2.0.0 0.0.255.255 area 2
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R22 Initial Configuration (Click)

!
!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R22
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.2.22.22 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.2.2.22 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.2.1.22 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 22.22.22.22
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 area 2 stub
 passive-interface FastEthernet0/0
 passive-interface Loopback0
 network 10.2.0.0 0.0.0.255 area 2
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R23 Initial Configuration (Click)

!
!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R23
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.2.23.23 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.2.3.23 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.2.1.23 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 23.23.23.23
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 passive-interface FastEthernet0/0
 passive-interface Loopback0
 network 10.2.0.0 0.0.255.255 area 2
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R31 Initial Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R31
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.3.31.31 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.0.31 255.255.255.0
 ip ospf message-digest-key 1 md5 cisco
 ip ospf hello-interval 1
 ip ospf priority 0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.3.1.31 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 23.23.23.23
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 area 3 stub no-summary
 area 3 range 10.3.0.0 255.255.0.0
 passive-interface FastEthernet0/0
 passive-interface Loopback0
 network 10.0.0.0 0.0.0.255 area 0
 network 10.2.0.0 0.0.255.255 area 2
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R41 Initial Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R41
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.4.41.41 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.0.41 255.255.255.0
 ip ospf authentication 
 ip ospf message-digest-key 1 md5 cisco
 ip ospf hello-interval 1
 ip ospf priority 0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.4.1.41 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 41.41.41.41
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 area 4 nssa default-information-originate
 area 4 range 10.4.0.0 255.255.0.0
 passive-interface Loopback0
 network 10.0.0.0 0.0.0.255 area 0
 network 10.4.0.0 0.0.255.255 area 4
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R42 Initial Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R42
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.4.42.42 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.4.1.42 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 ip address 172.16.0.42 255.255.255.0
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 42.42.42.42
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 area 4 nssa
 summary-address 172.16.0.0 255.255.252.0
 redistribute rip 
 passive-interface Loopback0
 network 10.4.0.0 0.0.255.255 area 4
!
router rip
 version 2
 network 172.16.0.0
 default-information originate
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R43 Initial Configuration (Click)

!
!
!
!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R43
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.4.43.43 255.255.255.255
!
interface Loopback1
 ip address 172.16.2.43 255.255.255.0 secondary
 ip address 172.16.1.43 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial2/0
 ip address 172.16.0.43 255.255.255.0
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router rip
 version 2
 passive-interface default
 no passive-interface Serial2/0
 network 172.16.0.0
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

ISP Initial Configuration (Click)

!
!
!
!
!
!
!
!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ISP
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 100.1.1.1 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial2/0
 ip address 100.1.0.2 255.255.255.252
 serial restart-delay 0
!
interface Serial2/1
 ip address 100.1.0.6 255.255.255.252
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

Part5:トラブルシューティング 切り分けと修正

1. Hello/Deadインターバルのミスマッチ

R11 FastEtehrnet0/0のHelloインターバルが他のルータと一致していないため、ネイバーを確立することができません。

切り分け

R11 切り分け

R11#debug ip ospf hello
OSPF hello events debugging is on
R11#
*Mar  1 00:03:18.567: OSPF: Rcv hello from 14.14.14.14 area 1 from FastEthernet1/0 10.1.1.14
*Mar  1 00:03:18.571: OSPF: End of hello processing
*Mar  1 00:03:18.611: OSPF: Rcv hello from 21.21.21.21 area 0 from FastEthernet0/0 10.0.0.21
*Mar  1 00:03:18.615: OSPF: Mismatched hello parameters from 10.0.0.21
*Mar  1 00:03:18.615: OSPF: Dead R 4 C 40, Hello R 1 C 10  Mask R 255.255.255.0 C 255.255.255.0
-- omitted --

設定の修正

R11 設定の修正

interface FastEthernet0/0
 ip ospf hello-interval 1

2.デフォルトルート(スタティック)の設定漏れ

R13のルーティングテーブルにISPをネクストホップとするデフォルトルートが存在しないため、default-information originateコマンドでデフォルトルートをアドバタイズできません。

切り分け

R13 切り分け

R13#show ip route 0.0.0.0
Routing entry for 0.0.0.0/0, supernet
  Known via "ospf 1", distance 110, metric 1, candidate default path
  Tag 1, type extern 2, forward metric 30
  Last update from 10.1.1.14 on FastEthernet1/0, 00:00:57 ago
  Routing Descriptor Blocks:
  * 10.1.1.14, from 14.14.14.14, 00:00:57 ago, via FastEthernet1/0
      Route metric is 1, traffic share count is 1
      Route tag 1

R13#show ip ospf database external self-originate

            OSPF Router with ID (13.13.13.13) (Process ID 1)

設定の修正

R13 設定の修正

ip route 0.0.0.0 0.0.0.0 100.1.0.2

3.スタブエリア設定のミスマッチ

R23でエリア2のスタブエリアの設定が行われていないので、他のルータとネイバーを確立することができません。

切り分け

R23 切り分け

R23#debug ip ospf hello
OSPF hello events debugging is on
R23#
*Mar  1 00:07:49.475: OSPF: Send hello to 224.0.0.5 area 2 on FastEthernet1/0 from 10.2.1.23
*Mar  1 00:07:50.443: OSPF: Rcv hello from 22.22.22.22 area 2 from FastEthernet1/0 10.2.1.22
*Mar  1 00:07:50.447: OSPF: Hello from 10.2.1.22 with mismatched Stub/Transit area option bit

設定の修正

R23 設定の修正

router ospf 1
 area 2 stub

4.ネイバー認証のミスマッチ

R31 FastEthernet0/0でMD5によるユーザ認証が有効化されていないので、他のルータとネイバーを確立することができません。

切り分け

R31 切り分け

R31#debug ip ospf adj
OSPF adjacency events debugging is on
R31#
*Mar  1 00:09:24.355: OSPF: Rcv pkt from 10.0.0.12, FastEthernet0/0 : Mismatch Authentication type. Input packet specified type 2, we use type 0

設定の修正

R31 設定の修正

interface FastEthernet0/0
 ip ospf authentication message-digest

5.再配送時のsubnetsオプション

R42でRIPからOSPFへ再配送するときにsubnetsオプションが付けられていないので、サブネッティングされたRIPドメインのルートがOSPFへ再配送されていません。

切り分け

R42 切り分け

R42#show ip ospf database nssa-external self-originate

            OSPF Router with ID (42.42.42.42) (Process ID 1)
R42#show run | section router ospf
router ospf 1
 router-id 42.42.42.42
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 area 4 nssa
 summary-address 172.16.0.0 255.255.252.0
 redistribute rip
 passive-interface Loopback0
 network 10.4.0.0 0.0.255.255 area 4

設定の修正

R42 設定の修正

router ospf 1
 redistribute rip subnets

正常な設定ファイル

R11 Correct Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R11
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.1.11.11 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.0.11 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 ip ospf hello-interval 1
 ip ospf priority 255
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.1.1.11 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 11.11.11.11
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 area 1 range 10.1.0.0 255.255.0.0
 passive-interface Loopback0
 network 10.0.0.0 0.0.0.255 area 0
 network 10.1.0.0 0.0.255.255 area 1
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R12 Correct Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R12
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.1.12.12 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.0.12 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 ip ospf hello-interval 1
 ip ospf priority 100
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.1.1.12 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 12.12.12.12
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 area 1 range 10.1.0.0 255.255.0.0
 passive-interface Loopback0
 network 10.0.0.0 0.0.0.255 area 0
 network 10.1.0.0 0.0.255.255 area 1
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R13 Correct Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R13
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.1.13.13 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.1.2.13 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.1.1.13 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface Serial2/0
 ip address 100.1.0.1 255.255.255.252
 ip nat outside
 ip virtual-reassembly
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 13.13.13.13
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 passive-interface FastEthernet0/0
 passive-interface Loopback0
 network 10.1.0.0 0.0.255.255 area 1
 default-information originate metric-type 1
!
ip http server
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 100.1.0.2
!
!
ip nat inside source list 1 interface Serial2/0 overload
!
access-list 1 permit 10.0.0.0 0.255.255.255
access-list 1 permit 172.16.0.0 0.0.255.255
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R14 Correct Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R14
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.1.14.14 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.1.3.14 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.1.1.14 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface Serial2/0
 ip address 100.1.0.5 255.255.255.252
 ip nat outside
 ip virtual-reassembly
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 14.14.14.14
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 passive-interface FastEthernet0/0
 passive-interface Loopback0
 network 10.1.0.0 0.0.255.255 area 1
 default-information originate
!
ip http server
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 100.1.0.6
!
!
ip nat inside source list 1 interface Serial2/0 overload
!
access-list 1 permit 10.0.0.0 0.255.255.255
access-list 1 permit 172.16.0.0 0.0.255.255
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R21 Correct Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R21
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.2.21.21 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.0.21 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 ip ospf hello-interval 1
 ip ospf priority 0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.2.1.21 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 21.21.21.21
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 area 2 stub
 area 2 range 10.2.0.0 255.255.0.0
 passive-interface Loopback0
 network 10.0.0.0 0.0.0.255 area 0
 network 10.2.0.0 0.0.255.255 area 2
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R22 Correct Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R22
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.2.22.22 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.2.2.22 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.2.1.22 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 22.22.22.22
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 area 2 stub
 passive-interface FastEthernet0/0
 passive-interface Loopback0
 network 10.2.0.0 0.0.255.255 area 2
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R23 Correct Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R23
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.2.23.23 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.2.3.23 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.2.1.23 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 23.23.23.23
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 area 2 stub
 passive-interface FastEthernet0/0
 passive-interface Loopback0
 network 10.2.0.0 0.0.255.255 area 2
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R31 Correct Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R31
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.3.31.31 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.0.31 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 ip ospf hello-interval 1
 ip ospf priority 0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.3.1.31 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 23.23.23.23
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 area 3 stub no-summary
 area 3 range 10.3.0.0 255.255.0.0
 passive-interface FastEthernet0/0
 passive-interface Loopback0
 network 10.0.0.0 0.0.0.255 area 0
 network 10.2.0.0 0.0.255.255 area 2
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R41 Correct Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R41
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.4.41.41 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.0.41 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 ip ospf hello-interval 1
 ip ospf priority 0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.4.1.41 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 41.41.41.41
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 area 4 nssa default-information-originate
 area 4 range 10.4.0.0 255.255.0.0
 passive-interface Loopback0
 network 10.0.0.0 0.0.0.255 area 0
 network 10.4.0.0 0.0.255.255 area 4
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R42 Correct Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R42
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.4.42.42 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.4.1.42 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 ip address 172.16.0.42 255.255.255.0
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 42.42.42.42
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 area 4 nssa
 summary-address 172.16.0.0 255.255.252.0
 redistribute rip subnets
 passive-interface Loopback0
 network 10.4.0.0 0.0.255.255 area 4
!
router rip
 version 2
 network 172.16.0.0
 default-information originate
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R43 Correct Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R43
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.4.43.43 255.255.255.255
!
interface Loopback1
 ip address 172.16.2.43 255.255.255.0 secondary
 ip address 172.16.1.43 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial2/0
 ip address 172.16.0.43 255.255.255.0
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router rip
 version 2
 passive-interface default
 no passive-interface Serial2/0
 network 172.16.0.0
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

ISP Correct Configuration (Click)

!
!
!
!
!
!
!
!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ISP
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 100.1.1.1 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial2/0
 ip address 100.1.0.2 255.255.255.252
 serial restart-delay 0
!
interface Serial2/1
 ip address 100.1.0.6 255.255.255.252
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

関連記事

関連記事




OSPFの仕組み