OSPFでのデフォルトルート生成

デフォルトルートをOSPFルートとして生成して、他のルータにアドバタイズするためには、以下のようにいくつかの方法があります。

  • default-information originateコマンド
  • スタブエリアにする

スタブエリアの設定によるデフォルトルートの生成について、簡単な設定例を解説します。


default-information originateコマンドを利用したデフォルトルートの生成については、以下の記事で解説しています。


スタブエリアによるデフォルトルートの生成

【ネットワーク構成】

図 OSPFデフォルトルートの生成(スタブエリア)
図 OSPFデフォルトルートの生成(スタブエリア)

【条件】

  • R2がR3へデフォルトルートをOSPFでアドバタイズして、すべてのインタフェースの接続性を確保できるようにします。
  • R2でのデフォルトルートの生成はエリア1をスタブエリアにすることによって行います。

【初期設定】

R1

interface Loopback0
 ip address 172.16.2.1 255.255.255.0 secondary
 ip address 172.16.1.1 255.255.255.0
!
interface Ethernet0/0
 ip address 192.168.12.1 255.255.255.0
!
ip route 192.168.0.0 255.255.0.0 192.168.12.2

R2

interface Loopback0
 ip address 192.168.2.2 255.255.255.0
 ip ospf network point-to-point
!
interface Ethernet0/0
 ip address 192.168.12.2 255.255.255.0
!
interface Ethernet0/1
 ip address 192.168.23.2 255.255.255.0
!
!
router ospf 100
 log-adjacency-changes
 network 192.168.2.0 0.0.0.255 area 0
 network 192.168.23.0 0.0.0.255 area 1

R3

interface Loopback0
 ip address 192.168.3.3 255.255.255.0
!
interface Ethernet0/0
 ip address 192.168.23.3 255.255.255.0
!
router ospf 100
 log-adjacency-changes
 network 192.168.3.0 0.0.0.255 area 1
 network 192.168.23.0 0.0.0.255 area 1

【Step1:R2でデフォルトルートの設定】

R2でR1のネットワークへパケットをルーティングするために、デフォルトルートをスタティックルートとして設定します。

R2

ip route 0.0.0.0 0.0.0.0 192.168.12.1

このデフォルトルートの設定は、あくまでもR1への接続性を確保するためです。スタブエリアのABRはルーティングテーブルにデフォルトルートがなくてもデフォルトルートを生成します。

【Step2:エリア1をスタブエリアにする】

エリア1を通常のスタブエリアとして設定します。エリア1に含まれているR2、R3でともにエリア1をスタブエリアとして指定します。

R2/R3

router ospf 100
 area 1 stub

【Step3:デフォルトルートの確認】

R3のOSPF LSDBおよびルーティングテーブルを見て、R2からデフォルトルートがアドバタイズされていることを確認します。

R3

R3#show ip ospf database

            OSPF Router with ID (192.168.3.3) (Process ID 100)

                Router Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum Link count
192.168.2.2     192.168.2.2     6           0x80000003 0x009AAD 1
192.168.3.3     192.168.3.3     5           0x80000003 0x00893A 2

                Net Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum
192.168.23.3    192.168.3.3     5           0x80000001 0x00E685

                Summary Net Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum
0.0.0.0         192.168.2.2     23          0x80000001 0x008B45
192.168.2.0     192.168.2.2     23          0x80000002 0x00C1A2
R3#show ip route
~省略~
Gateway of last resort is 192.168.23.2 to network 0.0.0.0
C    192.168.23.0/24 is directly connected, Ethernet0/0
O IA 192.168.2.0/24 [110/11] via 192.168.23.2, 00:00:11, Ethernet0/0
C    192.168.3.0/24 is directly connected, Loopback0
O*IA 0.0.0.0/0 [110/11] via 192.168.23.2, 00:00:11, Ethernet0/0

スタブエリアのABRであるR2(RID:192.168.2.2)はLSAタイプ3で配下のエリアにデフォルトルートをアドバタイズします。そのため、R3のルーティングテーブルにはO IAでデフォルトルートが登録されています。

【Step4:トータリースタブエリアへ変更】

エリア1をトータリースタブエリアとします。R2でarea 1 stub no-summaryの設定を行います。

R2

router ospf 100
 area 1 stub no-summary

【Step5:デフォルトルートの確認】

R3のOSPF LSDBおよびルーティングテーブルを見て、R2からデフォルトルートがアドバタイズされていることを確認します。

R3

R3#show ip ospf database

            OSPF Router with ID (192.168.3.3) (Process ID 100)

                Router Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum Link count
192.168.2.2     192.168.2.2     113         0x80000003 0x009AAD 1
192.168.3.3     192.168.3.3     112         0x80000003 0x00893A 2

                Net Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum
192.168.23.3    192.168.3.3     112         0x80000001 0x00E685

                Summary Net Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum
0.0.0.0         192.168.2.2     10          0x80000002 0x008946
R3#show ip route
~省略~

Gateway of last resort is 192.168.23.2 to network 0.0.0.0

C    192.168.23.0/24 is directly connected, Ethernet0/0
C    192.168.3.0/24 is directly connected, Loopback0
O*IA 0.0.0.0/0 [110/11] via 192.168.23.2, 00:00:43, Ethernet0/0

トータリースタブでもABRであるR2(RID:192.168.2.2)がLSAタイプ3でデフォルトルートを生成していることがわかります。通常のスタブエリアと異なり、トータリースタブエリアの場合は、デフォルトルートを表すLSAタイプ3しか存在しないこともわかります。

【Step4:NSSAへ変更】

エリア1をNSSAとします。R2、R3ともにエリア1をNSSAとして設定します。

R2/R3

router ospf 100
 no area 1 stub
 area 1 nssa

【Step5:デフォルトルートの確認】

R3のOSPF LSDBおよびルーティングテーブルを確認します。

R3

R3#show ip ospf database

            OSPF Router with ID (192.168.3.3) (Process ID 100)

                Router Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum Link count
192.168.2.2     192.168.2.2     42          0x80000005 0x002418 1
192.168.3.3     192.168.3.3     42          0x80000005 0x000DAC 2

                Net Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum
192.168.23.3    192.168.3.3     41          0x80000003 0x006AF7

                Summary Net Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum
192.168.2.0     192.168.2.2     52          0x80000002 0x004913
R3#show ip route
~省略~

Gateway of last resort is not set

C    192.168.23.0/24 is directly connected, Ethernet0/0
O IA 192.168.2.0/24 [110/11] via 192.168.23.2, 00:00:42, Ethernet0/0
C    192.168.3.0/24 is directly connected, Loopback0

R2はNSSAのエリア1にはデフォルトルートをアドバタイズしていません。

【Step6:NSSA内にデフォルトルートを生成】

NSSAではABRが自動的にデフォルトルートを生成するわけではありませ。NSSAでは、デフォルトルートを生成したいルータで明示的にarea nssa default-information-originateコマンドでデフォルトルートの生成を行います。ここでは、R2でデフォルトルートを生成するために設定を行います。

R2

router ospf 100
 area 1 nssa default-information-originate

【Step7:デフォルトルートの確認】

R3のLSDB、ルーティングテーブルを見て、R2でNSSA内に生成されたデフォルトルートを確認します。

R3

R3#show ip ospf database

            OSPF Router with ID (192.168.3.3) (Process ID 100)

                Router Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum Link count
192.168.2.2     192.168.2.2     176         0x80000005 0x002418 1
192.168.3.3     192.168.3.3     175         0x80000005 0x000DAC 2

                Net Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum
192.168.23.3    192.168.3.3     175         0x80000003 0x006AF7

                Summary Net Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum
192.168.2.0     192.168.2.2     186         0x80000002 0x004913

                Type-7 AS External Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum Tag
0.0.0.0         192.168.2.2     35          0x80000001 0x00E65D 0
R3#show ip route
~省略~

Gateway of last resort is 192.168.23.2 to network 0.0.0.0

C    192.168.23.0/24 is directly connected, Ethernet0/0
O IA 192.168.2.0/24 [110/11] via 192.168.23.2, 00:02:54, Ethernet0/0
C    192.168.3.0/24 is directly connected, Loopback0
O*N2 0.0.0.0/0 [110/1] via 192.168.23.2, 00:00:37, Ethernet0/0

R2でarea 1 nssa default-information-originateコマンドを設定することによって、LSAタイプ7でデフォルトルートを生成していることがわかります。そのため、R3のルーティングテーブルではO N2でデフォルトルートが登録されています。

【Step8:トータリーNSSAへ変更】

エリア1をトータリーNSSAに変更します。

R2

router ospf 100
 no area 1 nssa
 area 1 nssa no-summary

default-information-originateのオプションを削除するため、いったんNSSAの設定自体を削除しています。

【Step9:デフォルトルートの確認】

R3のLSDB、ルーティングテーブルを見て、R2でNSSA内に生成されたデフォルトルートを確認します。

R3

R3#show ip ospf database

            OSPF Router with ID (192.168.3.3) (Process ID 100)

                Router Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum Link count
192.168.2.2     192.168.2.2     38          0x80000007 0x00201A 1
192.168.3.3     192.168.3.3     300         0x80000005 0x000DAC 2

                Net Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum
192.168.23.3    192.168.3.3     300         0x80000003 0x006AF7

                Summary Net Link States (Area 1)

Link ID         ADV Router      Age         Seq#       Checksum
0.0.0.0         192.168.2.2     42          0x80000001 0x0013B5
R3#show ip route
~省略~

Gateway of last resort is 192.168.23.2 to network 0.0.0.0

C    192.168.23.0/24 is directly connected, Ethernet0/0
C    192.168.3.0/24 is directly connected, Loopback0
O*IA 0.0.0.0/0 [110/11] via 192.168.23.2, 00:00:38, Ethernet0/0

トータリーNSSAでは、通常のスタブやトータリースタブと同じようにLSAタイプ3でデフォルトルートを生成していることがわかります。そのため、R3のルーティングテーブルにはO IAでデフォルトルートが登録されています。

【Step10:通信確認】

R3およびR2にデフォルトルートが登録されているので、R3からR1への通信が可能です。

R3

R3#ping 172.16.1.1 source 192.168.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.3.3
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/12/20 ms
R3#ping 172.16.2.1 source 192.168.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.2.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.3.3
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/12/24 ms