概要

広域イーサネットで相互接続している4拠点の社内ネットワークにおいて、OSPFによるルーティングを行う演習です。Part4では、ルート集約を行ってルーティングテーブルのエントリを最適化します。

Part1:OSPFの基本設定
Part2:デフォルトルートの生成
Part3:スタブエリア
Part4:ルート集約
Part5:トラブルシューティング

ネットワーク構成

図 演習:実践的なOSPFルーティング 論理構成図
図 演習:実践的なOSPFルーティング 論理構成図

 図 演習:実践的なOSPFルーティング ルーティングプロトコル
図 演習:実践的なOSPFルーティング ルーティングプロトコル

設定条件

Part1:OSPFの基本設定

  1. 図 ルーティングプロトコルの構成のように、OSPFおよびRIPv2の設定を行います。OSPFルータのルータIDは、YY.YY.YY.YY(YY:ルータ番号)とします。また、将来的なギガビットイーサネット導入に対応できるように設定します。
  2. 不要なインタフェースにはルーティングプロトコルのパケットを送信しないようにします。
  3. R42では、RIPv2のルートをOSPFへ再配送します。また、R42はR43へRIPv2でデフォルトルートをアドバタイズします。
  4. 10.0.0.0/24上では、R11がDR、R12がBDRとなるようにします。また、MD5によるネイバー認証を行い、ネイバーの障害検出を4秒以内にできるようにします。

Part2デフォルトルートの生成

  1. R13、R14でインターネットへルーティングするためのデフォルトルートをスタティックで設定します。
  2. R13、R14でOSPFドメインにデフォルトルートを生成します。インターネットへのルーティングはR13を優先します。

Part3:スタブエリアの設定

  1. エリア2、エリア4にはLSAタイプ5をアドバタイズしないように設定します。エリア4にはインターネットへの接続性を確保するために、デフォルトルートをアドバタイズできるようにします。
  2. エリア3のLSDBのサイズが最も小さくなるように設定します。

Part4:ルート集約 -> このページで設定

  1. エリア1、エリア2、エリア3、エリア4のネットワークアドレスを集約してバックボーンエリアにアドバタイズします。
  2. RIPv2ドメインのルートを集約してOSPFドメインへアドバタイズします。

初期設定

「演習:実践的なOSPFルーティング Part3」完了時点から開始します。

R11 Initial Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R11
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.1.11.11 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.0.11 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 ip ospf hello-interval 1
 ip ospf priority 255
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.1.1.11 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 11.11.11.11
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 passive-interface Loopback0
 network 10.0.0.0 0.0.0.255 area 0
 network 10.1.0.0 0.0.255.255 area 1
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R12 Initial Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R12
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.1.12.12 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.0.12 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 ip ospf hello-interval 1
 ip ospf priority 100
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.1.1.12 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 12.12.12.12
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 passive-interface Loopback0
 network 10.0.0.0 0.0.0.255 area 0
 network 10.1.0.0 0.0.255.255 area 1
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R13 Initial Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R13
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.1.13.13 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.1.2.13 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.1.1.13 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface Serial2/0
 ip address 100.1.0.1 255.255.255.252
 ip nat outside
 ip virtual-reassembly
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 13.13.13.13
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 passive-interface FastEthernet0/0
 passive-interface Loopback0
 network 10.1.0.0 0.0.255.255 area 1
 default-information originate metric-type 1
!
ip http server
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 100.1.0.2
!
!
ip nat inside source list 1 interface Serial2/0 overload
!
access-list 1 permit 10.0.0.0 0.255.255.255
access-list 1 permit 172.16.0.0 0.0.255.255
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R14 Initial Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R14
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.1.14.14 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.1.3.14 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.1.1.14 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface Serial2/0
 ip address 100.1.0.5 255.255.255.252
 ip nat outside
 ip virtual-reassembly
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 14.14.14.14
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 passive-interface FastEthernet0/0
 passive-interface Loopback0
 network 10.1.0.0 0.0.255.255 area 1
 default-information originate
!
ip http server
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 100.1.0.6
!
!
ip nat inside source list 1 interface Serial2/0 overload
!
access-list 1 permit 10.0.0.0 0.255.255.255
access-list 1 permit 172.16.0.0 0.0.255.255
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R21 Initial Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R21
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.2.21.21 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.0.21 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 ip ospf hello-interval 1
 ip ospf priority 0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.2.1.21 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 21.21.21.21
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 area 2 stub
 passive-interface Loopback0
 network 10.0.0.0 0.0.0.255 area 0
 network 10.2.0.0 0.0.255.255 area 2
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R22 Initial Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R22
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.2.22.22 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.2.2.22 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.2.1.22 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 22.22.22.22
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 area 2 stub
 passive-interface FastEthernet0/0
 passive-interface Loopback0
 network 10.2.0.0 0.0.255.255 area 2
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R23 Initial Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R23
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.2.23.23 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.2.3.23 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.2.1.23 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 23.23.23.23
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 area 2 stub
 passive-interface FastEthernet0/0
 passive-interface Loopback0
 network 10.2.0.0 0.0.255.255 area 2
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R31 Initial Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R31
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.3.31.31 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.0.31 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 ip ospf hello-interval 1
 ip ospf priority 0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.3.1.31 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 23.23.23.23
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 area 3 stub no-summary
 passive-interface FastEthernet0/0
 passive-interface Loopback0
 network 10.0.0.0 0.0.0.255 area 0
 network 10.2.0.0 0.0.255.255 area 2
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R41 Initial Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R41
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.4.41.41 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.0.41 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 ip ospf hello-interval 1
 ip ospf priority 0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.4.1.41 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 41.41.41.41
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 area 4 nssa default-information-originate
 passive-interface Loopback0
 network 10.0.0.0 0.0.0.255 area 0
 network 10.4.0.0 0.0.255.255 area 4
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R42 Initial Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R42
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.4.42.42 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.4.1.42 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 ip address 172.16.0.42 255.255.255.0
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 42.42.42.42
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 area 4 nssa
 redistribute rip subnets
 passive-interface Loopback0
 network 10.4.0.0 0.0.255.255 area 4
!
router rip
 version 2
 network 172.16.0.0
 default-information originate
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R43 Initial Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R43
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.4.43.43 255.255.255.255
!
interface Loopback1
 ip address 172.16.2.43 255.255.255.0 secondary
 ip address 172.16.1.43 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial2/0
 ip address 172.16.0.43 255.255.255.0
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router rip
 version 2
 passive-interface default
 no passive-interface Serial2/0
 network 172.16.0.0
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

ISP Initial Configuration (Click)

!
!
!
!
!
!
!
!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ISP
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 100.1.1.1 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial2/0
 ip address 100.1.0.2 255.255.255.252
 serial restart-delay 0
!
interface Serial2/1
 ip address 100.1.0.6 255.255.255.252
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

設定と確認 Part4:ルート集約

Step1:エリア0のLSDBの確認

ルート集約にともなってLSDBの変化を確認するために、ルート集約の設定を行う前のエリア0のLSDBを確認します。R11でエリア0のLSDBを見ると、次のようになります。

R11 show ip ospf database

R11#show ip ospf database 

            OSPF Router with ID (11.11.11.11) (Process ID 1)

                Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
11.11.11.11     11.11.11.11     1053        0x8000005B 0x00BC7B 1
12.12.12.12     12.12.12.12     1895        0x8000005A 0x0080AF 1
21.21.21.21     21.21.21.21     847         0x8000005A 0x00508E 1
31.31.31.31     31.31.31.31     1419        0x8000005B 0x00DFA3 1
41.41.41.41     41.41.41.41     999         0x8000005B 0x0077AF 1

                Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
10.0.0.11       11.11.11.11     1053        0x8000005D 0x00BD01

                Summary Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
10.1.1.0        11.11.11.11     1053        0x8000005A 0x001F6E
10.1.1.0        12.12.12.12     1895        0x8000005A 0x000188
10.1.2.0        11.11.11.11     1053        0x8000005A 0x00412D
10.1.2.0        12.12.12.12     1895        0x8000005A 0x002347
10.1.3.0        11.11.11.11     1055        0x8000005A 0x003637
10.1.3.0        12.12.12.12     1897        0x8000005A 0x001851
10.1.11.11      11.11.11.11     1057        0x8000005A 0x001F76
10.1.11.11      12.12.12.12     1899        0x8000005A 0x002E45
10.1.12.12      11.11.11.11     1057        0x8000005A 0x00373E
10.1.12.12      12.12.12.12     1899        0x8000005A 0x00EBA3
10.1.13.13      11.11.11.11     1057        0x8000005A 0x002251
10.1.13.13      12.12.12.12     1899        0x8000005A 0x00046B
10.1.14.14      11.11.11.11     1057        0x8000005A 0x000D64
10.1.14.14      12.12.12.12     1899        0x8000005A 0x00EE7E
10.2.1.0        21.21.21.21     851         0x8000005A 0x00E57E
10.2.2.0        21.21.21.21     1609        0x80000025 0x007208
10.2.3.0        21.21.21.21     1609        0x80000025 0x006712
10.2.21.21      21.21.21.21     851         0x8000005A 0x001345
10.2.22.22      21.21.21.21     1609        0x80000025 0x0095D7
10.2.23.23      21.21.21.21     1609        0x80000025 0x0080EA
10.3.1.0        31.31.31.31     1423        0x8000005A 0x00AC8E
10.3.31.31      31.31.31.31     1423        0x8000005A 0x000714
10.4.1.0        41.41.41.41     1002        0x8000005A 0x00739E
10.4.41.41      41.41.41.41     1002        0x8000005A 0x00FAE2
10.4.42.42      41.41.41.41     1259        0x80000024 0x007F74

                Summary ASB Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
13.13.13.13     11.11.11.11     1298        0x8000003C 0x008EF3
13.13.13.13     12.12.12.12     1899        0x8000003C 0x00700E
14.14.14.14     11.11.11.11     1298        0x8000003C 0x00601E
14.14.14.14     12.12.12.12     1899        0x8000003C 0x004238

-- omitted --

R11は、エリア1内のネットワークアドレス(10.1.x.x/24)を表すLSAタイプ3をエリア0のLSDBに生成しています。これは、R12も同様です。

Step2:エリア1のルート集約の設定

エリア1とエリア0のABRであるR11およびR12でエリア1のルート集約の設定を行います。エリア1のルートを10.1.0.0/16で集約します。

R11/R12 エリア1のルート集約の設定

router ospf 1
 area 1 range 10.1.0.0 255.255.0.0

Step3:エリア1のルート集約の確認

集約の設定をしたあと、R11でエリア0のLSDBを確認します。

R11 show ip ospf database

R11#show ip ospf database 

            OSPF Router with ID (11.11.11.11) (Process ID 1)

                Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
11.11.11.11     11.11.11.11     1711        0x8000005B 0x00BC7B 1
12.12.12.12     12.12.12.12     530         0x8000005B 0x007EB0 1
21.21.21.21     21.21.21.21     1504        0x8000005A 0x00508E 1
31.31.31.31     31.31.31.31     57          0x8000005C 0x00DDA4 1
41.41.41.41     41.41.41.41     1656        0x8000005B 0x0077AF 1

                Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
10.0.0.11       11.11.11.11     1711        0x8000005D 0x00BD01

                Summary Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
10.1.0.0        11.11.11.11     401         0x80000001 0x00B94B
10.1.0.0        12.12.12.12     396         0x80000001 0x009B65
10.2.1.0        21.21.21.21     1504        0x8000005A 0x00E57E
10.2.2.0        21.21.21.21     221         0x80000026 0x007009
10.2.3.0        21.21.21.21     222         0x80000026 0x006513
10.2.21.21      21.21.21.21     1505        0x8000005A 0x001345
10.2.22.22      21.21.21.21     222         0x80000026 0x0093D8
10.2.23.23      21.21.21.21     222         0x80000026 0x007EEB
10.3.1.0        31.31.31.31     58          0x8000005B 0x00AA8F
10.3.31.31      31.31.31.31     58          0x8000005B 0x000515
10.4.1.0        41.41.41.41     1656        0x8000005A 0x00739E
10.4.41.41      41.41.41.41     1656        0x8000005A 0x00FAE2
10.4.42.42      41.41.41.41     1913        0x80000024 0x007F74

                Summary ASB Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
13.13.13.13     11.11.11.11     1952        0x8000003C 0x008EF3
13.13.13.13     12.12.12.12     531         0x8000003D 0x006E0F
14.14.14.14     11.11.11.11     1952        0x8000003C 0x00601E
14.14.14.14     12.12.12.12     531         0x8000003D 0x004039

-- omitted --

R11は集約ルート10.1.0.0/16を表すLSAタイプ3をエリア0のLSDBに生成していることがわかります。R12も同様です。

図 エリア1のルート集約
図 エリア1のルート集約

そして、他のルータのルーティングテーブルを確認するとエリア1のルートが集約されていることが分かります。R21では、次のようになります。

R21 show ip route ospf

R21#show ip route ospf 
     172.16.0.0/24 is subnetted, 3 subnets
O E2    172.16.0.0 [110/20] via 10.0.0.41, 00:11:49, FastEthernet0/0
O E2    172.16.1.0 [110/20] via 10.0.0.41, 00:11:49, FastEthernet0/0
O E2    172.16.2.0 [110/20] via 10.0.0.41, 00:11:49, FastEthernet0/0
     10.0.0.0/8 is variably subnetted, 13 subnets, 3 masks
O IA    10.3.1.0/24 [110/60] via 10.0.0.31, 20:10:31, FastEthernet0/0
O       10.2.23.23/32 [110/31] via 10.2.1.23, 20:47:15, FastEthernet1/0
O       10.2.22.22/32 [110/31] via 10.2.1.22, 20:47:15, FastEthernet1/0
O IA    10.3.31.31/32 [110/31] via 10.0.0.31, 20:10:31, FastEthernet0/0
O       10.2.2.0/24 [110/60] via 10.2.1.22, 20:47:15, FastEthernet1/0
O       10.2.3.0/24 [110/60] via 10.2.1.23, 20:47:15, FastEthernet1/0
O IA    10.1.0.0/16 [110/31] via 10.0.0.12, 00:11:48, FastEthernet0/0
                    [110/31] via 10.0.0.11, 00:11:48, FastEthernet0/0
O IA    10.4.42.42/32 [110/61] via 10.0.0.41, 20:10:10, FastEthernet0/0
O IA    10.4.41.41/32 [110/31] via 10.0.0.41, 20:10:31, FastEthernet0/0
O IA    10.4.1.0/24 [110/60] via 10.0.0.41, 20:10:31, FastEthernet0/0
O*E1 0.0.0.0/0 [110/61] via 10.0.0.12, 00:11:49, FastEthernet0/0
               [110/61] via 10.0.0.11, 00:11:49, FastEthernet0/0

Step4:エリア2/エリア3/エリア4のルート集約の設定

エリア2、エリア3、エリア4でもエリア1と同様に、ABRでルート集約の設定を行います。

R21 ルート集約

router ospf 1
 area 2 range 10.2.0.0 255.255.0.0

R31 ルート集約

router ospf 1
 area 3 range 10.3.0.0 255.255.0.0

R41 ルート集約

router ospf 1
 area 4 range 10.4.0.0 255.255.0.0

Step5:エリア2/エリア3/エリア4のルート集約の確認

各エリアのルート集約を確認するために、エリア0のLSDBを確認します。R11では、次のような表示になります。

R11

R11#show ip ospf database 

            OSPF Router with ID (11.11.11.11) (Process ID 1)

                Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
11.11.11.11     11.11.11.11     1727        0x8000005E 0x00B67E 1
12.12.12.12     12.12.12.12     588         0x8000005E 0x0078B3 1
21.21.21.21     21.21.21.21     1734        0x8000005D 0x004A91 1
31.31.31.31     31.31.31.31     47          0x8000005F 0x00D7A7 1
41.41.41.41     41.41.41.41     1679        0x8000005E 0x0071B2 1

                Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
10.0.0.11       11.11.11.11     1727        0x80000060 0x00B704

                Summary Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
10.1.0.0        11.11.11.11     485         0x80000004 0x00B34E
10.1.0.0        12.12.12.12     588         0x80000004 0x009568
10.2.0.0        21.21.21.21     253         0x80000001 0x00805B
10.3.0.0        31.31.31.31     226         0x80000001 0x00476B
10.4.0.0        41.41.41.41     194         0x80000001 0x000E7B

                Summary ASB Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
13.13.13.13     11.11.11.11     1984        0x8000003F 0x0088F6
13.13.13.13     12.12.12.12     588         0x80000040 0x006812
14.14.14.14     11.11.11.11     1984        0x8000003F 0x005A21
14.14.14.14     12.12.12.12     588         0x80000040 0x003A3C

-- omitted --

各エリアのABRがエリア内のネットワークアドレスを集約して、エリア0にLSAタイプ3として集約ルートをアドバタイズしていることがわかります。

図 各エリアのルート集約
図 各エリアのルート集約

また、いずれかのルータでルーティングテーブルを確認すると、他のエリアのルートがすべて/16のサブネットマスクで集約されていることがわかります。R21では、次のような表示です。

R21 show ip route ospf

R21#show ip route ospf 
     172.16.0.0/24 is subnetted, 3 subnets
O E2    172.16.0.0 [110/20] via 10.0.0.41, 00:14:04, FastEthernet0/0
O E2    172.16.1.0 [110/20] via 10.0.0.41, 00:14:04, FastEthernet0/0
O E2    172.16.2.0 [110/20] via 10.0.0.41, 00:14:04, FastEthernet0/0
     10.0.0.0/8 is variably subnetted, 11 subnets, 3 masks
O       10.2.23.23/32 [110/31] via 10.2.1.23, 00:15:08, FastEthernet1/0
O       10.2.22.22/32 [110/31] via 10.2.1.22, 00:15:08, FastEthernet1/0
O       10.2.0.0/16 is a summary, 00:15:08, Null0
O IA    10.3.0.0/16 [110/31] via 10.0.0.31, 00:14:42, FastEthernet0/0
O       10.2.2.0/24 [110/60] via 10.2.1.22, 00:15:08, FastEthernet1/0
O       10.2.3.0/24 [110/60] via 10.2.1.23, 00:15:08, FastEthernet1/0
O IA    10.1.0.0/16 [110/31] via 10.0.0.12, 00:15:08, FastEthernet0/0
                    [110/31] via 10.0.0.11, 00:15:08, FastEthernet0/0
O IA    10.4.0.0/16 [110/31] via 10.0.0.41, 00:14:09, FastEthernet0/0
O*E1 0.0.0.0/0 [110/61] via 10.0.0.12, 00:14:04, FastEthernet0/0
               [110/61] via 10.0.0.11, 00:14:04, FastEthernet0/0

Step6:エリア4のLSDBの確認

外部ルートのルート集約にともなうLSDBの変化を確認するために、主役の設定を行う前のLSDBを確認します。

R42 show ip ospf database

R42#show ip ospf database 

            OSPF Router with ID (42.42.42.42) (Process ID 1)

                Router Link States (Area 4)

Link ID         ADV Router      Age         Seq#       Checksum Link count
41.41.41.41     41.41.41.41     440         0x80000063 0x004F2F 2
42.42.42.42     42.42.42.42     932         0x80000062 0x002F46 2

                Net Link States (Area 4)

Link ID         ADV Router      Age         Seq#       Checksum
10.4.1.42       42.42.42.42     932         0x80000061 0x00D3D0

                Summary Net Link States (Area 4)

Link ID         ADV Router      Age         Seq#       Checksum
10.0.0.0        41.41.41.41     440         0x8000005F 0x004AC1
10.1.0.0        41.41.41.41     1203        0x80000004 0x00FE66
10.2.0.0        41.41.41.41     1054        0x80000001 0x00F86E
10.3.0.0        41.41.41.41     1027        0x80000001 0x00EC79

                Type-7 AS External Link States (Area 4)
          
Link ID         ADV Router      Age         Seq#       Checksum Tag
0.0.0.0         41.41.41.41     692         0x80000028 0x00EBF9 0
172.16.0.0      42.42.42.42     932         0x80000028 0x009F08 0
172.16.1.0      42.42.42.42     932         0x80000028 0x009412 0
172.16.2.0      42.42.42.42     932         0x80000028 0x00891C 0

R42は、RIPドメイン内のネットワークアドレス(172.16.0.0/24、172.16.1.0/24、172.16.2.0/24)を表すLSAタイプ7をエリア4のLSDBに生成しています。

Step7:RIPドメインのルート集約の設定

R42でRIPドメインのルートを集約してOSPFドメインへアドバタイズします。

R42 ルート集約の設定

router ospf 1
 summary-address 172.16.0.0 255.255.252.0

Step8:RIPドメインのルート集約の確認

外部ルートのルート集約を確認するために、エリア4のLSDBを確認します。R42では、次のような表示になります。

R42 show ip ospf database

R42#show ip ospf database 

            OSPF Router with ID (42.42.42.42) (Process ID 1)

                Router Link States (Area 4)

Link ID         ADV Router      Age         Seq#       Checksum Link count
41.41.41.41     41.41.41.41     821         0x80000063 0x004F2F 2
42.42.42.42     42.42.42.42     1313        0x80000062 0x002F46 2

                Net Link States (Area 4)

Link ID         ADV Router      Age         Seq#       Checksum
10.4.1.42       42.42.42.42     1313        0x80000061 0x00D3D0

                Summary Net Link States (Area 4)

Link ID         ADV Router      Age         Seq#       Checksum
10.0.0.0        41.41.41.41     821         0x8000005F 0x004AC1
10.1.0.0        41.41.41.41     1584        0x80000004 0x00FE66
10.2.0.0        41.41.41.41     1434        0x80000001 0x00F86E
10.3.0.0        41.41.41.41     1408        0x80000001 0x00EC79

                Type-7 AS External Link States (Area 4)
          
Link ID         ADV Router      Age         Seq#       Checksum Tag
0.0.0.0         41.41.41.41     1073        0x80000028 0x00EBF9 0
172.16.0.0      42.42.42.42     77          0x80000029 0x008E1B 0

R42はRIPドメインのルートを172.16.0.0/22に集約して、エリア4(NSSA)にLSAタイプ7としてアドバタイズしていることがわかります。

図 RIPドメインのルート集約
図 RIPドメインのルート集約

R41でルーティングテーブルを確認すると、RIPドメインの集約ルートが「O N2」のルートとして登録されていることがわかります。

R41 show ip route ospf

R41#show ip route ospf 
     172.16.0.0/22 is subnetted, 1 subnets
O N2    172.16.0.0 [110/20] via 10.4.1.42, 00:09:16, FastEthernet1/0
     10.0.0.0/8 is variably subnetted, 8 subnets, 3 masks
O IA    10.2.0.0/16 [110/31] via 10.0.0.21, 00:30:53, FastEthernet0/0
O IA    10.3.0.0/16 [110/31] via 10.0.0.31, 00:30:53, FastEthernet0/0
O IA    10.1.0.0/16 [110/31] via 10.0.0.12, 00:30:53, FastEthernet0/0
                    [110/31] via 10.0.0.11, 00:30:53, FastEthernet0/0
O       10.4.42.42/32 [110/31] via 10.4.1.42, 00:30:53, FastEthernet1/0
O       10.4.0.0/16 is a summary, 00:30:53, Null0
O*E1 0.0.0.0/0 [110/61] via 10.0.0.12, 00:30:53, FastEthernet0/0
               [110/61] via 10.0.0.11, 00:30:53, FastEthernet0/0

また、LSAタイプ7はNSSAのABRであるR41がLSAタイプ5に変換してエリア0にアドバタイズします。R11のLSDBとルーティングテーブルを確認すると、RIPドメインの集約ルートがLSAタイプ5に変換されていることがわかります。

R11 show ip ospf database/show ip route ospf

R11#show ip ospf database 

            OSPF Router with ID (11.11.11.11) (Process ID 1)

-- omitted --

                Type-5 AS External Link States

Link ID         ADV Router      Age         Seq#       Checksum Tag
0.0.0.0         13.13.13.13     1662        0x80000040 0x00B10E 1
0.0.0.0         14.14.14.14     1504        0x80000040 0x001724 1
172.16.0.0      41.41.41.41     643         0x8000002A 0x003F77 0
R11#show ip route ospf 
     172.16.0.0/22 is subnetted, 1 subnets
O E2    172.16.0.0 [110/20] via 10.0.0.41, 00:10:47, FastEthernet0/0
     10.0.0.0/8 is variably subnetted, 12 subnets, 3 masks
O IA    10.2.0.0/16 [110/31] via 10.0.0.21, 00:33:29, FastEthernet0/0
O       10.1.3.0/24 [110/60] via 10.1.1.14, 02:16:56, FastEthernet1/0
O IA    10.3.0.0/16 [110/31] via 10.0.0.31, 00:33:02, FastEthernet0/0
O       10.1.2.0/24 [110/60] via 10.1.1.13, 02:16:56, FastEthernet1/0
O       10.1.14.14/32 [110/31] via 10.1.1.14, 02:16:56, FastEthernet1/0
O       10.1.13.13/32 [110/31] via 10.1.1.13, 02:16:56, FastEthernet1/0
O       10.1.12.12/32 [110/31] via 10.1.1.12, 02:16:56, FastEthernet1/0
O       10.1.0.0/16 is a summary, 02:16:56, Null0
O IA    10.4.0.0/16 [110/31] via 10.0.0.41, 00:32:29, FastEthernet0/0
O*E1 0.0.0.0/0 [110/31] via 10.1.1.13, 00:32:24, FastEthernet1/0

Part4完了の設定ファイル

R11 Completed Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R11
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.1.11.11 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.0.11 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 ip ospf hello-interval 1
 ip ospf priority 255
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.1.1.11 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 11.11.11.11
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 area 1 range 10.1.0.0 255.255.0.0
 passive-interface Loopback0
 network 10.0.0.0 0.0.0.255 area 0
 network 10.1.0.0 0.0.255.255 area 1
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R12 Completed Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R12
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.1.12.12 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.0.12 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 ip ospf hello-interval 1
 ip ospf priority 100
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.1.1.12 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 12.12.12.12
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 area 1 range 10.1.0.0 255.255.0.0
 passive-interface Loopback0
 network 10.0.0.0 0.0.0.255 area 0
 network 10.1.0.0 0.0.255.255 area 1
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R13 Completed Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R13
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.1.13.13 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.1.2.13 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.1.1.13 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface Serial2/0
 ip address 100.1.0.1 255.255.255.252
 ip nat outside
 ip virtual-reassembly
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 13.13.13.13
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 passive-interface FastEthernet0/0
 passive-interface Loopback0
 network 10.1.0.0 0.0.255.255 area 1
 default-information originate metric-type 1
!
ip http server
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 100.1.0.2
!
!
ip nat inside source list 1 interface Serial2/0 overload
!
access-list 1 permit 10.0.0.0 0.255.255.255
access-list 1 permit 172.16.0.0 0.0.255.255
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R14 Completed Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R14
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.1.14.14 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.1.3.14 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.1.1.14 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface Serial2/0
 ip address 100.1.0.5 255.255.255.252
 ip nat outside
 ip virtual-reassembly
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 14.14.14.14
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 passive-interface FastEthernet0/0
 passive-interface Loopback0
 network 10.1.0.0 0.0.255.255 area 1
 default-information originate
!
ip http server
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 100.1.0.6
!
!
ip nat inside source list 1 interface Serial2/0 overload
!
access-list 1 permit 10.0.0.0 0.255.255.255
access-list 1 permit 172.16.0.0 0.0.255.255
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R21 Completed Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R21
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.2.21.21 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.0.21 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 ip ospf hello-interval 1
 ip ospf priority 0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.2.1.21 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 21.21.21.21
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 area 2 stub
 area 2 range 10.2.0.0 255.255.0.0
 passive-interface Loopback0
 network 10.0.0.0 0.0.0.255 area 0
 network 10.2.0.0 0.0.255.255 area 2
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R22 Completed Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R22
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.2.22.22 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.2.2.22 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.2.1.22 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 22.22.22.22
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 area 2 stub
 passive-interface FastEthernet0/0
 passive-interface Loopback0
 network 10.2.0.0 0.0.255.255 area 2
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R23 Completed Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R23
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.2.23.23 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.2.3.23 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.2.1.23 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 23.23.23.23
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 area 2 stub
 passive-interface FastEthernet0/0
 passive-interface Loopback0
 network 10.2.0.0 0.0.255.255 area 2
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R31 Completed Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R31
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.3.31.31 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.0.31 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 ip ospf hello-interval 1
 ip ospf priority 0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.3.1.31 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 23.23.23.23
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 area 3 stub no-summary
 area 3 range 10.3.0.0 255.255.0.0
 passive-interface FastEthernet0/0
 passive-interface Loopback0
 network 10.0.0.0 0.0.0.255 area 0
 network 10.2.0.0 0.0.255.255 area 2
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R41 Completed Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R41
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.4.41.41 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.0.0.41 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 ip ospf hello-interval 1
 ip ospf priority 0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.4.1.41 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 41.41.41.41
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 area 4 nssa default-information-originate
 area 4 range 10.4.0.0 255.255.0.0
 passive-interface Loopback0
 network 10.0.0.0 0.0.0.255 area 0
 network 10.4.0.0 0.0.255.255 area 4
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R42 Completed Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R42
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.4.42.42 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 10.4.1.42 255.255.255.0
 duplex auto
 speed auto
!
interface Serial2/0
 ip address 172.16.0.42 255.255.255.0
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router ospf 1
 router-id 42.42.42.42
 log-adjacency-changes
 auto-cost reference-bandwidth 3000
 area 4 nssa
 summary-address 172.16.0.0 255.255.252.0
 redistribute rip subnets
 passive-interface Loopback0
 network 10.4.0.0 0.0.255.255 area 4
!
router rip
 version 2
 network 172.16.0.0
 default-information originate
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

R43 Completed Configuration (Click)

!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R43
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.4.43.43 255.255.255.255
!
interface Loopback1
 ip address 172.16.2.43 255.255.255.0 secondary
 ip address 172.16.1.43 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial2/0
 ip address 172.16.0.43 255.255.255.0
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
router rip
 version 2
 passive-interface default
 no passive-interface Serial2/0
 network 172.16.0.0
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

ISP Completed Configuration (Click)

!
!
!
!
!
!
!
!
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ISP
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 100.1.1.1 255.255.255.0
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial2/0
 ip address 100.1.0.2 255.255.255.252
 serial restart-delay 0
!
interface Serial2/1
 ip address 100.1.0.6 255.255.255.252
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
!
ip http server
ip forward-protocol nd
!
!
!
!
!
!
control-plane
!
!
!
!
mgcp behavior g729-variants static-pt
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
!
end

関連記事

OSPFの仕組み