概要

シンプルなネットワーク構成でEIGRPを利用しているときに、オフセットリストによってメトリックを加算して最適ルートを決定する設定を行います。

ネットワーク構成

図 オフセットリストの設定例 EIGRP ネットワーク構成
図 オフセットリストの設定例 EIGRP ネットワーク構成

初期設定

R1/R2のEIGRPに関連する設定の抜粋は、以下の通りです。

R1

interface Ethernet0/0
 ip address 192.168.12.1 255.255.255.0
!
interface Ethernet0/1
 ip address 192.168.21.1 255.255.255.0
!
router eigrp 1
 network 192.168.0.0 0.0.255.255
 no auto-summary

R2

interface Loopback0
 ip address 192.168.2.2 255.255.255.0
!
interface Ethernet0/0
 ip address 192.168.12.2 255.255.255.0
!
interface Ethernet0/1
 ip address 192.168.21.2 255.255.255.0
!
router eigrp 1
 network 192.168.0.0 0.0.255.255
 no auto-summary

初期設定の状態では、R1のEIGRPトポロジテーブル上で192.168.2.0/24のルート情報はメトリック(FD)409600で2つ学習しています。そして、ルーティングテーブルには等コストロードバランスで登録されています。

R1 show ip eigrp topology / show ip route eigrp

R1#show ip eigrp topology
IP-EIGRP Topology Table for AS(1)/ID(192.168.21.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 192.168.12.0/24, 1 successors, FD is 281600
        via Connected, Ethernet0/0
P 192.168.2.0/24, 2 successors, FD is 409600
        via 192.168.12.2 (409600/128256), Ethernet0/0
        via 192.168.21.2 (409600/128256), Ethernet0/1
P 192.168.21.0/24, 1 successors, FD is 281600
        via Connected, Ethernet0/1
R1#show ip route eigrp
D    192.168.2.0/24 [90/409600] via 192.168.21.2, 00:03:45, Ethernet0/1
                    [90/409600] via 192.168.12.2, 00:03:45, Ethernet0/0

また、メトリックを計算する要素として、Delayは6000μsecです。トポロジテーブルで192.168.2.0/24の詳細を確認します。

R1 show ip eigrp topology 192.168.2.0

R1#show ip eigrp topology 192.168.2.0
IP-EIGRP (AS 1): Topology entry for 192.168.2.0/24
  State is Passive, Query origin flag is 1, 2 Successor(s), FD is 409600
  Routing Descriptor Blocks:
  192.168.12.2 (Ethernet0/0), from 192.168.12.2, Send flag is 0x0
      Composite metric is (409600/128256), Route is Internal
      Vector metric:
        Minimum bandwidth is 10000 Kbit
        Total delay is 6000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 1
  192.168.21.2 (Ethernet0/1), from 192.168.21.2, Send flag is 0x0
      Composite metric is (409600/128256), Route is Internal
      Vector metric:
        Minimum bandwidth is 10000 Kbit
        Total delay is 6000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 1

オフセットリストの設定

R1/R2で以下のようにオフセットリストを設定します。

  • R1 E0/0で192.168.2.0/24のルート情報を受信時にオフセット25600加算
  • R2 E0/1で192.168.2.0/24のルート情報を送信時にオフセット51200加算

オフセット25600はDelay 1000μsecに相当します。オフセット51200はDelay 2000μsecに相当します。これにより、R1のルーティングテーブルで192.168.2.0/24のルート情報は、等コストロードバランスではなくE0/0で受信したルート情報を最適ルートになるようにします。

R1

router eigrp 1
 offset-list 1 in 25600 Ethernet0/0
!
access-list 1 permit 192.168.2.0

R2

router eigrp 1
 offset-list 1 out 51200 Ethernet0/1
!
access-list 1 permit 192.168.2.0

オフセットリストの確認

R1でshow ip protocolsを見ると、E0/0でルート情報を受信時にオフセットリストが適用されていることがわかります。

R1

R1#show ip protocols
Routing Protocol is "eigrp 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Incoming routes in Ethernet0/0 will have 25600 added to metric if on list 1
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
~省略~

オフセットリストでメトリックを加算する対象のルート情報は、ACL1で指定しています。

R1

R1#show access-lists
Standard IP access list 1
    10 permit 192.168.2.0 (7 matches)

この場合のACLは、ルート情報のネットワークアドレスを意味しています。ネットワークアドレスが「192.168.2.0」のルート情報がオフセットリストでメトリックを加算する対象です。サブネットマスクについてはみていません。

同様にR2でshow ip protocolsを見ると、E0/1からルートを送信時にオフセットリストが適用されていることがわかります。

R2

R2#show ip protocols
Routing Protocol is "eigrp 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Outgoing routes in Ethernet0/1 will have 51200 added to metric if on list 1
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
~省略~

そして、R1のEIGRPトポロジテーブルは、以下のようになります。

R1

R1#show ip eigrp topology
IP-EIGRP Topology Table for AS(1)/ID(192.168.21.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 192.168.12.0/24, 1 successors, FD is 281600
        via Connected, Ethernet0/0
P 192.168.2.0/24, 1 successors, FD is 409600
        via 192.168.12.2 (435200/153856), Ethernet0/0
        via 192.168.21.2 (460800/179456), Ethernet0/1
P 192.168.21.0/24, 1 successors, FD is 281600
        via Connected, Ethernet0/1
R1#show ip eigrp topology 192.168.2.0
IP-EIGRP (AS 1): Topology entry for 192.168.2.0/24
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 409600
  Routing Descriptor Blocks:
  192.168.12.2 (Ethernet0/0), from 192.168.12.2, Send flag is 0x0
      Composite metric is (435200/153856), Route is Internal
      Vector metric:
        Minimum bandwidth is 10000 Kbit
        Total delay is 7000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 1
  192.168.21.2 (Ethernet0/1), from 192.168.21.2, Send flag is 0x0
      Composite metric is (460800/179456), Route is Internal
      Vector metric:
        Minimum bandwidth is 10000 Kbit
        Total delay is 8000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 1

R2から受信した192.168.2.0/24のルート情報のメトリックは、オフセットリストによってDelay 1000μsec相当増加しています。また、R3から受信した192.168.2.0/24のルート情報のメトリックは、オフセットリストによってDelay 2000μsec相当増加しています。

最後にR1のルーティングテーブルを見ると、192.168.2.0/24の最適ルートはE0/0で受信するルート情報になっています。

R1

R1# show ip route eigrp
D    192.168.2.0/24 [90/435200] via 192.168.12.2, 00:18:50, Ethernet0/0

図 オフセットリストの動作
図 オフセットリストの動作

関連記事

IPルーティング応用