概要

OSPFとEIGRPの再配送について、設定ミスの切り分け修正を行います。OSPFへの再配送ではsubunetsオプションを指定すること、EIGRPへの再配送ではシードメトリックが必要なことがポイントです。

ネットワーク構成

下記のネットワーク構成において、R2でEIGRPとOSPFの双方向再配送を設定しています。

図 再配送 設定ミスの切り分けと修正 Part1 ネットワーク構成
図 再配送 設定ミスの切り分けと修正 Part1 ネットワーク構成

設定概要

以下の設定は、各ルータのルーティングプロトコルに関連する設定を抜き出したものです。これらの設定には、一部設定ミスがあります。

R1

interface FastEthernet0/0
 ip address 10.1.1.1 255.255.255.0
!
interface FastEthernet1/0
 ip address 192.168.12.1 255.255.255.0
!
router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 network 10.1.1.0 0.0.0.255 area 0
 network 192.168.12.0 0.0.0.255 area 0

R2

interface FastEthernet0/0
 ip address 192.168.12.2 255.255.255.0
!
interface FastEthernet1/0
 ip address 192.168.23.2 255.255.255.0
!
!
router eigrp 1
 redistribute ospf 1
 network 192.168.23.0
 no auto-summary
!
router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 redistribute eigrp 1
 network 192.168.12.0 0.0.0.255 area 0

R3

interface FastEthernet0/0
 ip address 192.168.23.3 255.255.255.0
!
interface FastEthernet1/0
 ip address 10.3.3.3 255.255.255.0
!
router eigrp 1
 network 10.0.0.0
 network 192.168.23.0
 no auto-summary

トラブルの症状

R2でOSPFとEIGRPの双方向再配送を行っているのですが、OSPFドメインのR1、EIGRPドメインのR3で正しくルート情報を学習できていません。R1およびR3のルーティングテーブルは次のようになっています。

R1 show ip route

R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
C    192.168.12.0/24 is directly connected, FastEthernet1/0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, FastEthernet0/0
O E2 192.168.23.0/24 [110/20] via 192.168.12.2, 00:31:45, FastEthernet1/0

R3 show ip route

R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
     10.0.0.0/24 is subnetted, 1 subnets
C       10.3.3.0 is directly connected, FastEthernet1/0
C    192.168.23.0/24 is directly connected, FastEthernet0/0

R1とR3で正しくルーティングテーブルにルート情報が登録されていないので、10.1.1.0/24と10.3.3.0/24間の通信が正常にできません。R2のルーティングテーブルには、10.1.1.0/24、10.3.3.0/24のルートがきちんと登録されています。

R2 show ip route

R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
C    192.168.12.0/24 is directly connected, FastEthernet0/0
     10.0.0.0/24 is subnetted, 2 subnets
D       10.3.3.0 [90/30720] via 192.168.23.3, 00:32:26, FastEthernet1/0
O       10.1.1.0 [110/2] via 192.168.12.1, 00:33:54, FastEthernet0/0
C    192.168.23.0/24 is directly connected, FastEthernet1/0

そのため、このトラブルの原因はOSPFやEIGRP自体の設定が間違っているわけではなく、R2での再配送の設定が間違っている可能性が高いです。R2での再配送の動作を確認するために、次のコマンドを実行しました。

R2

  • show ip protocols
  • show ip eigrp topology
  • show ip ospf database

R2 showコマンドの結果

R2#show ip protocols
Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 2.2.2.2
  It is an autonomous system boundary router
  Redistributing External Routes from,
    eigrp 1
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    192.168.12.0 0.0.0.255 area 0
 Reference bandwidth unit is 100 mbps
  Routing Information Sources:
    Gateway         Distance      Last Update
    1.1.1.1              110      00:36:23
  Distance: (default is 110)
 
Routing Protocol is "eigrp 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Redistributing: ospf 1, eigrp 1
  EIGRP NSF-aware route hold timer is 240s
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    192.168.23.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.23.3          90      00:34:55
  Distance: internal 90 external 170
 
R2#show ip eigrp topology
IP-EIGRP Topology Table for AS(1)/ID(192.168.23.2)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status
 
P 10.3.3.0/24, 1 successors, FD is 30720
        via 192.168.23.3 (30720/28160), FastEthernet1/0
P 192.168.23.0/24, 1 successors, FD is 28160
        via Connected, FastEthernet1/0
R2#show ip ospf database
 
            OSPF Router with ID (2.2.2.2) (Process ID 1)
 
                Router Link States (Area 0)
 
Link ID         ADV Router      Age         Seq#       Checksum Link count
1.1.1.1         1.1.1.1         193         0x80000003 0x00819C 2
2.2.2.2         2.2.2.2         305         0x80000008 0x003FEB 1
 
                Net Link States (Area 0)
 
Link ID         ADV Router      Age         Seq#       Checksum
192.168.12.2    2.2.2.2         305         0x80000002 0x008D20
 
                Type-5 AS External Link States
 
Link ID         ADV Router      Age         Seq#       Checksum Tag
192.168.23.0    2.2.2.2         305         0x80000002 0x00F91D 0

設定概要およびshowコマンドの結果からトラブルの原因となっている設定ミスを判断し、次の問題に回答してください。

問題

  • なぜR1、R3でルーティングテーブルに正常にルート情報が登録されていないのですか?
  • 10.1.1.0/24と10.3.3.0/24のネットワーク間で正しく通信できるようにするためにはどのように設定を修正すればよいですか。

解答

なぜR1、R3でルーティングテーブルに正常にルート情報が登録されていないのですか?

OSPFへの再配送時にsubnetsの指定が抜けているので、EIGRPドメインの10.3.3.0/24のルート情報がOSPFドメインに再配送されないから。また、EIGRPへの再配送時にシードメトリックの指定が抜けているので、OSPFドメインのルート情報がEIGRPドメインに再配送されないから。

10.1.1.0/24と10.3.3.0/24のネットワーク間で正しく通信できるようにするためにはどのように設定を修正すればよいですか。

R2

router eigrp 1
 redistribute ospf 1 metric 100000 10 255 1 1500
!
router ospf 1
 redistribute eigrp 1 subnets

ワンポイント

  • EIGRPに再配送するときには必ずシードメトリックを指定する
  • OSPFに再配送するときには必ずsubnetsを指定する

解説

EIGRP、OSPFへの再配送の際に間違えやすい典型的な設定ミスに関しての問題です。

【EIGRPへの再配送の設定ミス】

EIGRPへルートを再配送するときには、シードメトリックの指定を行わなければなりません。シードメトリックの指定がないとルートのメトリックは∞と見なされて、再配送自体されなくなってしまいます。ただし、connected、staticのみ例外です。connected、staticからEIGRPへ再配送した場合は、シードメトリックを指定してなくても再配送されます。

OSPFドメインのルートをEIGRPドメインに再配送するためには、R2で次のようにシードメトリックの指定を行います。

R2 OSPFからEIGRPへの再配送

router eigrp 1
 redistribute ospf 1 metric 100000 10 255 1 1500

EIGRPなのでメトリックのパラメータとしてBW、Delay、Reliablity、Load、MTUを指定します。このネットワーク構成では、値自体は適当で構いません。シードメトリックを指定すれば、OSPFのルートがEIGRPへ再配送されます。このことは、R2でshow ip eigrp topologyを見ると確認できます。

R2 show ip eigrp topology

R2#show ip eigrp topology
IP-EIGRP Topology Table for AS(1)/ID(192.168.23.2)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 10.1.1.0/24, 1 successors, FD is 28160
        via Redistributed (28160/0)
P 10.3.3.0/24, 1 successors, FD is 30720
        via 192.168.23.3 (30720/28160), FastEthernet1/0
P 192.168.12.0/24, 1 successors, FD is 28160
        via Redistributed (28160/0)
P 192.168.23.0/24, 1 successors, FD is 28160
        via Connected, FastEthernet1/0

すると、R3でOSPFドメインのルート 10.1.1.0/24と192.168.12.0/24 を確認できます。

R3 show ip route

R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

D EX 192.168.12.0/24 [170/30720] via 192.168.23.2, 00:09:23, FastEthernet0/0
     10.0.0.0/24 is subnetted, 2 subnets
C       10.3.3.0 is directly connected, FastEthernet1/0
D EX    10.1.1.0 [170/30720] via 192.168.23.2, 00:09:23, FastEthernet0/0
C    192.168.23.0/24 is directly connected, FastEthernet0/0

【OSPFへの再配送の設定ミス】

OSPFへ再配送するときには、デフォルトでサブネッティングされたルート情報は再配送の対象外です。サブネッティングされたルート情報をOSPFに再配送する場合は、redistributeコマンドの中でsubnetsを指定します。一般的なネットワーク構成では、当たり前のようにサブネッティングしているアドレッシングを行います。そのため、OSPFへ再配送するときにはsubnetsの指定は必須だと考えてください。R2で次のようにsubnetsの指定を追加して、OSPFへEIGPRドメインのサブネッティングされたルート情報 10.3.3.0/24 を再配送できるようにします。

R2 EIGRPからOSPFへの再配送

router ospf 1
 redistribute eigrp 1 subnets

subnetsを指定すると、R2のLSDB上で10.3.3.0/24のLSAタイプ5が生成されます。R2のLSDBは次のようになります。

R2 show ip ospf database

R2#show ip ospf database

            OSPF Router with ID (2.2.2.2) (Process ID 1)

                Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
1.1.1.1         1.1.1.1         1430        0x80000002 0x00F826 2
2.2.2.2         2.2.2.2         1429        0x80000002 0x004BE5 1

                Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
192.168.12.2    2.2.2.2         1429        0x80000001 0x008F1F

                Type-5 AS External Link States

Link ID         ADV Router      Age         Seq#       Checksum Tag
10.3.3.0        2.2.2.2         3           0x80000001 0x00E3A4 0
192.168.23.0    2.2.2.2         1468        0x80000001 0x00FB1C 0

すると、R1でEIGRPドメインの10.3.3.0/24と192.168.23.0/24のルートがルーティングテーブルに登録されるようになります。

R1 show ip route

R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.12.0/24 is directly connected, FastEthernet1/0
     10.0.0.0/24 is subnetted, 2 subnets
O E2    10.3.3.0 [110/20] via 192.168.12.2, 00:02:13, FastEthernet1/0
C       10.1.1.0 is directly connected, FastEthernet0/0
O E2 192.168.23.0/24 [110/20] via 192.168.12.2, 00:25:54, FastEthernet1/0

EIGRPへの再配送とOSPFへの再配送の設定ミスを修正すると、EIGRPドメインとOSPFドメイン間での通信が可能になります。R1からR3の10.3.3.3への通信を確認します。

R1 ping

R1#ping 10.3.3.3 source 10.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.3.3.3, timeout is 2 seconds:
Packet sent with a source address of 10.1.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/29/72 ms

【設定ミスのまとめ】

今回解説したEIGRPとOSPFの再配送の設定ミスを図にまとめています。

図 再配送 設定ミスの切り分けと修正 Part1 設定ミスのまとめ
図 再配送 設定ミスの切り分けと修正 Part1 設定ミスのまとめ


関連記事

IPルーティング応用