概要

シンプルなネットワーク構成でRIPを利用しているときに、オフセットリストによってメトリックを加算して最適ルートを決定する設定を確認を行います。

ネットワーク構成

図 オフセットリストの設定例 RIP ネットワーク構成
図 オフセットリストの設定例 RIP ネットワーク構成

初期設定

R1/R2のRIPに関連する設定の抜粋は、以下の通りです。

R1

interface Ethernet0/0
 ip address 192.168.12.1 255.255.255.0
!
interface Ethernet0/1
 ip address 192.168.21.1 255.255.255.0
!
router rip
 version 2
 network 192.168.12.0
 network 192.168.21.0
 no auto-summary

R2

interface Loopback0
 ip address 192.168.2.2 255.255.255.0
!
interface Ethernet0/0
 ip address 192.168.12.2 255.255.255.0
!
interface Ethernet0/1
 ip address 192.168.21.2 255.255.255.0
!
router rip
 version 2
 network 192.168.2.0
 network 192.168.12.0
 network 192.168.21.0
 no auto-summary

初期設定の状態では、R1のRIPデータベース上で、192.168.2.0/24のルート情報は、メトリック1で2つ学習しています。そして、ルーティングテーブルには等コストロードバランスで登録されています。

R1 show ip rip database/show ip route rip

R1#show ip rip database
192.168.2.0/24    auto-summary
192.168.2.0/24
    [1] via 192.168.21.2, 00:00:13, Ethernet0/1
    [1] via 192.168.12.2, 00:00:15, Ethernet0/0
192.168.12.0/24    auto-summary
192.168.12.0/24    directly connected, Ethernet0/0
192.168.21.0/24    auto-summary
192.168.21.0/24    directly connected, Ethernet0/1
R1#show ip route rip
R    192.168.2.0/24 [120/1] via 192.168.21.2, 00:00:16, Ethernet0/1
                    [120/1] via 192.168.12.2, 00:00:17, Ethernet0/0

オフセットリストの設定

R1/R2で以下のようにオフセットリストを設定します。

  • R1 E0/0で192.168.2.0/24のルート情報を受信時にメトリック3加算
  • R2 E0/1で192.168.2.0/24のルート情報を送信時にメトリック5加算

これにより、R1のルーティングテーブルで192.168.2.0/24のルート情報は、等コストロードバランスではなくE0/0で受信したルート情報を最適ルートになるようにします。

R1

router rip
 offset-list 1 in 3 Ethernet0/0
!
access-list 1 permit 192.168.2.0

R2

router rip
 offset-list 1 out 5 Ethernet0/1
!
access-list 1 permit 192.168.2.0

オフセットリストの確認

R1でshow ip protocolsを見ると、E0/0受信時にオフセットリストが適用されていることがわかります。

R1

R1#show ip protocols
Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Incoming routes in Ethernet0/0 will have 3 added to metric if on list 1
  Sending updates every 30 seconds, next due in 17 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
~省略~

オフセットリストでメトリックを加算する対象のルート情報は、ACL1で指定しています。

R1

R1#show access-lists
Standard IP access list 1
    10 permit 192.168.2.0 (7 matches)

この場合のACLは、ルート情報のネットワークアドレスを意味しています。ネットワークアドレスが「192.168.2.0」のルート情報がオフセットリストでメトリックを加算する対象です。サブネットマスクについてはみていません。

同様にR2でshow ip protocolsを見ると、E0/1からルートを送信時にオフセットリストが適用されていることがわかります。

R2

R2#show ip protocols
Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Outgoing routes in Ethernet0/1 will have 5 added to metric if on list 1
  Sending updates every 30 seconds, next due in 22 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
~省略~

そして、R1のRIPデータベースには192.168.2.0/24のルート情報はメトリック4で登録されています。

R1

R1#show ip rip database
192.168.2.0/24    auto-summary
192.168.2.0/24
    [4] via 192.168.12.2, 00:00:22, Ethernet0/0
192.168.12.0/24    auto-summary
192.168.12.0/24    directly connected, Ethernet0/0
192.168.21.0/24    auto-summary
192.168.21.0/24    directly connected, Ethernet0/1

E0/1で受信するルート情報は、RIPデータベース上では見えていませんが、debug ip ripを実行するとE0/1で受信する192.168.2.0/24のルート情報のメトリックが5加算されて6になっていることがわかります。

R1

R1#debug ip rip
RIP protocol debugging is on
~省略~
*Mar  1 00:27:48.643: RIP: received v2 update from 192.168.21.2 on Ethernet0/1
*Mar  1 00:27:48.643:      192.168.2.0/24 via 0.0.0.0 in 6 hops
*Mar  1 00:27:48.647:      192.168.12.0/24 via 0.0.0.0 in 1 hops
R1#u all

最後にR1のルーティングテーブルを見ると、192.168.2.0/24の最適ルートはE0/0で受信するルート情報になっています。

R1

R1#show ip route rip
R    192.168.2.0/24 [120/4] via 192.168.12.2, 00:00:12, Ethernet0/0

図 オフセットリストの動作
図 オフセットリストの動作

関連記事

「ネットワークのおべんきょしませんか?」内の記事を検索

IPルーティング応用