概要

RIPv2/OSPF/EIGRPの3つのルーティングプロトコルを利用しているネットワーク構成で最適ルートを制御するための設定を考えます。

ネットワーク構成

図 ルート制御 ケーススタディ Part3 ネットワーク構成
図 ルート制御 ケーススタディ Part3 ネットワーク構成

設定概要

各ルータのルーティングに関する設定は次のとおりです。

R1

interface Ethernet0/0
 ip address 192.168.12.1 255.255.255.0
!
interface Ethernet0/1
 ip address 192.168.13.1 255.255.255.0
!
interface Ethernet0/2
 ip address 192.168.14.1 255.255.255.0
!
interface Ethernet0/3
 ip address 192.168.15.1 255.255.255.0
!
interface Ethernet1/0
 ip address 192.168.16.1 255.255.255.0
!
interface Ethernet1/1
 ip address 192.168.17.1 255.255.255.0
!
router eigrp 1
 network 192.168.16.0
 network 192.168.17.0
 no auto-summary
!
router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 network 192.168.14.0 0.0.0.255 area 0
 network 192.168.15.0 0.0.0.255 area 0
!
router rip
 version 2
 network 192.168.12.0
 network 192.168.13.0

R2

interface Ethernet0/0
 ip address 192.168.12.2 255.255.255.0
!
interface Ethernet0/1
 ip address 192.168.28.2 255.255.255.0
!
router rip
 version 2
 network 192.168.12.0
 network 192.168.28.0
 no auto-summary

R3

interface Ethernet0/0
 ip address 192.168.13.3 255.255.255.0
!
interface Ethernet0/1
 ip address 192.168.38.3 255.255.255.0
!
router rip
 version 2
 network 192.168.13.0
 network 192.168.38.0
 no auto-summary

R4

interface Ethernet0/0
 ip address 192.168.14.4 255.255.255.0
!
interface Ethernet0/1
 ip address 192.168.48.4 255.255.255.0
!
router ospf 1
 router-id 4.4.4.4
 log-adjacency-changes
 network 192.168.0.0 0.0.255.255 area 0

R5

interface Ethernet0/0
 ip address 192.168.15.5 255.255.255.0
!
interface Ethernet0/1
 ip address 192.168.58.5 255.255.255.0
!
router ospf 1
 router-id 5.5.5.5
 log-adjacency-changes
 network 192.168.0.0 0.0.255.255 area 0

R6

interface Ethernet0/0
 ip address 192.168.16.6 255.255.255.0
!
interface Ethernet0/1
 ip address 192.168.68.6 255.255.255.0
!
router eigrp 1
 network 192.168.0.0 0.0.255.255
 no auto-summary

R7

interface Ethernet0/0
 ip address 192.168.17.7 255.255.255.0
!
interface Ethernet0/1
 ip address 192.168.78.7 255.255.255.0
!
router eigrp 1
 network 192.168.0.0 0.0.255.255
 no auto-summary

R8

interface Loopback0
 ip address 192.168.2.8 255.255.255.0 secondary
 ip address 192.168.4.8 255.255.255.0 secondary
 ip address 192.168.6.8 255.255.255.0 secondary
 ip address 192.168.1.8 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback3
 ip address 192.168.3.8 255.255.255.0
 ip ospf network point-to-point
!
interface Loopback5
 ip address 192.168.5.8 255.255.255.0
 ip ospf network point-to-point
!
interface Ethernet0/0
 ip address 192.168.28.8 255.255.255.0
!
interface Ethernet0/1
 ip address 192.168.38.8 255.255.255.0
!
interface Ethernet0/2
 ip address 192.168.48.8 255.255.255.0
!
interface Ethernet0/3
 ip address 192.168.58.8 255.255.255.0
!
interface Ethernet1/0
 ip address 192.168.68.8 255.255.255.0
!
interface Ethernet1/1
 ip address 192.168.78.8 255.255.255.0
!
router eigrp 1
 network 192.168.1.0
 network 192.168.2.0
 network 192.168.3.0
 network 192.168.4.0
 network 192.168.5.0
 network 192.168.6.0
 network 192.168.68.0
 network 192.168.78.0
 no auto-summary
!
router ospf 1
 router-id 8.8.8.8
 log-adjacency-changes
 network 192.168.1.0 0.0.0.255 area 0
 network 192.168.2.0 0.0.0.255 area 0
 network 192.168.3.0 0.0.0.255 area 0
 network 192.168.4.0 0.0.0.255 area 0
 network 192.168.5.0 0.0.0.255 area 0
 network 192.168.6.0 0.0.0.255 area 0
 network 192.168.48.0 0.0.0.255 area 0
 network 192.168.58.0 0.0.0.255 area 0
!
router rip
 version 2
 network 192.168.1.0
 network 192.168.2.0
 network 192.168.3.0
 network 192.168.4.0
 network 192.168.5.0
 network 192.168.6.0
 network 192.168.28.0
 network 192.168.38.0

問題

RIPルートの制御

R1のルーティングテーブルに192.168.1.0/24と192.168.2.0/24がRIPルートとして次のように見えるようにしてください。ただし、RIPルートのメトリックを変更してはいけません。

R1

R1#show ip route rip
R    192.168.1.0/24 [89/2] via 192.168.12.2, 00:00:06, Ethernet0/0
R    192.168.2.0/24 [89/2] via 192.168.13.3, 00:00:06, Ethernet0/1

上記の出力はRIPルートの抜粋です。

OSPFルートの制御

R1のルーティングテーブルで192.168.3.0/24と192.168.4.0/24がOSPFルートとして次のように見えるようにしてください。

R1

R1#show ip route ospf
O    192.168.4.0/24 [89/21] via 192.168.15.5, 00:00:55, Ethernet0/3
                    [89/21] via 192.168.14.4, 00:00:55, Ethernet0/2
O    192.168.3.0/24 [89/21] via 192.168.15.5, 00:00:55, Ethernet0/3
                    [89/21] via 192.168.14.4, 00:00:55, Ethernet0/2

上記の出力はOSPFルートの抜粋です。

EIGRPルートの制御

R1のルーティングテーブルで192.168.5.0/24と192.168.6.0/24がEIGRPルートとして次のように見えるようにしてください。

R1

R1#show ip route eigrp 
D    192.168.5.0/24 [90/435200] via 192.168.17.7, 00:00:34, Ethernet1/1
D    192.168.6.0/24 [90/435200] via 192.168.16.6, 00:00:28, Ethernet1/0

上記の出力はEIGRPルートの抜粋です。

解答

R1

router rip
 distance 89 192.168.12.2 0.0.0.0 1
 distance 89 192.168.13.3 0.0.0.0 2
!         
access-list 1 permit 192.168.1.0
access-list 2 permit 192.168.2.0
!
router ospf 1
 distance 89 0.0.0.0 255.255.255.255 3
!
access-list 3 permit 192.168.3.0
access-list 3 permit 192.168.4.0
!
router eigrp 1
 offset-list 5 in 100 Ethernet1/0
 offset-list 6 in 100 Ethernet1/1
!
access-list 5 permit 192.168.5.0
access-list 6 permit 192.168.6.0

ワンポイント

  • 同一のルーティングプロトコルでもアドミニストレイティブディスタンスによってルートの優先制御が可能
  • ネクストホップやルート単位でアドミニストレイティブディスタンスを変更することができる。ただし、OSPFではネクストホップ単位のアドミニストレイティブディスタンスの変更はできない
  • EIGRPでは、オフセットリストによって送受信するルートのメトリックを増加させることができる。

解説

RIPルートの制御

192.168.1.0/24、192.168.2.0/24のルートがRIPルートとして見えるようにするためには、EIGRPよりもアドミニストレイティブディスタンスを小さくします。単にEIGRPよりもアドミニストレイティブディスタンスを小さくしただけでは、R2経由とR3経由では等コストになります。設定条件のように等コストロードバランスにならないようにするためには、ネクストホップとルートごとにアドミニストレイティブディスタンスをEIGRPよりも小さくします。

R2から受信する192.168.1.0/24のADを89に変更するための設定は、以下の部分です。distance 89のあとの「192.168.12.2 0.0.0.0」でネクストホップを指定して、ACL1でADを変更したい対象ルートのネットワークアドレスを決めています。

R1

router rip
 distance 89 192.168.12.2 0.0.0.0 1
!         
access-list 1 permit 192.168.1.0

そして、R3から受信する192.168.2.0/24のADを89に変更するための設定は、以下の部分です。設定の考え方は同じです。

R1

router rip
 distance 89 192.168.13.3 0.0.0.0 2
!         
access-list 2 permit 192.168.2.0

図 RIPルートのADの変更
図 RIPルートのADの変更

RIPルートのAD変更の設定を確認します。show ip protocolsコマンドでAD変更について確認できます。また、ルーティングテーブルを見ると条件通りに192.168.1.0/24と192.168.2.0/24がRIPルートとして見えるようになります。

R1

R1#show ip protocols 
Routing Protocol is "eigrp 2"
~省略~

Routing Protocol is "eigrp 1"
~省略~

Routing Protocol is "ospf 1"
~省略~

Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 4 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    Interface             Send  Recv  Triggered RIP  Key-chain
    Ethernet0/0           2     2                                    
    Ethernet0/1           2     2                                    
  Automatic network summarization is in effect
  Maximum path: 4
  Routing for Networks:
    192.168.12.0
    192.168.13.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.13.3          89      00:00:22
    192.168.12.2          89      00:00:10
  Distance: (default is 120)
    Address         Wild mask       Distance  List
    192.168.12.2            0.0.0.0       89  1
    192.168.13.3            0.0.0.0       89  2
R1#show ip route rip 
R    192.168.28.0/24 [120/1] via 192.168.12.2, 00:00:00, Ethernet0/0
R    192.168.38.0/24 [120/1] via 192.168.13.3, 00:00:00, Ethernet0/1
R    192.168.1.0/24 [89/2] via 192.168.12.2, 00:00:00, Ethernet0/0
R    192.168.2.0/24 [89/2] via 192.168.13.3, 00:00:00, Ethernet0/1

OSPFルートの制御

192.168.3.0/24、192.168.4.0/24のルートはEIGRPとOSPFとRIPで学習します。EIGRPのアドミニストレイティブディスタンスが最も小さいので、ルーティングテーブルにはEIGRPルートとして登録されます。そこで、192.168.3.0/24、192.168.4.0/24のルートがOSPFルートとして見えるようにするためには、EIGRPよりもアドミニストレイティブディスタンスを小さくします。

そのための設定は、以下の通りです。

R1

router ospf 1
 distance 89 0.0.0.0 255.255.255.255 3
!
access-list 3 permit 192.168.3.0
access-list 3 permit 192.168.4.0

distance 89のあとの「0.0.0.0 255.255.2555」は、ルートのネクストホップは特に見ていないということです。そして、ACL3でアドミニストレイティブディスタンスを変更する対象となるルートのネットワークアドレスを指定しています。

図 OSPFルートのADの変更
図 OSPFルートのADの変更

OSPFではネクストホップ単位のAD制御は基本的にできません。OSPFでのdistanceコマンドの<address> <wildcard>の指定は、show ip protocolsコマンドで確認できる同一エリア内のルータのルータIDを指定することになります。

設定後、OSPFルートのAD変更の設定を確認します。show ip protocolsコマンドでAD変更について確認できます。また、ルーティングテーブルを見ると条件通りに192.168.3.0/24と192.168.4.0/24がRIPルートとして見えるようになります。

R1

R1#show ip protocols 
Routing Protocol is "eigrp 2"
~省略~

Routing Protocol is "eigrp 1"
~省略~

Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 1.1.1.1
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    192.168.14.0 0.0.0.255 area 0
    192.168.15.0 0.0.0.255 area 0
 Reference bandwidth unit is 100 mbps
  Routing Information Sources:
    Gateway         Distance      Last Update
    8.8.8.8               89      15:56:07
    5.5.5.5               89      15:56:07
    4.4.4.4               89      15:56:07
  Distance: (default is 110)
    Address         Wild mask       Distance  List
    0.0.0.0         255.255.255.255       89  3

Routing Protocol is "rip"
~省略=

R1#show ip route ospf 
O    192.168.58.0/24 [110/20] via 192.168.15.5, 15:57:12, Ethernet0/3
O    192.168.4.0/24 [89/21] via 192.168.15.5, 15:57:12, Ethernet0/3
                    [89/21] via 192.168.14.4, 15:57:12, Ethernet0/2
O    192.168.3.0/24 [89/21] via 192.168.15.5, 15:57:12, Ethernet0/3
                    [89/21] via 192.168.14.4, 15:57:12, Ethernet0/2
O    192.168.48.0/24 [110/20] via 192.168.14.4, 15:57:12, Ethernet0/2

EIGRPのルート制御

192.168.5.0/24と192.168.6.0/24は等コストロードバランスのEIGRPルートとしてルーティングテーブルに登録されています。条件通りに等コストロードバランスでなくなるようにするために、オフセットリストによってメトリックを調整します。R1でのオフセットリストの設定が、以下の部分です。

R1

router eigrp 1
 offset-list 5 in 100 Ethernet1/0
 offset-list 6 in 100 Ethernet1/1
!
access-list 5 permit 192.168.5.0
access-list 6 permit 192.168.6.0

オフセットリストの設定後、EIGRPのルート制御を確認します。show ip protocolsコマンドでオフセットリストの適用を確認することができます。また、show ip eigrp toplogyでオフセットリストによってメトリックが増加していることがわかります。そして、ルーティングテーブルを見ると、条件通りに192.168.5.0/24と192.168.6.0/24のルートが登録されています。

R1

R1#show ip protocols 
Routing Protocol is "eigrp 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Incoming routes in Ethernet1/0 will have 100 added to metric if on list 5
  Incoming routes in Ethernet1/1 will have 100 added to metric if on list 6
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Redistributing: eigrp 1
  EIGRP NSF-aware route hold timer is 240s
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    192.168.16.0
    192.168.17.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.16.6          90      00:07:08
    192.168.17.7          90      00:07:08
  Distance: internal 90 external 170

Routing Protocol is "ospf 1"
~省略~

Routing Protocol is "rip"
~省略~

R1#show ip eigrp 1 topology 
IP-EIGRP Topology Table for AS(1)/ID(192.168.19.1)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status 

~省略~
P 192.168.5.0/24, 1 successors, FD is 435200
        via 192.168.17.7 (435200/409600), Ethernet1/1
        via 192.168.16.6 (435300/409700), Ethernet1/0
P 192.168.6.0/24, 1 successors, FD is 435200
        via 192.168.16.6 (435200/409600), Ethernet1/0
        via 192.168.17.7 (435300/409700), Ethernet1/1
~省略~
R1#show ip route eigrp
D    192.168.78.0/24 [90/307200] via 192.168.17.7, 00:01:06, Ethernet1/1
D    192.168.4.0/24 [90/435200] via 192.168.17.7, 00:01:06, Ethernet1/1
                    [90/435200] via 192.168.16.6, 00:01:06, Ethernet1/0
D    192.168.5.0/24 [90/435200] via 192.168.17.7, 00:00:07, Ethernet1/1
D    192.168.6.0/24 [90/435200] via 192.168.16.6, 00:00:07, Ethernet1/0
D    192.168.68.0/24 [90/307200] via 192.168.16.6, 00:01:06, Ethernet1/0
D    192.168.1.0/24 [90/435200] via 192.168.17.7, 00:01:06, Ethernet1/1
                    [90/435200] via 192.168.16.6, 00:01:06, Ethernet1/0
D    192.168.2.0/24 [90/435200] via 192.168.17.7, 00:01:06, Ethernet1/1
                    [90/435200] via 192.168.16.6, 00:01:06, Ethernet1/0
D    192.168.3.0/24 [90/435200] via 192.168.17.7, 00:01:06, Ethernet1/1
                    [90/435200] via 192.168.16.6, 00:01:06, Ethernet1/0

関連記事

IPルーティング応用