RIPでのデフォルトルート生成

デフォルトルート(0.0.0.0/0)をRIPルートとして生成して、他のルータにアドバタイズするためには、以下のようにいくつかの方法があります。

  • スタティックルートのデフォルトルートをRIPへ再配送
  • default-information originateコマンド
  • ip default-networkコマンド

ip default-networkコマンドは、デフォルトルート0.0.0.0/0そのものをアドバタイズするわけではないのですが、デフォルトルートと同じような役割を果たせるようにします。

以降で、スタティックルートのデフォルトルートをRIPへ再配送することについて簡単な設定例を解説します。


default-information orignateコマンド、ip default-networkの設定例は、以下の記事をご覧ください。

スタティックルートのデフォルトルートをRIPへ再配送

【ネットワーク構成】

図 RIPでのデフォルトルート生成の設定例 ネットワーク構成
図 RIPでのデフォルトルート生成の設定例 ネットワーク構成

【条件】

  • R2がR3へデフォルトルートをRIPでアドバタイズして、すべてのインタフェースの接続性を確保できるようにします。
  • デフォルトルートの生成はスタティックルートの再配送で行います。

【初期設定】

R1

interface Loopback0
 ip address 172.16.2.1 255.255.255.0 secondary
 ip address 172.16.1.1 255.255.255.0
!
interface Ethernet0/0
 ip address 192.168.12.1 255.255.255.0
!
ip route 192.168.0.0 255.255.0.0 192.168.12.2

R2

interface Ethernet0/0
 ip address 192.168.12.2 255.255.255.0
!
interface Ethernet0/1
 ip address 192.168.23.2 255.255.255.0
!
router rip
 version 2
 network 192.168.23.0
 no auto-summary

R3

interface Loopback0
 ip address 192.168.3.3 255.255.255.0
!
interface Ethernet0/0
 ip address 192.168.23.3 255.255.255.0
!
router rip
 version 2
 network 192.168.3.0
 network 192.168.23.0
 no auto-summary

【Step1:デフォルトルートの設定】

R2でスタティックルートとしてデフォルトルートを設定します。

R2

ip route 0.0.0.0 0.0.0.0 192.168.12.1

【Step2:スタティックルートをRIPへ再配送】

Step1で設定したデフォルトルートをRIPルートとするために、R2でスタティックルートをRIPへ再配送します。

R2

router rip
 redistribute static

再配送元がstaticおよびconnectedのときには、シードメトリックを指定しなくても問題ありません。

【Step3:デフォルトルートの確認】

R3のルーティングテーブルにRIPルートとしてデフォルトルートが登録されていることを確認します。

R3

R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.23.2 to network 0.0.0.0

C    192.168.23.0/24 is directly connected, Ethernet0/0
C    192.168.3.0/24 is directly connected, Loopback0
R*   0.0.0.0/0 [120/1] via 192.168.23.2, 00:00:26, Ethernet0/0

【Step4:通信確認】

R3からR1へpingを実行して通信できることを確認します。デフォルトルートがあるので、Pingの応答が正常に返ってきます。

R3

R3#ping 172.16.1.1 source 192.168.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.3.3
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/12/20 ms
R3#ping 172.16.2.1 source 192.168.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.2.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.3.3
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/10/20 ms

IPルーティングのキホン