概要

不連続サブネットのアドレス構成でRIPを利用するときの設定ミスの切り分けと修正を行います。

ネットワーク構成

下記のネットワーク構成でRIPv2を利用したダイナミックルーティングを行います。

図 RIP 設定ミスの切り分けと修正 Part1 ネットワーク構成
図 RIP 設定ミスの切り分けと修正 Part1 ネットワーク構成

設定概要

各ルータのRIPに関連する設定概要は次の通りです。これらの設定には、一部設定ミスがあります。

R1

interface FastEthernet0/0
 ip address 192.168.12.1 255.255.255.0
!
interface FastEthernet1/0
 ip address 192.168.13.1 255.255.255.0
!
!
router rip
 version 2
 network 192.168.12.0
 network 192.168.13.0
 no auto-summary

R2

interface FastEthernet0/0
 ip address 192.168.12.2 255.255.255.0
!
interface FastEthernet1/0
 ip address 10.2.2.2 255.255.255.0
!
!
router rip
 version 2
 network 10.0.0.0
 network 192.168.12.0

R3

interface FastEthernet0/0
 ip address 192.168.13.3 255.255.255.0
!
interface FastEthernet1/0
 ip address 10.3.3.3 255.255.255.0
!
!
router rip
 version 2
 network 10.0.0.0
 network 192.168.13.0

トラブルの症状

各ルータのルーティングテーブルにルート情報が正常に登録されません。各ルータのルーティングテーブルは次のようになっています。

R1 show ip route

R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
C    192.168.12.0/24 is directly connected, FastEthernet0/0
C    192.168.13.0/24 is directly connected, FastEthernet1/0
R    10.0.0.0/8 [120/1] via 192.168.13.3, 00:00:19, FastEthernet1/0
                [120/1] via 192.168.12.2, 00:00:16, FastEthernet0/0

R2 show ip route

R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
C    192.168.12.0/24 is directly connected, FastEthernet0/0
R    192.168.13.0/24 [120/1] via 192.168.12.1, 00:00:11, FastEthernet0/0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.2.2.0 is directly connected, FastEthernet1/0

R3 show ip route

R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
R    192.168.12.0/24 [120/1] via 192.168.13.1, 00:00:22, FastEthernet0/0
C    192.168.13.0/24 is directly connected, FastEthernet0/0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.3.3.0 is directly connected, FastEthernet1/0

各ルータのルーティングテーブルに正しくルート情報が登録されていないため、10.2.2.0/24と10.3.3.0/24間の通信ができません。

問題

  • なぜ各ルータのルーティングテーブルにルート情報が正しく登録されていないのでしょうか?
  • ルーティングテーブルにルート情報が正しく登録されるようにするためには、どのように設定を修正すればよいでしょうか?ただし、アドレッシングを変更してはいけません。

解答

なぜ各ルータのルーティングテーブルにルート情報が正しく登録されていないのでしょうか?

不連続サブネットのアドレス構成なのに、自動集約がデフォルトの有効のままになっているため

ルーティングテーブルにルート情報が正しく登録されるようにするためには、どのように設定を修正すればよいでしょうか?ただし、アドレッシングを変更してはいけません。

R2/R3

router rip
 no auto-summary

ワンポイント

  • 不連続サブネットのアドレス構成のときは自動集約を無効化しなければいけない
  • RIPはデフォルトで自動集約が有効化されている

解説

RIP/EIGRPといったディスタンスベクタ型ルーティングプロトコルで、不連続サブネットの場合の注意点についての問題です。RIP/EIGRPは、デフォルトでメジャーネットワーク境界において自動集約を行います。不連続サブネットのアドレス構成のときは、自動集約によって正しくルーティングテーブルにルート情報を登録できなくなってしまいます。


不連続サブネットと自動集約について、以下の記事で解説しています。


R2はF0/0から10.2.2.0/24のルートを送信するとき、メジャーネットワーク境界なので集約して10.0.0.0/8とします。同じようにR3はF0/0から10.3.3.0/24のルートを送信するとき、メジャーネットワーク境界なので集約して10.0.0.0/8とします。その結果、R1には集約された10.0.0.0/8が等コストルートとしてルーティングテーブルに登録されます。また、R2、R3にはお互いのF1/0のルートは登録されません。

図 自動集約
図 自動集約

R1 show ip route

R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.12.0/24 is directly connected, FastEthernet0/0
C    192.168.13.0/24 is directly connected, FastEthernet1/0
R    10.0.0.0/8 [120/1] via 192.168.13.3, 00:00:14, FastEthernet1/0
                [120/1] via 192.168.12.2, 00:00:07, FastEthernet0/0

R2 show ip route

R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.12.0/24 is directly connected, FastEthernet0/0
R    192.168.13.0/24 [120/1] via 192.168.12.1, 00:00:08, FastEthernet0/0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.2.2.0 is directly connected, FastEthernet1/0

R3 show ip route

R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

R    192.168.12.0/24 [120/1] via 192.168.13.1, 00:00:19, FastEthernet0/0
C    192.168.13.0/24 is directly connected, FastEthernet0/0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.3.3.0 is directly connected, FastEthernet1/0

このような不連続サブネットのアドレス構成では、必ず自動集約を無効化しなければいけません。R1ではすでに自動集約を無効化していますが、R2/R3ではデフォルトのままです。そこで、R2/R3で次のようにRIPの自動集約を無効化します。

R2/R3 自動集約の無効化

router rip
 no auto-summary

R2/R3で自動集約を無効化した後、ルーティングテーブルを確認すると次のようになります。

R1 show ip route

R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.12.0/24 is directly connected, FastEthernet0/0
C    192.168.13.0/24 is directly connected, FastEthernet1/0
     10.0.0.0/24 is subnetted, 2 subnets
R       10.3.3.0 [120/1] via 192.168.13.3, 00:00:20, FastEthernet1/0
R       10.2.2.0 [120/1] via 192.168.12.2, 00:00:11, FastEthernet0/0

R2 show ip route

R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.12.0/24 is directly connected, FastEthernet0/0
R    192.168.13.0/24 [120/1] via 192.168.12.1, 00:00:07, FastEthernet0/0
     10.0.0.0/24 is subnetted, 2 subnets
R       10.3.3.0 [120/2] via 192.168.12.1, 00:00:07, FastEthernet0/0
C       10.2.2.0 is directly connected, FastEthernet1/0

R3 show ip route

R3#show ip route
*Mar  1 00:34:47.451: %SYS-5-CONFIG_I: Configured from console by console
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

R    192.168.12.0/24 [120/1] via 192.168.13.1, 00:00:25, FastEthernet0/0
C    192.168.13.0/24 is directly connected, FastEthernet0/0
     10.0.0.0/24 is subnetted, 2 subnets
C       10.3.3.0 is directly connected, FastEthernet1/0
R       10.2.2.0 [120/2] via 192.168.13.1, 00:00:25, FastEthernet0/0

R2/R3で自動集約を無効化すると、各ルータのルーティングテーブルに必要なすべてのルート情報が正しく登録されることがわかります。

関連記事

IPルーティングのキホン