ホストルートとは

ホストルートとは、サブネットマスク/32のルート情報です。最長一致検索により、ホストルートは最も優先されるルート情報です。

IPv6のホストルートはプレフィクス長/128のルート情報です。

ホストルートが登録されるのは、以下のようなケースです。

  • ルータのローカルルート
  • ループバックインタフェースのIPアドレスの設定
  • PPPネイバールート
通常のスタティックルートの設定でサブネットマスク/32でホストルートを設定することもできます。上記の3通りで登録されたホストルートのルート情報をルーティングプロトコルでアドバタイズすることもできます。

ルータのローカルート

ルータのインタフェースにIPアドレスを設定すると、そのネットワークアドレスが直接接続のルート情報としてルーティングテーブルに登録されます。直接接続のルート情報はコード「C」です。

Cisco IOS 15.0以降では、直接接続のルート情報に加えて、ローカルルートも登録されます。ローカルルートは、コード「L」でルータのインタフェースに設定されているIPアドレスを示すホストルートです。

ローカルルートの例

ローカルルートの例を挙げます。ルータのGigabitEthernet0にIPアドレス192.168.1.254/24を設定します。

interface GigabitEthernet0
 ip address 192.168.1.254 255.255.255.0
 no shutdown

すると、ルーティングテーブルにはコード「C」で192.168.1.0/24が登録されます。それに加えて、コード「L」で192.168.1.254/32が登録されます。

Center#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, GigabitEthernet0
L        192.168.1.254/32 is directly connected, GigabitEthernet0
図 ローカルルート
図 ローカルルート

ループバックインタフェースのIPアドレスの設定

ルータの管理用にループバックインタフェースを作成して、IPアドレスを設定することができます。このときサブネットマスク/32として、IPアドレスを設定することが多いです。ループバックインタフェースの先には他のデバイスが存在することはなく、/32のサブネットマスクでただ1つのIPアドレスを設定することになります。ルーティングテーブル上はサブネットマスク/32のホストルートになります。

ループバックインタフェースのIPアドレスを設定する際に/32のサブネットマスク以外でも特に問題ありません。

PPPネイバールート

PPPのカプセル化を行っているシリアルインタフェースで、対向のルータのIPアドレスをホストルートとして自動的にルーティングテーブルに登録します。これをPPPネイバールートと呼んでいます。PPPネイバールートはコード「C」です。

PPPネイバールートの例

PPPネイバールートの例です。R1とR2をPPPカプセル化のシリアルインタフェースで接続しています。

R1

interface Serial0/0
 ip address 192.168.1.1 255.255.255.0
 encapsulation ppp
 no shutdown

R2

interface Serial0/0
 ip address 192.168.1.2 255.255.255.0
 encapsulation ppp
 no shutdown

R1のルーティングテーブルにはR2のIPアドレス192.168.1.2を表すホストルート192.168.1.2/32がコード「C」で登録されます。また、R2ではR1のIPアドレス192.168.1.1を表すホストルート192.168.1.1/32がコード「C」で登録されます。

R1

R1#show ip route
~省略~

Gateway of last resort is not set

     192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.1.0/24 is directly connected, Serial0/0
C       192.168.1.2/32 is directly connected, Serial0/0

R1

R2#show ip route
~省略~

Gateway of last resort is not set

     192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.1.1/32 is directly connected, Serial0/0
C       192.168.1.0/24 is directly connected, Serial0/0

図 PPPネイバールート
図 PPPネイバールート
PPPネイバールートの例のルータは、ローカルルートが登録されないIOSを利用しています。

ホストルートのポイント

ホストルートのポイント
  • ホストルートはサブネットマスク/32のルート情報
  • ホストルートが登録されるケースは主に3通り
    • ルータのローカルルート
    • ループバックインタフェースのIPアドレス設定
    • PPPネイバールート

関連記事

「ネットワークのおべんきょしませんか?」内の記事を検索

IPルーティングのキホン