概要

ルーティングテーブルの状態を監視して、VRRPマスタルータを切り替えるための設定例について解説します。

ネットワーク構成

図 ルーティングテーブルのトラッキング ネットワーク構成
図 ルーティングテーブルのトラッキング ネットワーク構成

初期設定

各ルータの初期設定は以下の通りです。

R1

interface FastEthernet0/0
 ip address 192.168.1.251 255.255.255.0
 vrrp 1 ip 192.168.1.254
 vrrp 1 priority 120
!
interface FastEthernet0/1
 ip address 192.168.3.251 255.255.255.0
!
interface FastEthernet1/0
 ip address 192.168.12.251 255.255.255.0
!
router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 passive-interface FastEthernet0/0
 network 192.168.0.0 0.0.255.255 area 0

R2

interface FastEthernet0/0
 ip address 192.168.1.252 255.255.255.0
 vrrp 1 ip 192.168.1.254
!
interface FastEthernet0/1
 ip address 192.168.3.252 255.255.255.0
!
interface FastEthernet1/0
 ip address 192.168.12.252 255.255.255.0
!
router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 passive-interface FastEthernet0/0
 network 192.168.0.0 0.0.255.255 area 0

R3

interface FastEthernet0/0
 ip address 192.168.100.253 255.255.255.0
!
interface FastEthernet1/0
 ip address 192.168.3.253 255.255.255.0
!
router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
 network 192.168.0.0 0.0.255.255 area 0

R1とR2のFa0/0でVRRPを有効にしていて、R1がマスタルータです。

R1

R1#show vrrp brief
Interface          Grp Pri Time  Own Pre State   Master addr     Group addr
Fa0/0              1   120 3531       Y  Master  192.168.1.251   192.168.1.254
R1#show ip route
~省略~

Gateway of last resort is not set

C    192.168.12.0/24 is directly connected, FastEthernet1/0
C    192.168.1.0/24 is directly connected, FastEthernet0/0
O    192.168.100.0/24 [110/2] via 192.168.3.253, 01:16:10, FastEthernet0/1
C    192.168.3.0/24 is directly connected, FastEthernet0/1

R1のFa0/1がダウンすると、R1がマスタルータのままではパケットの転送経路が効率的ではありません。R1のFa0/1がダウンすると、R2がマスタルータになったほうがいいです。そこで、R1のルーティングテーブル上のOSPFルート192.168.100.0/24の状態を監視するトラッキングの設定を行います。

ルーティングテーブルのトラッキングの設定 ~特定のルート情報が存在しているかどうか~

設定

ルーティングテーブル上のOSPFルート192.168.100.0/24が存在しているかどうかを監視して、VRRPマスタルータを切り替えます。R1でOSPFルート192.168.100.0/24がルーティングテーブルから削除されると、VRRPプライオリティを30下げる設定をします。

R1

track 1 ip route 192.168.100.0 255.255.255.0 reachability
!
interface FastEthernet0/0
 vrrp 1 track 1 decrement 30

確認

R1で設定を確認すると、以下のようになります。

R1

R1#show track
Track 1
  IP route 192.168.100.0 255.255.255.0 reachability
  Reachability is Up (OSPF)
    1 change, last change 00:04:18
  First-hop interface is FastEthernet0/1
  Tracked by:
    VRRP FastEthernet0/0 1
R1#show vrrp
FastEthernet0/0 - Group 1
  State is Master
  Virtual IP address is 192.168.1.254
  Virtual MAC address is 0000.5e00.0101
  Advertisement interval is 1.000 sec
  Preemption enabled
  Priority is 120
    Track object 1 state Up decrement 30
  Master Router is 192.168.1.251 (local), priority is 120
  Master Advertisement interval is 1.000 sec
  Master Down interval is 3.531 sec

R1 Fa0/1をshutdownすると、ルーティングテーブルから192.168.100.0/24が削除されます。それに伴ってVRRPマスタルータがR2に切り替わります。ただし、すぐにもとに戻ります。OSPFがコンバージェンスして、192.168.100.0/24のルートを再度学習すると、R1が再びマスタルータとなります。以下、R1のFa0/1をshutdownしたときのコンソールのログです。

R1

R1(config)#interface FastEthernet 0/1
R1(config-if)#shutdown
R1(config-if)#
*Mar  1 00:08:33.783: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on FastEthernet0/1 from FULL to DOWN, Neighbor Down: Interface down or detached
*Mar  1 00:08:33.783: %OSPF-5-ADJCHG: Process 1, Nbr 3.3.3.3 on FastEthernet0/1 from FULL to DOWN, Neighbor Down: Interface down or detached
R1(config-if)#
*Mar  1 00:08:35.767: %LINK-5-CHANGED: Interface FastEthernet0/1, changed state to administratively down
*Mar  1 00:08:36.767: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
R1(config-if)#
*Mar  1 00:08:38.839: %TRACKING-5-STATE: 1 ip route 192.168.100.0/24 reachability Up->Down
R1(config-if)#
*Mar  1 00:08:42.483: %VRRP-6-STATECHANGE: Fa0/0 Grp 1 state Master -> Backup
R1(config-if)#
*Mar  1 00:08:53.839: %TRACKING-5-STATE: 1 ip route 192.168.100.0/24 reachability Down->Up
R1(config-if)#
*Mar  1 00:08:56.771: %VRRP-6-STATECHANGE: Fa0/0 Grp 1 state Backup -> Master

図 R1 Fa0/1をshutdown直後
図 R1 Fa0/1をshutdown直後
図 R1 マスタルータに戻る
図 R1 マスタルータに戻る

例として考えているネットワーク構成では、単純にルート情報が存在するかどうかを監視しても、効果的にアクティブルータを切り替えることができません。

ルーティングテーブルのトラッキングの設定 ~ルート情報のメトリックのしきい値~

設定

R1のFa0/1がダウンして192.168.100.0/24へルートが切り替わったときに、マスタルータをR2にするために、トラッキングオブジェクトを以下のように設定します。

R1

track 2 ip route 192.168.100.0 255.255.255.0 metric threshold
 threshold metric up 2 down 3

R1から192.168.100.0/24への最適ルートが切り替わると、メトリックが2から3に増えます。192.168.100.0/24のメトリックが3になるとDownとなるようにトラッキングオブジェクト2を設定します。

そして、HSRPにトラッキングオブジェクト2を関連付けます。

R1

interface FastEthernet0/0
 no vrrp 1 track 1
 vrrp 1 track 2 decrement 30

確認

R1で設定を確認すると、以下のようになります。

R1

R1#show track
Track 1
  IP route 192.168.100.0 255.255.255.0 reachability
  Reachability is Up (OSPF)
    3 changes, last change 00:39:50
  First-hop interface is FastEthernet0/1
Track 2
  IP route 192.168.100.0 255.255.255.0 metric threshold
  Metric threshold is Up (OSPF/2/2)
    1 change, last change 00:05:31
  Metric threshold down 3 up 2
  First-hop interface is FastEthernet0/1
  Tracked by:
    VRRP FastEthernet0/0 1
R1#show vrrp
FastEthernet0/0 - Group 1
  State is Master
  Virtual IP address is 192.168.1.254
  Virtual MAC address is 0000.5e00.0101
  Advertisement interval is 1.000 sec
  Preemption enabled
  Priority is 120
    Track object 2 state Up decrement 30
  Master Router is 192.168.1.251 (local), priority is 120
  Master Advertisement interval is 1.000 sec
  Master Down interval is 3.531 sec

R1 Fa0/1をshutdownすると、ルーティングテーブルの192.168.100.0/24のメトリックが3になります。それに伴ってVRRPマスタルータがR2に切り替わります。以下、R1のFa0/1をshutdownしたときのコンソールのログです。

R1

R1(config)#interface FastEthernet 0/1
R1(config-if)#shutdown
R1(config-if)#
*Mar  1 00:16:42.779: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on FastEthernet0/1 from FULL to DOWN, Neighbor Down: Interface down or detached
*Mar  1 00:16:42.779: %OSPF-5-ADJCHG: Process 1, Nbr 3.3.3.3 on FastEthernet0/1 from FULL to DOWN, Neighbor Down: Interface down or detached
R1(config-if)#
*Mar  1 00:16:44.763: %LINK-5-CHANGED: Interface FastEthernet0/1, changed state to administratively down
*Mar  1 00:16:45.763: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
R1(config-if)#
*Mar  1 00:16:53.839: %TRACKING-5-STATE: 2 ip route 192.168.100.0/24 metric threshold Up->Down
R1(config-if)#
*Mar  1 00:16:56.923: %VRRP-6-STATECHANGE: Fa0/0 Grp 1 state Master -> Backup
R1(config-if)#do show track 2
Track 2
  IP route 192.168.100.0 255.255.255.0 metric threshold
  Metric threshold is Down (OSPF/3/3)
    5 changes, last change 00:00:24
  Metric threshold down 3 up 2
  First-hop interface is FastEthernet1/0
  Tracked by:
    VRRP FastEthernet0/0 1
R1(config-if)#do show vrrp
FastEthernet0/0 - Group 1
  State is Backup
  Virtual IP address is 192.168.1.254
  Virtual MAC address is 0000.5e00.0101
  Advertisement interval is 1.000 sec
  Preemption enabled
  Priority is 90  (cfgd 120)
    Track object 2 state Down decrement 30
  Master Router is 192.168.1.252, priority is 100
  Master Advertisement interval is 1.000 sec
  Master Down interval is 3.531 sec (expires in 3.367 sec)

図 R1 ルートが切り替わるとバックアップに
図 R1 ルートが切り替わるとバックアップに

関連記事

IPルーティングのキホン