RIPでのデフォルトルート生成

デフォルトルートをRIPルートとして生成して、他のルータにアドバタイズするためには、以下のようにいくつかの方法があります。

  • スタティックルートのデフォルトルートをRIPへ再配送
  • default-information originateコマンド
  • ip default-networkコマンド

ip default-networkコマンドは、デフォルトルート0.0.0.0/0そのものをアドバタイズするわけではないのですが、デフォルトルートと同じような役割を果たせるようにします。

以降で、default-information originateコマンドについて簡単な設定例を解説します。


スタティックルートの再配送、ip default-networkコマンドの設定例は、以下の記事をご覧ください。

default-information originateコマンドでのデフォルトルート生成

【ネットワーク構成】

図 RIPでのデフォルトルート生成の設定例 ネットワーク構成
図 RIPでのデフォルトルート生成の設定例 ネットワーク構成

【条件】

  • R2がR3へデフォルトルートをRIPでアドバタイズして、すべてのインタフェースの接続性を確保できるようにします。
  • デフォルトルートの生成はdefault-information originateコマンドで行います。

【初期設定】

R1

interface Loopback0
 ip address 172.16.2.1 255.255.255.0 secondary
 ip address 172.16.1.1 255.255.255.0
!
interface Ethernet0/0
 ip address 192.168.12.1 255.255.255.0
!
ip route 192.168.0.0 255.255.0.0 192.168.12.2

R2

interface Ethernet0/0
 ip address 192.168.12.2 255.255.255.0
!
interface Ethernet0/1
 ip address 192.168.23.2 255.255.255.0
!
router rip
 version 2
 network 192.168.23.0
 no auto-summary

R3

interface Loopback0
 ip address 192.168.3.3 255.255.255.0
!
interface Ethernet0/0
 ip address 192.168.23.3 255.255.255.0
!
router rip
 version 2
 network 192.168.3.0
 network 192.168.23.0
 no auto-summary

【Step1:default-information originateコマンドでデフォルトルートを生成】

R2でdefault-information originateコマンドでデフォルトルートを生成し、R3へアドバタイズします。RIPの場合は、特に何の条件もなくdefault-information originateコマンドを入力すると、RIPルートとして0.0.0.0/0を生成できます。

R2

router rip
 default-information originate

【Step2:デフォルトルートの確認】

R3のルーティングテーブルにRIPルートとしてデフォルトルートが登録されていることを確認します。

R3

R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.23.2 to network 0.0.0.0

C    192.168.23.0/24 is directly connected, Ethernet0/0
C    192.168.3.0/24 is directly connected, Loopback0
R*   0.0.0.0/0 [120/1] via 192.168.23.2, 00:00:26, Ethernet0/0

【Step3:通信確認】

R3からR1へpingを実行してみると、応答が返ってこないことがわかります。

R3

R3#ping 172.16.1.1 source 192.168.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.3.3
U.U.U
Success rate is 0 percent (0/5)
R3#ping 172.16.2.1 source 192.168.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.2.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.3.3
U.U.U
Success rate is 0 percent (0/5)

R3からR1へのPingが失敗するのはR2のルーティングテーブルに必要なルート情報が存在しないからです。RIPのdefaut-information originateコマンドは、無条件にデフォルトルートを生成します。R3はデフォルトルートを利用してR1宛てのパケットをR2へ転送します。しかし、R2のルーティングテーブルにR1へルーティングするためのルート情報が存在しないので、パケットは破棄されます。

【Step4:デフォルトルートの設定】

R2でR1へルーティングするためのルート情報として、デフォルトルートをスタティックルートとして設定します。

R2

ip route 0.0.0.0 0.0.0.0 192.168.12.1

【Step5:通信確認】

再度、R3からR1へpingを実行すると正常に応答が返ってくることが確認できます。

R3

R3#ping 172.16.1.1 source 192.168.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.3.3
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/11/24 ms
R3#ping 172.16.2.1 source 192.168.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.2.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.3.3
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/10/16 ms

関連記事

「ネットワークのおべんきょしませんか?」内の記事を検索

IPルーティングのキホン