概要

RIPタイマの整合性が取れていない設定ミスについて、切り分けと修正を行います。

ネットワーク構成

下記のネットワーク構成でRIPv2を利用したダイナミックルーティングを行います。

図 RIP 設定ミスの切り分けと修正 Part3 ネットワーク構成
図 RIP 設定ミスの切り分けと修正 Part3 ネットワーク構成

設定概要

各ルータのRIPに関連する設定概要は次の通りです。これらの設定には、一部設定ミスがあります。

R1

interface FastEthernet0/0
 ip address 192.168.12.1 255.255.255.0
 ip rip advertise 2
!
interface FastEthernet1/0
 ip address 192.168.13.1 255.255.255.0
 ip rip advertise 2
!
router rip
 version 2
 timers basic 2 10 10 20
 network 192.168.12.0
 network 192.168.13.0
 no auto-summary

R2

interface FastEthernet0/0
 ip address 192.168.12.2 255.255.255.0
!
interface FastEthernet1/0
 ip address 10.2.2.2 255.255.255.0
!
router rip
 version 2
 network 10.0.0.0
 network 192.168.12.0
 no auto-summary

R3

interface FastEthernet0/0
 ip address 192.168.13.3 255.255.255.0
!
interface FastEthernet1/0
 ip address 10.3.3.3 255.255.255.0
!
router rip
 version 2
 network 10.0.0.0
 network 192.168.13.0
 no auto-summary

トラブルの症状

各ルータのルーティングテーブルにルート情報が登録されているものの、とても不安定な状態になってしまっています。たとえば、R1であるときには必要なルート情報が登録されていても、しばらくすると「possibly down」と表示されて、そのちルーティングテーブルから削除されてしまいます。その後、またしばらくすると、ルート情報が現れてきます。ルータのインタフェース自体はフラッピングしていないにも関わらず、このような現象が繰り返し発生してしまっています。

R1 show ip route

R1#show ip route
~省略~
 
Gateway of last resort is not set
 
C    192.168.12.0/24 is directly connected, FastEthernet0/0
C    192.168.13.0/24 is directly connected, FastEthernet1/0
     10.0.0.0/24 is subnetted, 2 subnets
R       10.3.3.0 [120/1] via 192.168.13.3, 00:00:00, FastEthernet1/0
R       10.2.2.0 [120/1] via 192.168.12.2, 00:00:04, FastEthernet0/0
R1#show ip route
~省略~
 
Gateway of last resort is not set
 
C    192.168.12.0/24 is directly connected, FastEthernet0/0
C    192.168.13.0/24 is directly connected, FastEthernet1/0
     10.0.0.0/24 is subnetted, 2 subnets
R       10.3.3.0/24 is possibly down,
          routing via 192.168.13.3, FastEthernet1/0
R       10.2.2.0/24 is possibly down,
          routing via 192.168.12.2, FastEthernet0/0
R1#show ip route
~省略~
 
Gateway of last resort is not set
 
C    192.168.12.0/24 is directly connected, FastEthernet0/0
C    192.168.13.0/24 is directly connected, FastEthernet1/0

このトラブルの原因を調べるために、各ルータでshow ip protocolsコマンドによって、RIPの設定を確認しました。

R1 show ip protocols

R1#show ip protocols
Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 2 seconds, next due in 1 seconds
  Invalid after 10 seconds, hold down 10, flushed after 20
  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    FastEthernet0/0       2     2
    FastEthernet1/0       2     2
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    192.168.12.0
    192.168.13.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.13.3         120      00:00:09
    192.168.12.2         120      00:00:25
  Distance: (default is 120)

R2 show ip protocols

R2#show ip protocols
Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 13 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    FastEthernet0/0       2     2
    FastEthernet1/0       2     2
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    10.0.0.0
    192.168.12.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.12.1         120      00:00:01
  Distance: (default is 120)

R3 show ip protocols

R3#show ip protocols
Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 2 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    FastEthernet0/0       2     2
    FastEthernet1/0       2     2
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    10.0.0.0
    192.168.13.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.13.1         120      00:00:01
  Distance: (default is 120)

問題

  • なぜ各ルータのルーティングテーブルのルート情報が不安定になってしまっているのでしょうか?
  • このような現象を解決するためには、どのように設定を修正すればよいでしょうか?

解答

なぜ各ルータのルーティングテーブルのルート情報が不安定になってしまっているのでしょうか?

R1のRIPタイマとR2/R3でのRIPタイマが一致していないため。R1のタイマは、以下のように設定されている。

  • Updateタイマ:2s
  • Invalidタイマ:10s
  • Hold downタイマ:10s
  • Flushタイマ:20s

しかし、R2/R3のタイマはデフォルトのまま。R2/R3からアップデートを受信して、次のアップデートを受信するまでの間にR1のルーティングテーブルからはRIPルートが削除される。

このような現象を解決するためには、どのように設定を修正すればよいでしょうか?

R1

router rip
 no timers basic

ワンポイント

  • ルーティングプロトコルは他のルータと相互作用している
  • ルーティングプロトコルのタイマは1台だけ変更しても意味がない

解説

RIPのタイマ設定についてのトラブルです。とても当たり前のことなんですが、ルーティングプロトコルは1台のルータだけで動作しているわけではありません。他のルータとの間で相互作用しています。RIPに限らず、ルーティングプロトコルの動作はさまざまなタイマで制御されています。障害の検出を早くしたいなどで、タイマの値をデフォルト値から変更することがあります。ルーティングプロトコルは複数のルータで相互作用するわけですから、1台のルータだけでタイマを変更しても意味がありません。タイマを変更するときには、関連するすべてのルータで変更しなければいけません。タイマの値が一致していなくても問題がない場合もありますが、原則としてタイマの値は一致させておくべきです。

今回の問題ではR1のみRIPの各種タイマの値を変更しています。

  • Updateタイマ:2s (デフォルト 30s)
  • Invalidタイマ:10s (デフォルト 180s)
  • Hold downタイマ:10s (デフォルト 180s)
  • Flushタイマ:20s (デフォルト 240s)

R2やR3はデフォルトのままなので、30秒ごとにRIPのルート情報を送っています。R1はR2やR3からRIPルート情報を受信するとルーティングテーブルに登録します。しかし、10秒後にInvalidタイマによってそのルートが無効ルートとしてHold Down状態(possibly down)にします。そして、20秒でFlushタイマが切れてしまうため、ルーティングテーブルからルートが削除されます。その後、R2やR3からルート情報を受信すると、上記のことをずっと繰り返してしまい不安定なルーティングテーブルになってしまいます。

図 RIPタイマの不一致
図 RIPタイマの不一致


この問題を解決するために、R1のRIPタイマをデフォルトに戻します。

R1

router rip
 no timers basic

R1のRIPタイマをデフォルトに戻すと、R1のルーティングテーブルはフラッピングせずに安定します。

R1 show ip route

R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.12.0/24 is directly connected, FastEthernet0/0
C    192.168.13.0/24 is directly connected, FastEthernet1/0
     10.0.0.0/24 is subnetted, 2 subnets
R       10.3.3.0 [120/1] via 192.168.13.3, 00:00:12, FastEthernet1/0
R       10.2.2.0 [120/1] via 192.168.12.2, 00:00:03, FastEthernet0/0

関連記事

「ネットワークのおべんきょしませんか?」内の記事を検索

IPルーティングのキホン