概要

RIPのバージョンの不整合について、設定ミスの切り分けと修正を行います。

ネットワーク構成

下記のネットワーク構成でRIPv2を利用したダイナミックルーティングを行います。

図 RIP 設定ミスの切り分けと修正 Part2 ネットワーク構成
図 RIP 設定ミスの切り分けと修正 Part2 ネットワーク構成

設定概要

各ルータのRIPに関連する設定概要は次の通りです。これらの設定には一部設定ミスがあります。

R1

interface FastEthernet0/0
 ip address 192.168.12.1 255.255.255.0
!
interface FastEthernet1/0
 ip address 192.168.13.1 255.255.255.0
!
!
router rip
 version 2
 network 192.168.12.0
 network 192.168.13.0
 no auto-summary

R2

interface FastEthernet0/0
 ip address 192.168.12.2 255.255.255.0
 ip rip receive version 1
!
interface FastEthernet1/0
 ip address 10.2.2.2 255.255.255.0
!
router rip
 version 2
 network 10.0.0.0
 network 192.168.12.0
 no auto-summary

R3

interface FastEthernet0/0
 ip address 192.168.13.3 255.255.255.0
 ip rip send version 1
!
interface FastEthernet1/0
 ip address 10.3.3.3 255.255.255.0
!
!
router rip
 version 2
 network 10.0.0.0
 network 192.168.13.0
 no auto-summary

トラブルの症状

各ルータのルーティングテーブルにルート情報が正常に登録されません。各ルータのルーティングテーブルは次のようになっています。

R1 show ip route

R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.12.0/24 is directly connected, FastEthernet0/0
C    192.168.13.0/24 is directly connected, FastEthernet1/0
     10.0.0.0/24 is subnetted, 1 subnets
R       10.2.2.0 [120/1] via 192.168.12.2, 00:00:04, FastEthernet0/0

R2 show ip route

R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.12.0/24 is directly connected, FastEthernet0/0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.2.2.0 is directly connected, FastEthernet1/0

R3 show ip route

R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

R    192.168.12.0/24 [120/1] via 192.168.13.1, 00:00:14, FastEthernet0/0
C    192.168.13.0/24 is directly connected, FastEthernet0/0
     10.0.0.0/24 is subnetted, 2 subnets
C       10.3.3.0 is directly connected, FastEthernet1/0
R       10.2.2.0 [120/2] via 192.168.13.1, 00:00:14, FastEthernet0/0

各ルータのルーティングテーブルに正しくルート情報が登録されていないため、正常に通信できない状態です。

問題

  • なぜ各ルータのルーティングテーブルにルート情報が正しく登録されていないのでしょうか?
  • ルーティングテーブルにルート情報が正しく登録されるようにするためには、どのように設定を修正すればよいでしょうか?

解答

なぜ各ルータのルーティングテーブルにルート情報が正しく登録されていないのでしょうか?

RIPのバージョンの不整合のために、ルーティングテーブルに必要なルート情報が登録されていない。R2ではF0/0でRIPv1のルート情報のみ受信するので、R1から送信されるRIPv2のルート情報を受信できない。そのため、R2のルーティングテーブルにはRIPのルート情報が登録されていない。R3ではR0/0からRIPv1のルート情報しか送信しない。そのため、R1でR3からのRIPv1のルート情報を受信できない。

ルーティングテーブルにルート情報が正しく登録されるようにするためには、どのように設定を修正すればよいでしょうか?

R2

interface FastEthernet0/0
 no ip rip receive version 1

R3

interface FastEthernet0/0
 no ip rip send version 1

ワンポイント

  • RIPv1とRIPv2のルート情報には互換性がない
  • インタフェースごとに送受信するRIPバージョンを設定できる

解説

RIPにはRIPv1とRIPv2の2種類のバージョンがあります。RIPv1とRIPv2には互換性がありません。RIPv1とRIPv2で互換性がないことについてのトラブルです。CiscoルータでRIPを有効化した場合、インタフェースで送受信するRIPルート情報のバージョンは下記の通りです。

送信:v1
受信:v1/v2

RIPv1のルート情報を送信し、RIPv1/RIPv2両方のルート情報を受信します。そのため、デフォルトのRIPの設定ではRIPv1のルート情報をルータ間でやり取りすることになります。現在は、RIPv1を利用する理由はほとんどありません。RIPv2を利用することが一般的でしょう。そこで、RIPのバージョンを制御する設定が必要です。インタフェースで送受信するRIPルート情報のバージョンを制御するためには、以下の2通りの設定があります。

  • インタフェース一括設定
  • インタフェースごとの設定

RIPが有効なインタフェースで扱うバージョンを一括で決めるための設定は、次の通りです。

RIPバージョンの一括設定

(config)#router rip
(config-router)#version { 1 | 2 }

このコマンドにより、RIPが有効なインタフェースで送受信するRIPルート情報のメッセージを指定したバージョンにします。

そして、次のようにインタフェースごとに送受信するRIPルート情報を設定することもできます。

RIPバージョンのインタフェースごとの設定

(config)#interface <interface>
(config-if)#ip rip {send | recieve} version { 1 | 2 | 1 2 }

なお、インタフェースでのバージョン設定の方が優先されます。

今回のトラブルの原因は、R2/R3のインタフェースでのRIPルート情報のバージョンについての設定です。R2のFa0/0には、次のような設定がされています。

R2

interface FastEthernet0/0
 ip rip receive version 1

これにより、R2のFa0/0ではRIPv1のルート情報しか受信しません。R1はRIPv2のルート情報を送信しているので、R2はR1からのRIPv2ルート情報を受信していません。debug ip ripでRIPルートの送受信の様子を見ると、よくわかります。

R2 debug ip rip

R2#debug ip rip
RIP protocol debugging is on
R2#
*Mar  1 00:01:03.755: RIP: sending v2 update to 224.0.0.9 via FastEthernet0/0 (192.168.12.2)
*Mar  1 00:01:03.759: RIP: build update entries
*Mar  1 00:01:03.759:   10.2.2.0/24 via 0.0.0.0, metric 1, tag 0
*Mar  1 00:01:04.991: RIP: sending v2 update to 224.0.0.9 via FastEthernet1/0 (10.2.2.2)
*Mar  1 00:01:04.995: RIP: build update entries
*Mar  1 00:01:04.999:   192.168.12.0/24 via 0.0.0.0, metric 1, tag 0
*Mar  1 00:01:05.007: RIP: ignored v2 packet from 192.168.12.1 (illegal version)

RIPv1ルート情報のみ受信するR2のFa0/0にRIPv2ルート情報がやってくると、illegal versionとして無視していることがわかります。これを解決するために、R2のFa0/0でRIPv2ルート情報を受信できるように設定します。

R2 F0/0でRIPv2ルート情報を受信するための設定

interface FastEthernet0/0
 no ip rip receive version 1

そして、R3ではFa0/0に次のような設定が入っているため、Fa0/0からはRIPv1のルート情報を送信しています。

R3

interface FastEthernet0/0
 ip rip send version 1

R3から送信されたRIPv1ルート情報は、R1でバージョン不整合のため無視します。R1でdebug ip ripを見ると、その様子がよくわかります。

R2 debug ip rip

R1#debug ip rip
RIP protocol debugging is on
R1#
*Mar  1 00:05:37.467: RIP: sending v2 update to 224.0.0.9 via FastEthernet1/0 (192.168.13.1)
*Mar  1 00:05:37.471: RIP: build update entries
*Mar  1 00:05:37.471:   10.2.2.0/24 via 0.0.0.0, metric 2, tag 0
*Mar  1 00:05:37.475:   192.168.12.0/24 via 0.0.0.0, metric 1, tag 0
*Mar  1 00:05:37.995: RIP: ignored v1 packet from 192.168.13.3 (illegal version)
*Mar  1 00:05:38.627: RIP: received v2 update from 192.168.12.2 on FastEthernet0/0
*Mar  1 00:05:38.631:      10.2.2.0/24 via 0.0.0.0 in 1 hops

R3のFa0/0からRIPv2のルート情報を送信するようにしなければいけません。

R3 Fa0/0からRIPv2ルート情報を送信するための設定

interface FastEthernet0/0
 no ip rip send version 1

R2、R3で設定を修正するとすべてのルータで正しくルーティングテーブルにルート情報が登録され、ルーティングを行うことができるようになります。

R1 show ip route

R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.12.0/24 is directly connected, FastEthernet0/0
C    192.168.13.0/24 is directly connected, FastEthernet1/0
     10.0.0.0/24 is subnetted, 2 subnets
R       10.3.3.0 [120/1] via 192.168.13.3, 00:00:00, FastEthernet1/0
R       10.2.2.0 [120/1] via 192.168.12.2, 00:00:28, FastEthernet0/0

R2 show ip route

R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.12.0/24 is directly connected, FastEthernet0/0
R    192.168.13.0/24 [120/1] via 192.168.12.1, 00:00:09, FastEthernet0/0
     10.0.0.0/24 is subnetted, 2 subnets
R       10.3.3.0 [120/2] via 192.168.12.1, 00:00:09, FastEthernet0/0
C       10.2.2.0 is directly connected, FastEthernet1/0

R3 show ip route

R3#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

R    192.168.12.0/24 [120/1] via 192.168.13.1, 00:00:06, FastEthernet0/0
C    192.168.13.0/24 is directly connected, FastEthernet0/0
     10.0.0.0/24 is subnetted, 2 subnets
C       10.3.3.0 is directly connected, FastEthernet1/0
R       10.2.2.0 [120/2] via 192.168.13.1, 00:00:06, FastEthernet0/0

設定ミスのまとめ

R2とR3での設定ミスをまとめたものが次の図です。

図 RIP 設定ミスの切り分けと修正 Part2 設定ミスのまとめ
図 RIP 設定ミスの切り分けと修正 Part2 設定ミスのまとめ


関連記事

IPルーティングのキホン