ip default-networkコマンドとは

ip default-networkコマンドによって、ルーティングテーブル上の特定のルートエントリに「*(Candidate default:デフォルト候補)」のコードをつけます。

ルーティングテーブルにデフォルトルート「0.0.0.0/0」を登録すると、自動的に「*」がつけられています。0.0/0/0/0というルート情報以外でも、「*」のコードをつけて、デフォルトルートのように扱うためのコマンドがip default-networkコマンドです。ただし、ip default-networkコマンドによって「*」のコードをつけられるのは、サブネッティングされていないクラスフルなルート情報のみです。

そして、RIPを利用しているときにip default-networkコマンドでデフォルトルート以外のルート情報に「*」をつけると、自動的にRIPでデフォルトルートをアドバタイズします。EIGRPを利用しているときには、ip default-networkコマンドでルート情報に「*」をつけると、ネイバーにも伝わっていきます。

OSPFではip default-networkコマンドで設定したデフォルトルート候補の情報は、他のルータには影響しません。

ip default-networkコマンドの設定例(RIP)

ネットワーク構成

以下のネットワーク構成でip default-networkコマンドの設定を行います。

図 ip default-networkコマンド 設定例
図 ip default-networkコマンド 設定例

初期設定

R1、R2の初期設定の抜粋は以下の通りです。

R1

interface Ethernet0/0
 ip address 192.168.1.1 255.255.255.0
!
interface Serial1/0
 ip address 192.168.2.1 255.255.255.0
!
!
router rip
 version 2
 network 192.168.1.0
 network 192.168.2.0

R2

interface Loopback0
 ip address 192.168.255.1 255.255.255.0
!
interface Ethernet0/0
 ip address 192.168.3.1 255.255.255.0
!
interface Serial1/0
 ip address 192.168.2.2 255.255.255.0
!
router rip
 version 2
 network 192.168.2.0
 network 192.168.3.0

R1-R2間でRIPv2を設定していますが、R2 Lo0ではRIPを有効にしていません。そのため、R1のルーティングテーブルにR2 Lo0のルート情報が登録されずに、通信できません。

R1

R1#show ip route
~省略~

Gateway of last resort is not set

C    192.168.1.0/24 is directly connected, Ethernet0/0
C    192.168.2.0/24 is directly connected, Serial1/0
R    192.168.3.0/24 [120/1] via 192.168.2.2, 00:00:11, Serial1/0
R1#ping 192.168.255.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.255.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

ip default-networkコマンドの設定と確認

R2でip default-networkコマンドで192.168.3.0/24のルート情報にデフォルトルート候補の「*」をつけます。

R2

ip default-network 192.168.3.0

そして、R2のルーティングテーブルを見ると、192.168.3.0/24のルート情報に「*」が付加されます。

R2

R2#show ip route
~省略~

Gateway of last resort is not set

C    192.168.255.0/24 is directly connected, Loopback0
R    192.168.1.0/24 [120/1] via 192.168.2.1, 00:00:22, Serial1/0
C    192.168.2.0/24 is directly connected, Serial1/0
C*   192.168.3.0/24 is directly connected, Ethernet0/0

R2で192.168.3.0/24に「*」をつけると、R2からR1へデフォルトルート0.0.0.0/0をアドバタイズします。R1のルーティングテーブルに0.0.0.0/0が登録されます。その結果、R1からR2 Loopback0への通信が可能になります。

R1

R1#show ip route
~省略~

Gateway of last resort is 192.168.2.2 to network 0.0.0.0

C    192.168.1.0/24 is directly connected, Ethernet0/0
C    192.168.2.0/24 is directly connected, Serial1/0
R    192.168.3.0/24 [120/1] via 192.168.2.2, 00:00:06, Serial1/0
R*   0.0.0.0/0 [120/1] via 192.168.2.2, 00:00:06, Serial1/0
R1#ping 192.168.255.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.255.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/60/64 ms

図 ip default-networkの設定(RIP)
図 ip default-networkの設定(RIP)

ip default-networkコマンドの設定例(EIGRP)

初期設定

同じネットワーク構成でルーティングプロトコルとしてEIGRPを利用している場合についてです。R1、R2の初期設定の抜粋は以下の通りです。

R1

interface Ethernet0/0
 ip address 192.168.1.1 255.255.255.0
!
interface Serial1/0
 ip address 192.168.2.1 255.255.255.0
!
!
router eigrp 1
 network 192.168.1.0
 network 192.168.2.0
 auto-summary

R2

interface Loopback0
 ip address 192.168.255.1 255.255.255.0
!
interface Ethernet0/0
 ip address 192.168.3.1 255.255.255.0
!
interface Serial1/0
 ip address 192.168.2.2 255.255.255.0
!
router eigrp 1
 network 192.168.2.0
 network 192.168.3.0
 auto-summary

R1-R2間でEIGRP AS1を設定していますが、R2 Lo0ではEIGRPを有効にしていません。そのため、R1のルーティングテーブルにR2 Lo0のルート情報が登録されずに、通信できません。

R1

R1#show ip route
~省略~

Gateway of last resort is not set

C    192.168.1.0/24 is directly connected, Ethernet0/0
C    192.168.2.0/24 is directly connected, Serial1/0
D    192.168.3.0/24 [90/2195456] via 192.168.2.2, 00:00:44, Serial1/0
R1#ping 192.168.255.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.255.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

ip default-networkコマンドの設定と確認

RIPを利用しているときと同じように、R2でip default-networkコマンドで192.168.3.0/24のルート情報にデフォルトルート候補の「*」をつけます。

R2

ip default-network 192.168.3.0

すると、R2のルーティングテーブル上の192.168.3.0/24のルート情報に「*」が付加されます。また、トポロジテーブルの192.168.3.0/24の詳細を見ると、Exterior flag is setと表示されます。

R2

R2#show ip route
~省略~

Gateway of last resort is not set

C    192.168.255.0/24 is directly connected, Loopback0
D    192.168.1.0/24 [90/2195456] via 192.168.2.1, 00:04:35, Serial1/0
C    192.168.2.0/24 is directly connected, Serial1/0
C*   192.168.3.0/24 is directly connected, Ethernet0/0
R2#show ip eigrp topology 192.168.3.0
IP-EIGRP (AS 1): Topology entry for 192.168.3.0/24
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 281600
  Routing Descriptor Blocks:
  0.0.0.0 (Ethernet0/0), from Connected, Send flag is 0x0
      Composite metric is (281600/0), Route is Internal
      Vector metric:
        Minimum bandwidth is 10000 Kbit
        Total delay is 1000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 0
      Exterior flag is set

R2からR1へ192.168.3.0/24をアドバタイズするときにExterior flagによってデフォルトルート候補であることを通知しています。そのため、R1のルーティングテーブルの192.168.3.0/24のルート情報に「*」が付加されます。デフォルトルート候補が存在するので、R1からR2 Lo0への通信が可能になります。

R1

R1#show ip route
~省略~

Gateway of last resort is 192.168.2.2 to network 192.168.3.0

C    192.168.1.0/24 is directly connected, Ethernet0/0
C    192.168.2.0/24 is directly connected, Serial1/0
D*   192.168.3.0/24 [90/2195456] via 192.168.2.2, 00:04:40, Serial1/0
R1#ping 192.168.255.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.255.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/60/64 ms

図 ip default-networkの設定(EIGRP)
図 ip default-networkの設定(EIGRP)

関連記事

IPルーティングのキホン

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

CAPTCHA